Uvodne napomene

Kontakt - prodaja i podrška:

Autor softvera i nosilac autorskih prava za GeoMIR5 i CAD modula za ActCAD.

Distributer softvera ActCAD za Europu.:

Miroslav Mareković

Rohrerweg 12 A

5163 Mattsee

Austrija

Telefon i Viber: +43 664 4887943

Info telefon HR: 097 6790743

PDV ID: ATU50274705

Najnovije o GeoMIR programskim rješenjima na službenim internet stranicama .

Kronologija razvoja dostupna je u Kronologija odjeljku.

Početnicima preporučamo odjeljak " Prvi kontakt sa softverom GeoMIR5 "

Copyright © 1998-2021 - geomir.software, vl. Miroslav Mareković. Sva prava pridržana.


Kronologija

Uvodne napomene ››

21.01.21.0 (GeoMIR5 5.2.0.89, CAD-Modul 1.0.21.0121)

GeoMIR*Desktop CAD modul - Novo

Učitavanje koordinata iz datoteke i iz GeoMIR predmeta - odabir alternativnog GeoMIR5 bloka za točke "19999-1", koji je pogodniji za crteže koji nisu vezani uz SDGE .

Vizualiziranje kote voda - omogućen je odabir, hoće li se prikazati linija razlomka visina ili ne.

GeoMIR*Desktop CAD modul - Ispravljeno

Povezivanje na SDGE sustav - kontrola kvalitete.

Usklađivanje sa promjenama unutar SDGE sustava.

Računanje kubatura iz reljefa učitanih iz LandXML datoteke.

20.09.03.0 (GeoMIR5 5.2.0.87, CAD-Modul 1.0.20.0903)

GeoMIR*Desktop CAD modul - Novo

Učitavanje DOF 2019 sa WMS servisa Geoportala.

Ispis koordinata točaka u datoteku - ubačena je opcija za 4 decimalna mjesta.

Predmetne čestice - omogućen unos predmetnih čestica njihovim brojevima, alternativno na odabir iz crteža.

Prepravljen i proširen formular za učitavanje točaka iz datoteke . Omogućeno je učitavanje točaka sa dvije visine, te ako se točke učitavaju u predložak SDGE, pojaviti će se formular za odabir vrste, stabilizacije i nastanka točke.

Crtanje profila - mogućnost prikaza vrijednosti visine i udaljenosti u milimetrima.

Ubacivanje simbola iz Zbirke na krajeve linijskih elemenata LWPOLYLINE i LINE.

Odjeljak DGE točke :

  • Izbačeni pojedinačne naredbe naredbe za mijenjanje podataka atributa - sve su svedene u jednu pod nazivom "Uređivanje atributa".
  • Naredba za stvaranje poligona iz postojećih blokova ili direktnim unosom.
  • CSV Napomena: podatak Napomena, koji je nevidljiv u bloku no pojaviti će se pri ispisu točaka u CSV i XLS datoteku.
  • Novi kod za nastanak točke: 91 = "Točka između dvije sigurno mjerene točke".
  • Stvaranje točaka - iz elementa 3DPOLYLINE preuzimaju se visine VERTEX-a.
  • Uređivanje atributa točaka - zaokruživanje atributa VISINA i VISINA_VODA na dvije decimale
  • Interpoliranje visina u atribute točaka (SDGE blok "tocke") na osnovu DMR-a
  • Prepoznavanje i unošenje visina u atribute točaka (SDGE blok "tocke") iz obližnjih TEXT/MTEXT elemenata
  • Multi-promjena položaja Broja točke i kote terena - Prvo se odaberu svi atributi kojima je potrebno promijeniti položaj, nakon čega se odredi pomak za PRVI odabrani atribut. Svi ostali atributi će biti pomaknuti za iste vrijednosti.

Odjeljak DGE Grafika :

  • Unos simbola zgrada X ili O iz šrafura

GeoMIR*Desktop CAD modul - Ispravljeno

Usklađivanje sa promjenama unutar SDGE sustava.

Preuzete slike sa geoportala biti će smještene u sloj "g5_geoportal".

Prilagođavanje radu unutar AutoCAD-a.

Učitavanje točaka iz GeoMIR predmeta i iz datoteke u 3D - mjerene točke se prikazuju starim blokovima "19999-1", jer su pogodniji za prikaz u 3D.

20.02.13.0 (GeoMIR5 5.2.0.87, CAD-Modul 1.0.20.0213)

GeoMIR*Desktop CAD modul - Novo

Prepravljen i proširen je način preuzimanja slike sa Geoportala . Novost je mogućnost odabira mape (direktorija) smještaja slika.

Predmetne čestice - pronalaženje susjednih kada se dodiruju samo jednom točkom.

Identifikacije ZK čestica -vizualiziranje brojeva ZK čestica u odnosu na razliku u površini između katastarskog i ZK stanja.

Izrada pisama i potpisnih lista - Pojam pravne osobe, u svrhu ispisa polja "Ime i prezime" i "Funkcija" u potpisne liste

Koso odmjeranje se upisuje u zaseban sloj "sit_kontrolna_odmjeranja_koso"

Blok za "Dogledanja (dogledanja)" se može insertirati iz izbornika "DGU Zbirka/Simboli - granice (09)"

Blok za "Pomoćnu položajnu točku (10401-1)" se može insertirati iz izbornika "DGU Zbirka/Simboli - granice (09)"

GeoMIR*Desktop CAD modul - Ispravljeno

Prebacivanje 2D u 3D - prekid rada naredbe u ZWCAD-u je otklonjen.

Koordinate popratne datoteke pri preuzimanju slike sa Geoportala su ispravljene.

Izrada pisama i potpisnih lista - otklanjanje pucanja rada u određenim situacijama i ispravljeno pronalaženje poštanskog broja iz naziva naselja.

Datumska transformacija koordinata - nije bilo moguće pristupiti transformiranim podacima u određenim situacijama.

Formular rezultata kontrole kvalitete je dotjeran i prilagođen promjenama u sustavu DGE.

Usklađivanje učitavanja GML datoteke sa promjenama u sustavu DGE.

19.11.12.0 (GeoMIR5 5.2.0.86, CAD-Modul 1.0.19.1112)

GeoMIR*Desktop CAD modul - Novo

Prepravljen i proširen je način preuzimanja slike sa Geoportala . Novost je mogućnost odabira razlučivosti slike te ispis u PNG datoteku.

GeoMIR*Desktop CAD modul - Ispravljeno

Loša kvaliteta slike preuzete sa Geoportala u nekim slučajevima

Učitavanje koordinata iz datoteke, kada je razdjelnik TAB

19.10.31.0 (GeoMIR5 5.2.0.84, CAD-Modul 1.0.19.1031)

GeoMIR*Desktop CAD modul - Novo

Promjena u izbornicima - "DKP-GML" je raspodijeljen u "DGE Grafika" i "DGE knjižno" .

Unos posjednika u MTEXT sa indikacijama i pomakom.

Uvođenje pojma predmetnih čestica kao podloge za razne odabire.

Izrada pisama i potpisne liste odabirom čestica - Sučelje za automatiziranu izradu pisama, primjerice poziva i potpisnih lista (Videinstrukcije: https://youtu.be/71gtCB757Wk )

Prepravljen i proširen je način preuzimanja slike sa Geoportala . Područje je sada moguće odrediti na dva načina (Videinstrukcije: https://youtu.be/Q30nM7msIFc ):

  1. direktnim unosom vrhova četverokuta - kao i do sada, no sada ne mora biti kvadrat već proizvoljni četverokut
  2. unosom poligona područja zahvata - softver će popuniti područje rasterom manjih kvadratičnih slika proizvoljne veličine.

Ispis DGE točaka u CSV datoteku - dodatni podaci za sve točke iz popisa i opcija za ispis bez podataka E0 i N0.

GeoMIR*Desktop CAD modul - Ispravljeno

Podizanje crteža iz 2D u 3D

Visina voda unosom dubine, kada je visina voda jednaka nuli umjesto prazna.

Prepravljena naredba za prenumeraciju DGU točaka.

Učitavanje točaka iz datoteke, kada se nalaze specijani karakteri tipa TAB.

Općenito

Napravljeni Toolbari sa GeoMIR naredbama.

19.09.03.0 (GeoMIR5 5.2.0.84, CAD-Modul 1.0.19.0903)

GeoMIR*Desktop CAD modul - Novo

Kontrola kvalitete crteža spajanjem na SDGE servis i detaljan prikaz rezultata kontrole u crtež u jednom koraku (Videinstrukcije: https://youtu.be/RP7Y1dVg8cc )

Zakretanje crteža u Layoutu prema unosu referentnih točaka uz zakretanje simbola za sjever.

Podaci kućnih brojeva - odabir postojećeg kućnog broja i pohrana atributa Šifra ulice (S_U) i Šifra naselja (S_N) za unos novih

GeoMIR*Desktop CAD modul - Ispravljeno

Usklađivanje učitavanja GML datoteke sa promjenama u sustavu.

Usklađivanje predloška G5_DGE19.DWT sa promjenama u sustavu.

Posjedovni list za KČ - usklađeno sa strukturom GML-a i službenim izgledom ispisa.

Prijavni list za katastar - popis posjednika se sortira prema broju posjedovnog lista

Prijavni list za katastar - veza sa ZK česticama i ulošcima

Odabir grafičkog prikaza - preuzima se posljednji datum unosa umjesto trenutnog.

Prikazivanje formulara - provjera vidljivosti, ako su "zapeli" na trenutno nedostupnom zaslonu.

Unos bloka kućnog broja - pri unosu određuje se zakret, koji se potom upisuje u blok, zajedno sa pohranjenim Šifra ulice (S_U) i Šifra naselja (S_N) atributima.

19.06.29.0 (GeoMIR5 5.2.0.84, CAD-Modul 1.0.19.0629)

GeoMIR5 - Ispravljeno:

Izjednačenje slobodne mreže - unos podataka ručno i specijalni slučajevi izjednačenja

Učitavanje LandXML datoteke s mjerenim podacima - nadopunjeno

GeoMIR*Desktop CAD modul - Novo

Učitavanje DOF2018 sa WMS servisa Geoportala.

Zamjena vrijednosti BROJ <-> BROJ_U_ELABORATU u bloku "tocke".

Vizualiziranje kote terena+voda odabirom bloka "tocka" sa kotom terena i unosom dubine voda.

GeoMIR*Desktop CAD modul - Ispravljeno

Usklađivanje učitavanja GML datoteke sa promjenama u sustavu.

Prerađen je predložak G5_DGE19.DWT kako se izbjegla pogreška „Učitani DXF ima pogrešan CODEPAGE (mora biti ANSI_1250)“.

Kosa odmjeranja se crtaju u sloj "sit_kontrolna_odmjeranja_koso".

Općenito

Instalacija GeoMIR*Desktop podržava nedavno objavljene ActCAD 2020 i ZWCAD 2020

19.05.07.0 (GeoMIR5 5.2.0.82, CAD-Modul 1.0.19.0507)

GeoMIR*Desktop CAD modul - Novo

Naredbe za unos broja ZK i KT čestica, uz još neke varijante.

Prikaz brojeva ZK čestica prema Tehničkim specifikacijama za geodetske elaborate.

GeoMIR*Desktop CAD modul - Ispravljeno

Iskaz površina - ispravna površina ispod PMP-a.

19.04.05.0 (GeoMIR5 5.2.0.82, CAD-Modul 1.0.19.0405)

GeoMIR*Desktop CAD modul - Novo

Izrada bokocrta iz situacije - idealno za prikaz pročelja zgrade, mosta te ostalih građevina.

Urešivanje atributa DGE točaka - jedna naredba koja obuhvaća razne unose i ažuriranja atributa točaka

Brisanje elemenata crteža određene Katastarske općine .

GeoMIR*Desktop CAD modul - Ispravljeno

Ispis DGE točaka u CSV - ispisati samo točke za održavanje, odabir kvačicom.

Razna "nevidljiva" poboljšanja i usklađenja.

Identifikacije ZK čestica - ispis glavne knjige.

19.02.01.0 (GeoMIR5 5.2.0.82, CAD-Modul 1.0.19.0201)

GeoMIR5 - Ispravljeno:

Računanje detaljnih točaka - odabir grupe točaka za stajalište

Formula za dozvoljena odstupanja pri računanju vlakova

GeoMIR*Desktop CAD modul - Novo

DGE Točke : - vizualiziranje kota terena iz DGE točaka blokom "80101-1" u sloju "vsit_kote". Visina mora biti sadržana u atributu "VISINA" DGE točke.

Crtanje linijskih objekata - prikazivanje simbolima umjesto tipom linije

Identifikacije ZK čestica odabirom katastarskih čestica iz crteža a na temelju knjižnih podataka iz GML-a. Ispis je u Excel datoteku i MTEXT uz broj čestice.

Naredba za uključivanje 'ON' svih slojeva - naredba uključuje (ne odmrzava) sve slojeve i postavlja sloj '0' kao trenutni

Tema kodiranja prema specifikacijama za SDGE je postavljena na internet stranice

GeoMIR*Desktop CAD modul - Ispravljeno

Učitavanje GML datoteka - usklađenje sa novim formatima GML datoteka

Izrada prijavnog lista - Nove opcije pri stvaranju novog stanja za prijavu .

Ispis prijavnog lista i iskaza površina u Excel - ponovo uveden predložak u A3 formatu te prijave bez novog stanja.

Popis posjednika - ispravljen ispis djelova čestica.

Određivanje predložaka za Word i Excel - prošireno za nove predloške. Napomena - predlošcima za Excel (prijavni list i iskaz površina) su promjenjena imena, te će ih biti potrebno ovom naredbom redefinirati.

Naredba za vidljivost slojeva prema grafičkom prikazu je prepravljena.

Izrada skice mreže prema Zbirci kartografskih znakova - kada je za računanje mreže korišten GeoMIR5.

Određene promjere u predlošku (Drawing template) .

18.11.04.0 (GeoMIR5 5.2.0.80, CAD-Modul 1.0.18.1103)

GeoMIR*Desktop CAD modul - Novo

DGE Točke :

- prihvaćanje DKP točaka: prebacivanje u zamijenjeno i stvaranje u novo s istim atributima

- ažuriranje koordinata točaka u atributima, odnosno brisanje po želji ako je nastanak "1" ili "2"

- brisanje visine terena

- slojevi, tipovi linija i multilinija za vodove u predlošku

- određivanje točaka voda, odabirom točaka ili polilinije koja ih povezuje

- detektirane točke voda - odabirom dvije DT

- detektirane točke voda - dubinom voda

- detektirane točke voda - automatski

Ispis načina uporabe čestice u blok

GeoMIR*Desktop CAD modul - Ispravljeno

Učitavanje GML datoteka - usklađenje sa novim formatima GML datoteka

Stvaranje kopije linijskih objekata - potrebno za izradu po tehn.spec. SDGE, kada je situacija istovremeno dio DKP-a

Signature - tip linije u simbole - ubačene su neke nove definicije linijskih elemenata

Prilagodbe specifične za ZWCAD

18.10.08.0 (GeoMIR5 5.2.0.80, CAD-Modul 1.0.18.1008)

G5 modul za ActCAD - Novo

Priprema za plotanje (popunjavanje varijabli iz knjižnih podataka, izoliranje slojeva, zoom u omjeru) iz layouta prema grafičkom prikazu

Učitavanje DOF 2017 sa Geoportala

Odmrzavanje/zamrzavanje slojeva ovisno o željenom grafičkom prikazu

Preračunavanje geometrije elemenata na CM - LINE, LWPOLYLINE i BLOCK-INSERT elemenata crteža

G5 modul za ActCAD - Ispravljeno

Učitavanje GML datoteka - usklađenje sa novim formatima GML datoteka

Učitavanje točaka (iz GeoMIR5 predmeta ili datoteke ) u SDGE okruženju, učitane točke se učitavaju prema propisima u blok "tocke"

Unos centroida za vrste zgrada i načina korištenja zemljišta - upotpunjeni podaci

Ispis posjedovnog lista u Word

18.09.23.0 (GeoMIR5 5.2.0.80, CAD-Modul 1.0.18.0923)

G5 modul za ActCAD - Novo

Provjera sadržaja - još u razvoju, biti će interna kontrola kvalitete

Automatsko stvaranje DXF datoteke za SDGE

Dijeljenje linije pomoću druge linije na dvije decimale

Pretvaranje odabranih LWPOLYLINE elemenata u LINE

Crtanje na CM , čak i pri prostoručnom crtanju

G5 modul za ActCAD - Ispravljeno:

Učitavanje GML-a - došlo je do promjena u organizaciji podataka

Izrada prijavnog lista - usaglašeno sa predloškom SDGE

Stvaranje DGU točaka - pamti se posljednji korišten broj točke

Vidljivost slojeva - tematski

Promjena atributa DGU točkama

Promjena slojeva LINE elementima, do sada je bilo moguće samo LWPOLYLINE elementima

Novi slojevi za promjene

Popravke i poboljšanja na predlošku (template)

18.09.13.0 (GeoMIR5 5.2.0.80, CAD-Modul 1.0.18.0912)

GeoMIR5 - Ispravljeno:

Određivanje tipa linije za linijske objekte teme kodiranja

Novi format zapisa instrumenata "LandXML" - standard koji koristi sve više proizvođača instrumenata

Manje promjene prema potrebama Austrijskog tržišta

G5 modul za ActCAD - Novo

Prilagodba tehničkim specifikacijama za izradu digitalnog katastarskog elaborata

Izrada prijavnog lista samo sa podacima starog stanja

Učitavanje DGU točaka iz CSV datoteke

Promjena slojeva odabranim elementima crteža

G5 modul za ActCAD - Ispravljeno:

Unos novih DGU točaka (blok "tocke") u crtež

Učitavanje GML-a cijele katastarske općine

Izrada DMR-a, ispravljena pogreška prikaza 3D linija

Manje popravke i poboljšanja

18.01.25.0 (GeoMIR5 5.2.0.71, CAD-Modul 1.0.18.0502)

G5 modul za ActCAD - Novo

Izrada prijavnog lista i iskaza površina

Ispis posjednika i uporabe u MTEXT u jednom koraku naredbom "Posjednici i uporaba KČ u MTEXT"

G5 modul za ActCAD - Ispravljeno:

Raspored padajućih izbornika - ispis DGU točaka je prebačen u izbornik "DGU Točke"

17.12.27.0 (GeoMIR5 5.2.0.71, CAD-Modul 1.0.17.1227)

GeoMIR5 - Ispravljeno:

Prikaz K obrasca pri slijepim visinskim vlakovima

Manje interne ispravke

G5 modul za ActCAD - Novo:

Prikaz površina iz GML-a (atributna i grafička) za odabrane kat. čestice

Pretvaranje SVIH brojeva čestica iz DKP "kc" blokova u MTEXT prema Zbirci iz 2011

Apscisno odmjeranje

G5 modul za ActCAD - Ispravljeno i/ili prerađeno:

Prerađen formular "Geoportal DGU" - nove opcije su preuzimanje DOF 2014/16, te pristup vjerodajnicom

Učitavanje GML datoteka - napravljena opcija za učitavanje GML-a u postojeće stanje

Izgled detaljnih i DGU točaka - bolja integracija za olakšavanje crtanja

Prenumeracija DGU točaka

Učitavanje GML datoteka - provjera ispravnosti GML datoteka

17.10.15.0 (GeoMIR5 5.2.0.66, CAD-Modul 1.0.17.1015)

G5 modul za ActCAD - Ispravljeno:

Manje interne ispravke

17.09.03.0 (GeoMIR5 5.2.0.66, CAD-Modul 1.0.17.0903)

GeoMIR5 - Ispravljeno:

Manje interne ispravke.

G5 modul za ActCAD - Ispravljeno:

Ispuna zgrada prema Zbirci kartografskih znakova - neke boje su ispravljene.

Definiranje i iscrtavanje profila - u nekim posebnim slučajevima dolazilo je do prekida izvršavanja.

17.08.10.0 (GeoMIR5 5.2.0.65, CAD-Modul 1.0.17.0810)

GeoMIR5 - Novo:

Kodirani objekti - ispis koda objekta u atribut simbola

G5 modul za ActCAD - Novo:

Parametri ispisa u GML datoteke

Izoliranje novih GML podataka - priprema za ispis u GML datoteke

Ispis DGU točaka u GML datoteku

Izrada okvira - prerada formulara za izradu okvira

Prikaz detaljnih listova - elementima LWPOLYLINE i TEXT u zasebnom sloju

G5 modul za ActCAD - Ispravljeno:

Ispis DGU točaka u Excel - decimalna točka pri ispisu koordinata, neovisno o postavkama računala

Općenito

Instalacija GeoMIR*Desktop podržava najnoviju verziju ActCAD-a 2018 8.4

17.06.12.0 (GeoMIR5 5.2.0.64, CAD-Modul 1.0.17.0612)

GeoMIR5 - Novo:

Učitavanje koordinata - maska za točke s dvije visine

Grupiranje detaljnih točaka - grupiranje kodovima

Visina H2 detaljnih točaka direktnim unosom visinske razlike

Mjerilo 1:750 pri stvaranju objekata iz kodova

G5 modul za ActCAD - Novo:

MS Office povezivanje - izrada popisa posjednika i ispis DGU točaka

Izrada šrafura ispunjenja zgrada

Promjene na atributima blokova - vidljivost, visina teksta, boja, sadržaj atributa u tekst

Linijski objekti - signature (zid, ograda) - tip linije u simbole: popratni simboli umjesto tipova linija

DGU Zbirka / Linije - građevine : suhozidi, uski i široki

DGU Zbirka / Simboli - građevine : ulaz

G5 modul za ActCAD - Ispravljeno:

Učitavanje koordinata iz G5 predmeta - točke sa dvije visine

Visine raznih tekstova, prema savjetima korisnika

Boje šrafura ispunjenja zgrada

Slojnice - pretvaranje u Spline elemente

Općenito

"Datoteke za lakši početak" pri instalaciji - novi predmet i tema kodiranja "DKP1000"

17.05.03.0 (GeoMIR5 5.2.0.62, CAD-Modul 1.0.17.0503)

GeoMIR5 - Ispravljeno:

Smrzavanje programa pri ubacivanje točaka iz međuspremnika i iz ActCAD-a:

G5 modul za ActCAD - Novo:

Dvije DT -> jedna DT s dvije visine

DKP - Vrsta uporabe katastarske čestice

Odabir elemenata crteža prethodnim označavanjem (PICKFIRST) pri nekim naredbama

G5 modul za ActCAD - Ispravljeno:

Učitavanje ZIP GML datoteke - prepoznavanje posjednika čestica

Ispis DGU točaka - ispis visine voda ( druge visine )

Ispis točaka u datoteku - ispis visine voda ( druge visine )

Raspoznavanje atributa - vrijednost najniže moguće nadmorske visine

Općenito

Unaprijeđen postupak instalacije

03.04.2017 (GeoMIR5 5.2.0.60, CAD-Modul 1.0.17.0403)

GeoMIR5 - Novo:

Povezivanje grupe izvještaja u jedan

G5 modul za ActCAD - Novo:

Digitalni katastarski plan (DKP) kao osnova za izradu grafičkog djela Geodetskog projekta - ugrađene su sve naredbe i predlošci kako bi se pojednostavilo i ubrzalo crtanje elaborata prema strukturi DKP-a.

Jedinice za skaliranje insertiranih elemenata - Metri, centimetri, milimetri...ActCAD nema taj parametar unutar UNITS naredbe

G5 modul za ActCAD - Ispravljeno:

Stvaranje DGU točaka - način stvaranja točaka je prepravljen (sloj atributa i unos početnog broja)

Raspored padajućih izbornika

Izdanje 5.2.0.57 od 01.03.2017

GeoMIR5 - Ispravljeno:

Pristup datoteci za pomoć

Manja interna poboljšanja

G5 modul za ActCAD - Novo:

Učitavanje slike (DOF, HOK, TK25) direktno sa Geoportala

Učitavanje posjednika iz GML datoteke odabirom broja čestice

Ubacivanje broja indikacije

Ubacivanje znakova pripadnosti i poništenja u crtež

Smjer nitnog križa (crosshair) prema odabranom elementu

Spajanje elemenata na odabranu poliliniju

Boja atributa broja točke

Frontovi odabirom grafičkih elemenata - linije i polylinije

Pozivanje "Uputa za rad" kroz izbornik GeoMIR

Novo mjerilo 1:750

G5 modul za ActCAD - Ispravljeno:

Stvaranje DGU točaka - način stvaranja točaka je prepravljen (sloj atributa i unos početnog broja)

Ispravljeno crtanje nasipa i pokosa s rapoznatljivim dnom

Raspored padajućih izbornika

Izdanje 5.2.0.55 od 26.01.2017

GeoMIR5 - Ispravljeno:

Manja interna poboljšanja

Novi format zapisa totalne stanice - Stonex R2L+ (MES)

G5 modul za ActCAD - Novo:

Napravljene inačice modula za ActCAD 2017 - 32bit i 64bit

Zamjena blokova istima - poboljšana verzija ATTREDEF naredbe

Stvaranje predloška iz trenutnog crteža

Ispis točaka u datoteku - moguće je odrediti graničnik (znak koji odvaja stupce)

Prikaz dvostruke visine točaka vodova

Prikaz visinske skale kod profila

G5 modul za ActCAD - Ispravljeno:

Kodirani objekti - spajanje sa prvom točkom - ispravljeno

Kodirani objekti - prikaz tipova linija pri iscrtavanju polilinija - ispravljeno

Izdanje 5.1.0.54 od 30.11.2016

GeoMIR5 - Novo:

Dvije nove varijable svojstva programa : broj decimala za ispis površina u izvještajima i broj decimala za ispis kodiranih objekata u DWG

GeoMIR5 - Ispravljeno:

Stvaranje kodiranih objekata - odabir prema brojevima točaka

G5 modul za ActCAD - Novo:

Učitavanje točaka iz datoteke

Izrada DXF datoteke za DXF2GML konverter

G5 modul za ActCAD - Ispravljeno:

Sučelje za učitavanje koordinata iz GeoMIR5 predmeta je prerađeno

Izdanje od 10.11.2016

G5 modul za ActCAD - Novo:

Podizanje 2D crteža u 3D

G5 modul za ActCAD - Popravljeno:

Izrada slojnica iz DMR-a - vrsta polilinije te mogućnost unosa ekvidistance manje od 1 metra

Ispis DGU točaka u CSV datoteku - sučelje i sortiranje točaka

Izdanje 5.1.0.51 od 18.10.2016

GeoMIR5 - Novo:

Preuzimanje izvještaja iz nekog drugog predmeta

Ispis sumarnog izvješća računanja površina u CSV datoteku

Računanje površina - kopiranje/zaljepi u formularu za unos točaka

GeoMIR5 - Popravljeno:

Preuzimanje podataka iz nekog drugog predmeta - sučelje je prerađeno

Importiranje predmeta

Nekoliko manjih internih popravaka

G5 modul za ActCAD - Novo:

Prenumeracija DGU točaka - sljedeći poliliniju

Izdanje 5.1.0.47 od 03.10.2016

GeoMIR5 - Popravljeno:

Ispis točaka geodetske osnove pri stvaranju objekata

Čitanje/pisanje internog G5 XML formata

Datumska transformacija koordinata - prikaz dodatnih parametara, sintaksa poput G5 modula za ActCAD

Nekoliko manjih internih popravaka

G5 modul za ActCAD - Novo:

Analitičko računanje površina - CAD priprema za računanje u GeoMIR5 softveru

Pretvaranje Polylinija -> Linija + Pika

Ispis u DGU GML format (još u fazi izrade)

Kompatibilnost DMR-a s LandXML formatom (Civil 3D)

Promjena smjera polilinije

Poliliniju na pregibu prekinuti

Element na točci prekinuti

G5 modul za ActCAD - Popravljeno:

Stvaranje DGU točaka - iz izbora elemenata i dodatne opcije

Stvaranje objekata - linetype scale

Ispis koordinata u datoteku, preuređeno

Općenito

Upotpunjeni popis homogenih polja s parametrima transformacije

Izdanje 5.1.0.41 od 04.07.2016

GeoMIR5 - Novo:

Obrada detaljnih točaka

Grupiranje dvije DT u jednu s dvije visine

Izvještaji

Označavanje svih izvještaja u popisu

Traženje teksta unutar izvještaja

Tahimetrijski zapisnik

Nova vrsta izvještaja

GeoMIR5 - Popravljeno:

Novi formati instrumenata

Leica FlexLine TS06-09

Sokkia SDR33 - Code -> Info

Novi formati učitavanja koordinata

BrojT, Y, X, H, Kod

BrojT, Y, X, H, Kod, Info1, Info2

BrojT, Y, X, H, Kod->Info

Izrada objekata iz kodova

Ispis svih objekata na 3 decimale

Učitavanje podataka instrumenta i koordinata

Najveći postojeći broj DT je vidljiv i uzima u obzir točke iz svih tablica

ENTER pokreće TAB, radi kako treba

Nekoliko manjih popravaka prema željama korisnika

G5 modul za ActCAD - Novo:

Računanje kubature između dva reljefa

Stvaranje novih točaka, izborom elemenata crteža

Točke prema šifrarniku DGU: stvaranje, obrada i ispis u CSV

Crtanje prema DGU zbirci: predložak sa svim simbolima, crtanje linija itd.

Ostalo:

Uputstvo je nadopunjeno i prerađeno, nekoliko najvećih promjena:

Detaljno objašnjenje kodiranog mjerenja uz primjere

Detaljno objašnjen G5 modul za ActCAD

Radionica o izradi DMR-a, profila i kubatura unutar ActCAD-a

Uveden digitalni potpis svih datoteka - Code Signing Certificate

Izdanje 5.0.0.36 od 09.09.2015

Novo:

G4CAD/GeoMIR - datumska transformacija cijelog crteža

Ispis točaka geodetske osnove u G4KOR datoteku - radi kompatibilnosti

Popravljeno:

Nekoliko manjih nedostataka

Izdanje 5.0.0.34 od 16.09.2014

Novo:

Podrška formata zapisa Trimble M5

Popravljeno:

Stvaranje objekata iz kodova prema broju točke - pamćenje posljednjeg unosa

Nekoliko manjih nedostataka

Izdanje 5.0.0.33 od 14.06.2014

Početna verzija softvera GeoMIR5

Promjena u odnosu na GeoMIR4 ima vrlo mnogo i iako su ikone promijenjene, ostao je prepoznatljiv način rada s programom. U pozadini i dalje radi aktivna baza podataka, doduše sada nešto modernija. Mnogo nevidljivih promijena na "unutarnjim organima" nema niti potrebe nabrajati, dovoljno je napomenuti da se ne radi samo o jednostavnom faceliftingu.

Primjerice, večina postavki, koje nisu u bazi podataka, pohranjuju se u XML datoteke. Na taj način je riješen problem prikazivanja naziva predmeta sa hrvatskim znakovljem. Također, XML je preuzet kao izvorni format zapisa.

Prebacivanje točaka TGO <-> DT u istom ili neki drugi predmet može se provesti korištenjem međuspremnika, dovoljna su sva klika mišem.

No na sljedeće promjene želimo posebno skrenuti pažnju:

Ugradnja novog matematičkog modela, popularnog naziva izjednačenje mreža , kao nadogradnja na postojeće računske operacije. Sve računske operacije koje su bile u GeoMIR4 ostaju, no novi matematički model je njihova nadogradnja. Jednostavno rečeno - stare računske operacije mogu se smatrati kao približno računanje a novi matematički model kao završni računski korak.

Jedan od podataka koje se dobije novim matematičkim modelom je 95% elipsa razine povjerenja, koji zamjenjuje stari koncept maksimalnog dozvoljenog odstupanja.

Potpuna ugradnja koordinatnog sustava HTRS96/TM u GeoMIR5. Iako je unutar softvera GeoMIR4 bila ugrađena korekcija mjerene duljne, GeoMIR5 nudi korisnicima mogučnost međudatumske transformacije koordinata između sustava HTRS96/TM <-> HSKS. Osim transformacija korodinata, ugađena je i nova podjela na detaljne listove. Najlakši način za saznati na kojem detaljnom listu se nalazi neka točka geodetske osnove je označiti je prilikom obrade TGO te pritiskom na desnu tipku miša prikazati informacije o toŤčci .

Preuzimanje podataka iz programa GeoMIR4 vrlo je jednostavno te u dodatku E ovog uputstva detaljno objašnjeno. Teme kodiranja, korisnički formati zapisa, zajedničke koordinate točaka geodetske osnove te predlošci za teme kodiranja prebacuju se bez gubitaka takoreći u jednom potezu. Kako GeoMIR5 podržava završno osiguranje programa GeoMIR4, moguće je po potrebi prebaciti i predmete.


Vrste programa i licenciranje

Uvodne napomene ››

Komercijalna verzija GeoMIR5Pro licencira se isključivo harverskim ključem.

Hardverski ključ je svakako najbolji način licenciranja programa jer pruža određenu slobodu korištenja te nije vezano uz pojedino računalo. Jedini nedostatak je nešto duže vrijeme isporuke, no to rješavamo izdavanjem softverske licence na neko određeno vijeme do dostave hardverskog ključa.

Hardverski ključevi su USB vrste i ne zahtjevaju nikakve dodatne instalacije. Hardverski ključ je uključen u cijenu programa.

GeoMIR5Free je besplatna verzija programa koja je sama po sebi legalna i nije potrebna nikakva dodatna registracija ili licenciranje. Zamišljena ja kao dodatak na komercijalnu verziju, a ne omogućava računanja, već samo učitavanje i obradu podataka.


GeoMIR5 mape ( direktoriji )

Uvodne napomene ››

Točni nazivi mapa ovise o instalaciji, no ovdje su prikazane najčešće vrijednosti.

"Instalacijska mapa" je obvezna dok "Mapa predmeta" može biti po želji instalirana

odabirom instalacije "Datoteka za lakši početak".

C:\Program Files(x86)\GeoMIR5 – „Instalacijska mapa“

Sadrži programske datoteke te ostale datoteke potrebne za rad programa. Primjer:

GeoMIR5.exe

GeoMIR5.chm

G4_Surv.dll

i mnoge druge

C:\G5_DB – „Mapa predmeta“ (= baze podataka)

Isključivo za direktan pristup softverom GeoMIR5!

Instalira se uključivanjem opcije "Datoteke za lakši početak" tijekom instalacije.

Sadrži korisničke podatke – SVE predmete pojedinačno te zajedničke podatke. Savjetuje se redovita pohrana i osiguravanje cijele „Mape predmeta“. Nadalje, sve datoteke i mape unutar „Mape predmeta“ predviđene i organizirane su isključivo za direktan pristup softverom GeoMIR5 – svako mijenjanje datoteka ili strukture može dovesti do gubitaka podataka!

Za napredne korisnike: postavljanjem "Mape predmeta" na mrežni disk, omogućava se višekorisnički rad.

Primjer sadržaja "Mape predmeta":

COMMONDB.ABS - zajednička baza podataka

projects.xml - predmeti

*.G5T - teme kodiranja

COMMON.g5_udf - korisnički formati zapisa

000002 - mapa s podacima pojedinog predmeta

000002.ABS - baza podataka predmeta

000002.INI - pomoćna datoteka baze predmeta

000005 - mapa s podacima pojedinog predmeta

000005.ABS - baza podataka predmeta

000005.INI - pomoćna datoteka baze predmeta

000007 - mapa s podacima pojedinog predmeta

000007.ABS - baza podataka predmeta

000007.INI - pomoćna datoteka baze predmeta

Radna mapa

Radna mapa vezana je uz pojedini predmet a služi za početno postavljanje pri izboru datoteka, primjerice pri učitavanju mjerenih podataka ili koordinata.


Način pohrane i organizacija podataka

Uvodne napomene ››

GeoMIR5 organizira podatke po "Predmetima". Termin "Predmet" je odabran jer ima tradiciju u geodeziji, termini "Projekt" ili "Radni zadatak" također odgovaraju. Nema direktne veze s Predmetima prema definiciji DGU-e.

Bez obzira treba li stvoriti crtež iz nekoliko točaka snimljenih RTK kinematikom ili iz složenog sustava mjerenja različitim metodama, uvijek je potrebno stvoriti odgovarajući "Predmet"! Slikovito rečeno, svaki novi predmet je kao prazna bilježnica koja sadrži unaprijed definirane tablice, spremne za unošenje podataka.

Podatke učitane u tablice moguće je mijenjati i obrisati te ručno unositi nove.

Tablice podataka mjerenja

( Pohrana podataka odvija se prema redosljedu učitavanja, pregledno prikazanih formularom „Stajališta“ ):

Tahimetrijski podaci

Girusni podaci

Ortogonalni podaci

Nivelmanski podaci

Tablice s koordinatama točaka

Unos može biti direktan ili kao rezultat računanja. Za razliku od većine geodetskih softvera, GeoMIR5 razdvaja detaljne točke od točaka geodetske osnove.

( Podaci su indeksirani brojem točke, što znači kako dvije točke s istim brojem ne mogu postojati u tablici ):

Točke geodetske osnove

Detaljne točke

Tablica s izvještajima

( pohrana podataka prema redosljedu računanja ):

Tablica sa svojstvima predmeta


Kratice i rezervirane riječi

Uvodne napomene ››

U ovom uputstvu te u programu pojavljuju se određene kratice. Objašnjenja:

  • TGO: Točke geodetske osnove
  • DT: Detaljne točke
  • ORI: orijentacije (Vizure) na točke geodetske osnove

Pri unosu podataka GeoMIR5 sam vodi računa o sintaksi, tj. smije li određeni znak biti unesen ili ne. Ipak kratak pregled:

•Znakovi koji utječu na rad programa: "/", "*", "<", ">"

•Brojevi točaka: velika slova, brojevi te znakovi "_", " ", ".", "-"

•Kodovi: velika slova i brojevi

•Teme kodiranja: velika i mala slova, brojevi te znakovi "_", " ", "-"

•Datoteke: određeno sistemom, izbjegavati hrvatska slova

Postoje samo tri rezervirane oznake za kodove i one se ne bi smjele koristiti u druge svrhe jer bi moglo utjecati na rad programa:

•kod "00" ( dvostruka nula ): opažanje na TGO

•kod "__" ( dvostruka potcrta ): kontrolni nulti pravac

•kod "//" ( dvostruki znak kroz ): opažanja na TGO nakon izrade girusa iz tahimetrije

U izvještajima su radi boljeg rapoznavanja, detaljne točke označene predznakom "*" a bez predznaka su točke geodetske osnove.


Koordinatni sustavi

Uvodne napomene ››

Svaki GeoMIR5 predmet mora imati određen koordinatni sustav, jedan od:

  • WGS84

odabrati kada se koriste lokalne koordinate koje nisu vezane uz jedan od službenih koordinatnih sustava. U svojstvima predmeta potrebno je podesiti Korekcije mjerene duljine na Isključeno.

  • HTRS96/TM ( EPSG 3765 )

Službeni koordinatni sustav za Republiku Hrvatsku. U svrhu ispravnog računanja korekcija mjerenih duljina, u svojstvima predmeta potrebno je podesiti:

Korekcije mjerene duljine/Nivo ploha mora -> Državni sustav.

Korekcije mjerene duljine/Linearno mjerilo -> Državni sustav.

Ne sadrži dodatne parametre.

  • HDKS Z5 ( HDKS zona 5 )

Stari koordinatni sustav za Republiku Hrvatsku, zona 5. U svrhu ispravnog računanja korekcija mjerenih duljina, u svojstvima predmeta potrebno je podesiti:

Korekcije mjerene duljine/Nivo ploha mora -> Državni sustav.

Korekcije mjerene duljine/Linearno mjerilo -> Državni sustav.

Dodatni parametri:

GRID - jedinstveni parametri transformacije uz popravku distorzije ( poput T7D )

1015..1390 - službeni parametri transformacije za homogena polja

  • HDKS Z6 ( HDKS zona 6 )

Stari koordinatni sustav za Republiku Hrvatsku, zona 6. U svrhu ispravnog računanja korekcija mjerenih duljina, u svojstvima predmeta potrebno je podesiti:

Korekcije mjerene duljine/Nivo ploha mora -> Državni sustav.

Korekcije mjerene duljine/Linearno mjerilo -> Državni sustav.

Dodatni parametri:

GRID - jedinstveni parametri transformacije uz popravku distorzije ( poput T7D )

1015..1390 - službeni parametri transformacije za homogena polja

Međudatumska transformacija omogučava HTRS96/TM<->HDKS preračunavanje koordinata korištenjem jednog od modela:

- jedinstveni parametri transformacije uz popravku distrozije ( poput T7D )

- službeni parametri transformacije za homogena polja

Koordinate mogu biti transformirane u oba smjera.


Instalacija

Pri instaliranju:

Prilikom instaliranja programa potrebna su administratorska prava. Na taj način slijedi GeoMIR5 savjete i preporuke vezane uz sigurnost podataka na računalima.

Sve instalacije vezane uz GeoMIR5 ne pohranjuju niti jednu datoteku u sistemske mape operativnog sistema, ne mijenjaju ili unose vrijednosti u Registry nego isključivo koriste korisnički izabrane mape.

Pri radu:

Tjekom rada GeoMIR5 koristi:

• mapu predmeta

•korisničnu mapu {CurrentUser/ApplicationData}\GeoMIR5

•korisničnu mapu {CommonFiles}\GeoMIR5

•registry {CurrentUser/Software/}geomir.org\GeoMIR5

Potrebno je voditi računa o pravima za GeoMIR5 mape - Programska mapa i mapa predmeta zahtjevaju pune privilegije za čitanje i pisanje. Ovo je posebno bitno za korisnike Windows Vista operativnog sustava jer u istome korisnik nije "po defaultu" administrator sa svim pravima.

Nakon instalacije GeoMIR5 radi kao besplatna verzija GeoMIR5Free. Kako bi upoznavanje sa softverom bilo što kvalitetnije, svaki korisnik GeoMIR5Free verzije ima pravo na 20-o dnevnu probnu licencu koja otvara sve mogučnosti programa.

Dodjeljivanje probne licence je automatizirano i anonimno a jedino što je potrebno jest veza sa internetom.

Pri deinstalaciji:

Deinstalacija uklanja s računala sve datoteke sadržane instalacijom programa. Mapa s predmetima neće biti deinstalirana te je nju potrebno ručno obrisati.

Tijek instalacije:

1 – instalacija softvera ActCAD . Savjetuje se preuzimanje instalacijske datoteke sa www.geomir.org internet stranice

2 – instalacija softvera GeoMIR5, tijekom koje će biti instaliran CAD modul za ActCAD .


Korak 1 od 2 : Instalacija softvera ActCAD

Instalacija ››

Preporuča se instalacija 64-bitne inačice softvera ActCAD na sva 64-bitna računala.

Za pokretanje instalacije potrebna su administratorska prava. Instalacija i softver su na engleskom jeziku. Nakon pokretanja, instalacija provjerava postoje li sistemske datoteke potrebne za rad, te ako ne, instalira ih. Nakon nekog vremena pokreće se instalacija samog softvera pri čemu je nakon početnog formulara potrebno prihvatiti uvjete licenciranja. Slijedi izbor jednog od tri tipa instalacije:

"Typical": tipična instalacija, skoro sve se instalira, povezuju se DWG i DXF datoteke sa ActCAD-om.

"Custom": korisnička, moguće je odrediti što instalirati a što ne.

"Complete": potpuna, instaliraju se sve datoteke i povezuju se DWG i DXF datoteke sa ActCAD-om.

Nakon izbora slijedi instalacija softvera.

Pri prvom pokretanju softvera potrebno je izvršiti aktivaciju softvera. Ako trenutni Windows korisnički profil nema administratorska prava, potrebno je na ikonu ActCAD-a kliknuti desnom tipkom miša te "Pokrenuti kao administrator/Run as administrator".

Korisnici koji žele isprobati softver, moraju odabrati opciju "Activate trial". Na taj način se ActCAD aktivira na 15 dana.

Korisnici koji posjeduju licencni ključ, moraju odabrati opciju "Activate License Key" te unijeti korisničke podatke te licencni ključ.

Nakon instalacije, potrebno je barem jednom pokrenuti ActCAD, kako bi se stvorio korisnički profil, potreban za instalaciju GeoMIR CAD modula.

Prebacivanje licence s računala na računalo:

Deaktiviranje licence: unutar ActCAD-a unijeti naredbu "TransferLicense" i potvrditi deaktivaciju.

Aktiviranje licence: pokrenuti ActCAD na drugom računalu te unijeti potrebne podatke i licencni ključ. Za aktivaciju su potrebna administratorska pristupna prava (označiti program te desnim gumb miša odabrati "Pokreni kao administrator/Run as administrator").

Nadogradnja ActCAD-a na najnoviju verziju:

Koristiti isključivo ugrađen mehanizam nadogradnje, NE instalirati nanovo!

Postupak: Pokrenuti ActCAD sa administratorskim pravima, izbornikom "Help/Check for updates" pozvati te pokrenuti proces nadogradnje. Nakon što preuzimanje nadogradnje završi, zatvoriti ActCAD i formular za preuzimanje te iznova pokrenuti ActCAD čime se izvršava nadogadnja.

Nakon nadogradnje ActCAD-a, preporuča se nadogradnja softvera GeoMIR5 i CAD modula za ActCAD.


Korak 2 od 2 : Instalacija softvera GeoMIR5 i CAD modula za ActCAD

Instalacija ››

Nova instalacija - softver GeoMIR5 nije instaliran na računalu

U tom slučaju izvršava se instalacija svih potrebnih datoteka. Za pokretanje instalacije potrebna su administratorska prava, tijekom koje se isključivo koriste korisnički izabrane mape te Registry Lokalnog korisnika (CurrentUser)

Potrebno je voditi računa o pristupnim pravima za GeoMIR5 mape - Programska mapa i mapa predmeta zahtjevaju pune privilegije za čitanje i pisanje. Ovo je posebno bitno za korisnike Windows Vista operativnog sustava jer u istome korisnik nije "po defaultu" administrator sa svim pravima.

Pri pokretanju instalacija potrebno je prihvatiti ugovor o korištenju i pročitati informacije o softveru. Nakon toga potrebno je odabrati mapu instalacije i programsku grupu:

Slijedi instalacija datoteka za lakši početak, pri čemu instalacijska procedura stvara "Mapu predmeta", instalira u nju nekoliko predmeta, potrebne teme kodiranja te korisničke formate. Osim toga, podešava se cjelokupno okruženje kako bi nakon instalacije GeoMIR5 bio spreman za rad. Preporuča se svim korisnicima koji su na nivou početnika.

Pri dnu formulara je crvenim slovima označeno u koju "Mapu predmeta" će biti instalirane datoteke za lakši početak.

Moguće je, čak preporučljivo, "Mapu predmeta" postaviti na mrežni disk, u ovom slučaju bio bi to "P".

Instalaciju datoteka za lakši početak moguće je preskočiti isključivanjem kvačice pri "Instalirati datoteke za lakši početak"

Slijedi instalacija CAD modula za ActCAD. Ako postoji više instalacija ActCAD softvera na računalu, potrebno je odabrati u koju instalaciju će modul biti instaliran. Najnovija instalacija će biti programski odabrana.

Ako ActCAD nije instaliran na računalu, ovaj formular će biti preskočen.

Napomena: GeoMIR5 modul za ActCAD 2017/2018 je dostupan samo iz klasičnog okruženja. Ako se prikaže Ribbon Style menu, potrebno je u dnu radne površine s desne strane, pritisnuti na plavi zupčanik te označiti izbornik „ActCAD classic“. Čak ako je izbornik već označen, potrebno je kliknuti još jednom na isti!

Nakon formulara datoteka za lakši početak, potrebno je još jednom potvrditi odabrane opcije instalacije te potvrditi pokretanje instalacije. NAPOMENA: Nosilac licence softvera GeoMIR5 je hardverski ključ!

Nadogradnja - softver GeoMIR5 već je instaliran i podešen na računalu

Ne izvršavati deinstalaciju postojeće verzije! Potrebno se samo pokrenuti instalaciju najnovije verzije. U tom slučaju izvršava se samo nadogradnja, tj. instaliraju se samo datoteke koje su novije od postojećih. Za pokretanje instalacije potrebna su administratorska prava.

Potrebno je prihvatiti ugovor o korištenju, pročitati informacije o softveru te, ako je ActCAD instaliran na računalu, odabrati instalaciju u koju će CAD modul biti instaliran.


Prvi kontakt sa softverom GeoMIR5

GeoMIR5

Veliki broj opcija koje softver pruža te pristup koji zahtjeva od korisnika, uz jedinstveno sučelje bazirano na predmetima i bazama podataka, često djeluju obeshrabrujuće u početku. No, GeoMIR5 je alat – a s alatom treba znati raditi. Treba naučiti osnove i korak po korak savladavati one dijelove koje su pojedinom korisniku potrebne. Nakon toga, korisnici nauče cijeniti ono, što ih je u početku odbijalo – veliki broj opcija, postavaka i mogućnosti koje softver pruža.

U nekoliko osnovnih koraka, ovo je GeoMIR5:

Organizacija podataka - razumjevanje gdje je što te osnovna terminologija

GeoMIR5 "Predmet" - sve se vrti oko "Predmeta"

Nakon pokretanja - prvi susret

Glavno sučelje GeoMIR5 - pisaći stol

Formular za učitavanje koordinata i pristup koordinatama točaka

Formular za učitavanje podataka totalne stanice i pristup učitanim podacima

Osnovne informacije u računanjima , kodiranju , svojstvima predmeta

Osnovne informacije o ActCAD-u i nadogradnji nazvanoj GeoMIR5 modul


Organizacija podataka

Prvi kontakt sa softverom GeoMIR5 ››

Točni nazivi mapa ovise o instalaciji, no ovdje su prikazane najčešće vrijednosti.

"Instalacijska mapa" je obvezna dok "Mapa predmeta" može biti po želji instalirana

odabirom instalacije "Datoteka za lakši početak".

C:\Program Files(x86)\GeoMIR5 – „Instalacijska mapa“

Sadrži programske datoteke te ostale datoteke potrebne za rad programa. Primjer:

GeoMIR5.exe

GeoMIR5.chm

G4_Surv.dll

i mnoge druge

C:\G5_DB – „Mapa predmeta“ (= baze podataka)

Isključivo za direktan pristup softverom GeoMIR5!

Instalira se uključivanjem opcije "Datoteke za lakši početak" tijekom instalacije.

Sadrži korisničke podatke – SVE predmete pojedinačno te zajedničke podatke. Savjetuje se redovita pohrana i osiguravanje cijele „Mape predmeta“. Nadalje, sve datoteke i mape unutar „Mape predmeta“ predviđene i organizirane su isključivo za direktan pristup softverom GeoMIR5 – svako mijenjanje datoteka ili strukture može dovesti do gubitaka podataka!

Za napredne korisnike: postavljanjem "Mape predmeta" na mrežni disk, omogućava se višekorisnički rad.

Primjer sadržaja "Mape predmeta":

COMMONDB.ABS - zajednička baza podataka

projects.xml - predmeti

*.G5T - teme kodiranja

COMMON.g5_udf - korisnički formati zapisa

000002 - mapa s podacima pojedinog predmeta

000002.ABS - baza podataka predmeta

000002.INI - pomoćna datoteka baze predmeta

000005 - mapa s podacima pojedinog predmeta

000005.ABS - baza podataka predmeta

000005.INI - pomoćna datoteka baze predmeta

000007 - mapa s podacima pojedinog predmeta

000007.ABS - baza podataka predmeta

000007.INI - pomoćna datoteka baze predmeta


GeoMIR5 "Predmet"

Prvi kontakt sa softverom GeoMIR5 ››

GeoMIR5 organizira podatke po "Predmetima". Termin "Predmet" je odabran jer ima tradiciju u geodeziji, termini "Projekt" ili "Radni zadatak" također odgovaraju. Nema direktne veze s Predmetima prema definiciji DGU-e.

Bez obzira treba li stvoriti crtež iz nekoliko točaka snimljenih RTK kinematikom ili iz složenog sustava mjerenja različitim metodama, uvijek je potrebno stvoriti odgovarajući "Predmet"! Slikovito rečeno, svaki novi predmet je kao prazna bilježnica koja sadrži unaprijed definirane tablice, spremne za unošenje podataka.

Podatke učitane u tablice moguće je mijenjati i obrisati te ručno unositi nove.

Tablice podataka mjerenja

( Pohrana podataka odvija se prema redosljedu učitavanja, pregledno prikazanih formularom „Stajališta“ ):

Tahimetrijski podaci

Girusni podaci

Ortogonalni podaci

Nivelmanski podaci

Tablice s koordinatama točaka

Unos može biti direktan ili kao rezultat računanja. Za razliku od većine geodetskih softvera, GeoMIR5 razdvaja detaljne točke od točaka geodetske osnove.

( Podaci su indeksirani brojem točke, što znači kako dvije točke s istim brojem ne mogu postojati u tablici ):

Točke geodetske osnove

Detaljne točke

Tablica s izvještajima

( pohrana podataka prema redosljedu računanja ):

Tablica sa svojstvima predmeta


Nakon pokretanja

Prvi kontakt sa softverom GeoMIR5 ››

U svim formularima i tablicama, veliku ulogu igra kontekstni izbornik – pritiskom na desnu tipku miša prikazuju se sve radnje koje je u tom trenu moguće izvršiti.

Nakon pokretanja, prvi kontakt sa softverom uslijedit će formularom "Predmeti", koji služi kao sučelje za manipuliranje "Predmetima" – stvaranje, obradu i brisanje "Predmeta" i "Grupe predmeta", kao i za pohrane, eksportiranja i importiranja "Predmeta":

Prikaz u formularu "Predmeti" je u stilu grananja – gornji nivo su "Grupe predmeta", koje sadržavaju "Predmete". "Grupe predmeta" su uvedene u svrhu preglednosti, a svaki "Predmet" mora pripadati jednoj od dostupnih grupa. Kao naziv "Predmeta" ili "Grupe predmeta" može biti unesen bilo koji tekstualni podatak – pod uvjetom da isti takav naziv ne postoji. Naime, dva predmeta istog naziva nisu dozvoljena.

Preporuča se grupiranje "Predmeta" kronološki i možda još prema vrsti radova, primjerice stvoriti "Grupu predmeta" pod nazivom "2017 – katastar XXX".

Stvaranje nove "Grupe predmeta": Označiti bilo koju postojeću "Grupu predmeta", pritisak na desnu tipku miša poziva formular gdje je potrebno unijeti naziv nove "Grupe predmeta".

Stvaranje novog "Predmeta": Označiti "Grupu predmeta" unutar koje će biti stvoren novi predmet, pritisak na desnu tipku miša poziva formular "Novi predmet".

Jedini obavezan podatak je naziv novog "Predmeta", koji mora biti jednoznačan.

Savjetuje je definiranje "Radne mape", koja će u svim učitavanjima i ispisima biti početna mapa pri odabiru datoteka.

Bitno je odrediti ispravan koordinatni sustav novog "Predmeta", kako bi razne korekcije bile ispravno izračunate.

Dvostrukim klikom na željeni "Predmet", isti će biti prihvaćen kao trenutni i biti će prikazano glavno sučelje GeoMIR5.


Glavno sučelje GeoMIR5

Prvi kontakt sa softverom GeoMIR5 ››

Sve radnje koje će uslijediti do promjene "Predmeta" ili zatvaranja programa, odnositi će se na trenutni "Predmet".

Sve tablice su dostupne takozvanim "Plutajućim formularima" koji mogu biti otvoreni, zatvoreni te postavljeni po želji. Kako se vidi iz slike, obrada podataka unutar tablica sliči radu sa programima za tablična računanja.

Radnje te pristup podacima dostupni su iz padajućih izbornika te ikona. Značenje ikona s lijeva na desno:

1. formular "Predmeti"

2. učitavanje mjerenih podataka, pretežno podataka totalnih stanica

3. učitavanje koordinata iz datoteke

4. obrada podataka detaljnih točaka

5. obrada podataka točaka geodetske osnove

6. obrada podataka mjerenja, takozvani prikaz stajališta

7. računanje poligonskih vlakova

8. računanje detaljnih točaka – interaktivno

9. računanje slobodnog stajališta

10. izjednačenje mreže

11. stvaranje objekata iz kodova

12. G4CAD (zastarjelo)

13. brz prikaz (zastarjelo)

14. svojstva "Predmeta"


Formular za učitavanje koordinata

Prvi kontakt sa softverom GeoMIR5 ››

Prvo je potrebno odabrati datoteku koja sadrži koordinate, nakon čega se otvara formular. Nakon što je formular otvoren, potrebno je iz padajućeg izbornika "Polja unosa" odabrati kakvog oblika su podaci unutar datoteke, te iz padajućeg izbornika "Razdjelnik" koji znak dijeli podatke o koordinatama.

Nakon ispravnog odabira, formular će imati izgled sličan ovome:

Detaljno o formularu za učitavanje koordinata .


Pristup koordinatama točaka

Prvi kontakt sa softverom GeoMIR5 ››

Tijekom učitavanja, koordinate točaka se unose u jednu od dvije koordinatne tablice unutar baze podataka "Predmeta". Bez obzira iz kakve datoteke su koordinate točaka učitane, unutar GeoMIR5 softvera sve su prikazane na isti način. Polazne datoteke se ne mijenjaju.

Učitanim koordinatama točaka moguće je pristupiti intuitivnim formularom, koji sliči radu sa tabličnim računanjima. Unutar formulara desnim klikom miša dostupne su odgovarajuće naredbe, između ostaloga za promjenu i brisanje postojećih, te ručni unos novih koordinata točaka.

Prikazivanje plutajućeg formulara za obradu podataka detaljnih točaka (4).

Prikazivanje plutajućeg formulara za obradu podataka točaka geodetske osnove (5) i pripadajućeg kontekst izbornika .


Formular za učitavanje podataka totalne stanice

Prvi kontakt sa softverom GeoMIR5 ››

Prvo je potrebno odabrati vrstu instrumenta čiji podaci se učitavaju te pritisnuti na tipku "Pretražiti". Nakon odabira jedne ili više datoteka sa mjerenim podacima, iste će biti prikazane u polju ispod tipke "Pretražiti", gdje je prikazan točan redoslijed učitavanja u bazu podataka "Predmeta".

Napomena: Podaci se unose u bazu podataka "Predmeta" prema redu učitavanja.

Moguće je utjecati na brojeve točaka prilikom učitavanja podataka.

Detaljno o formularu za učitavanje podataka mjerenja.


Pristup podacima mjerenja formularom "Stajališta"

Prvi kontakt sa softverom GeoMIR5 ››

Formular "Stajališta" je centralni formular za pristup učitanim podacima mjerenja, koji su pregledno prikazani redosljedom učitavanja. Dvostrukim klikom na željeno stajalište, otvara se plutajući formular koji služi za pristup podacima stajališta.

Unutar formulara za obradu tahimetrijskih podataka, moguće je podatke mijenjati, ubacivati te brisati.

Detaljno objašnjenje formulara "Stajališta" i pripadajućeg kontekst izbornika .


Računske operacije

Prvi kontakt sa softverom GeoMIR5 ››

Softver GeoMIR5 objedinjuje veliki broj računskih operacija geodetskih podataka. Sva računanja se vrše najvećom matematičkom točnošću koju nudi operativni sustav. Izračunati podaci pohranjuju se u bazu podataka bez zaokruživanja, kako lanac računskih operacija ne bi dodatno gubio na točnosti.

Od klasičnih računskih operacija, za izdvojiti su računanja svih vrsta poligonskih i visinskih vlakova, slobodno stajalište (ekscentar), trigonometrijsko računanje visine, računanje detaljnih točaka i mnoge druge.

Suvremeniji način računanja podataka mjerenja je "Izjednačenje mreže" , bazirano na izjednačenju prema Gaussovoj teoriji najmanjih kvadrata, uz statističku obradu izjednačenih koordinata i opažanja. Izjednačenje mreže daje podatak 95% elipse povjerenja, koji je propisan od strane DGU-e.

Datumska transformacija koordinata između HTRS i HDKS koordinatnih sustava, i to pomoću jedinstvenih parametara transformacije (poput T7D aplikacije) ili parametrima transformacija homogenih polja.

Koordinatni sustav HTRS je integriran najtočnijim formulama iz tehničke dokumentacije DGU-e, što vrijedi za transformacije koordinata kao i za redukcije mjerenih duljina.


Kodirano mjerenje

Prvi kontakt sa softverom GeoMIR5 ››

Podrška za kodirano mjerenje detalja, uz posebno sučelje za izradu tablica kodova po potrebi je bez konkurencije na tržištu. Kodirano mjerenje se koristi za "crtanje planova na terenu", a u svrhu što jednostavnijeg poštivanja digitalnih topografskih ključeva, zadanih od poslodavaca. Moguće je kodirati točkaste i linijske objekte.

Detaljno o kodiranom mjerenju .


Svojstva predmeta

Prvi kontakt sa softverom GeoMIR5 ››

Prema poznatoj uzrečici "last but not least" - svojstva "Predmeta" sadrže parametre koji direktno utječu na rezultate računanja, te je vrlo bitno pozabaviti se njima.

Ikona za pristup svojstvima "Predmeta".

Izdvojena svojstva "Predmeta":

Kutne jedinice

Koodinatni sustav

Parametri korekcije mjerene duljine

Izvještaji – broj decimala pri ispisu izvještaja

Detaljno o svojstvima predmeta.


Hijerarhija podataka

Prvi kontakt sa softverom GeoMIR5 ›› Svojstva predmeta ››

Svaki pojedini predmet je jedna zasebna cjelina koja se sastoji od jedne baze podataka te još nekih internih datoteka. Podaci iz jednog predmeta nisu vidljivi u nekom drugom.

U nekim slučajevima potrebno je podatke pohraniti tako da budu vidljivi iz svih predmeta. Za GeoMIR5 to su:

  • Zajedničke točke geodetske osnove

U praksi se često državne točke koriste u više predmeta - najbolji primjer su trigonometri koji služe za orijentacije. Takve točke je moguće pohranjivati u tablicu zajedničkih točaka geodetske osnove.

  • Teme kodiranja

Teme kodiranja organizirane su tako da svaka promjena unutar teme kodiranja utječe na sve predmete.


ActCAD

Prvi kontakt sa softverom GeoMIR5 ››

ActCAD je CAD softver opće namjene, intuitivnog i prepoznatljivog sučelja:

ActCAD je profesionalan 2D i 3D CAD softver, koji se temelji na tehnologijama IntelliCAD tehnologije Consortium (ITC), a u potpunosti je kompatibilan sa DWG i DXF formatima datoteka, i podržava sve verzije DWG / DXF od R2.5 do 2016.

ActCAD ima vlastiti API te je moguće programiranje od najjednostavnijih LISPova do složenih programa u C++. Uz eventualne manje preinake, gotovo svi postojeći LISP programe mogu biti migrirani iz AutoCAD-a u ActCAD.


GeoMIR5 CAD modul

Prvi kontakt sa softverom GeoMIR5 ››

Ovdje su detaljne upute za GeoMIR5 CAD modul - isti je dostupan za sve relevantne CAD platforme: ActCAD, AutoCAD, ZWCAD i BricsCAD


Pokretanje GeoMIR5

Ako je prilikom instalacije instalirano okruženje za lakši početak, mapa predmeta je već definirana i program je spreman za korištenje.

Ukoliko okruženje za lakši početak nije instalirano, potrebno je odrediti mapu predmeta .

Napomena!

Korisnicima sofvera GeoMIR4 NE preporučamo instalaciju okruženja za lakši početak! U poglavlju određivanje mape predmeta navedeno je kako prebaciti postavke iz programa GeoMIR4 u GeoMIR5.


Određivanje mape predmeta

Pokretanje GeoMIR5 ››

Pokretanje odabira iz:

glavni izbornik/Datoteka/Određivanje mape podataka

pojavljuje se standardan Windows formular za izbor mape. Mapa predmeta ne smije sadržavati znakove izvan osnovne ANSI tablice! Preporuča se korištenje jednostavnih naziva poput G5_DB ili GeoMIR5.

Nakon izbora mape, GeoMIR5 razlikuje tri slučaja:

1: Ako je odabrana mapa već u prošlosti bila određena kao GeoMIR5 mapa predmeta

biti će određena kao trenutna mapa predmeta i GeoMIR5 će biti zatvoren kako bi promjene bile prihvaćene.

2: Ako odabrana mapa sadrži datoteke ili mape koje nisu vezane uz GeoMIR5, izbor neće biti odobren.

3: Ako je odabrana mapa prazna, pojavit će se formular za daljnji izbor:

Izbor mape predmeta

a) Stvoriti mapu predmeta - GeoMIR5 će stvoriti praznu i čistu mapu predmeta, bez ikakvih podataka.

b) Učitati postojeće podatke iz G4/G5 - pritiskom na tipku "..." izabrati postojeću GeoMIR4 ili GeoMIR5 mapu predmeta, iz koje će biti preuzeti svi zajednički podaci ( zajedničke točke geodetske osnove, teme kodiranja, korisnički formati zapisa, G4CAD predlošci ). Postojeći predmeti neće biti migrirani. Preporuča se korisnicima GeoMIR4 softvera!

Nakon izbora, GeoMIR5 će biti zatvoren kako bi promjene bile prihvaćene


Predmeti

Pokretanje GeoMIR5 ››

Služi za sve radnje koje su vezane uz predmete – stvaranje novih, brisanje itd. Svaki predmet pripada određenoj grupi predmeta gdje je grupa STANDARD rezervirana i osnovna. Iako je moguće sve predmete stvoriti unutar grupe STANDARD, preglednije je stvoriti nekoliko logičnih grupa te unutar njih stvarati nove predmete. U nastavku navedene radnje dostupne su putem KI.

Pri radu u višekorisničkom sučelju, formular je dostupan eksluzivno, što znači da samo jedan korisnik u jednom trenutku ima mogučnost punog pristupa, ostali mogu u tom trenutku samo promjeniti predmet na kojem rade ali ne mogu stvarati ili brisati predmete.

Svaki otvoreni predmet je također dostupan eksluzivno samo korisniku koji trenutno na njemu radi.

•Dodati predmet

•Preimenovati predmet

Potreban je samo novi naziv predmeta. Nazivi grupa i predmeta ne smiju se ponavljati.

•Obrisati predmet(e)

Izabrani predmeti biti će obrisani iz popisa predmeta - za svaki slučaj, biti će interno pohranjeni i po potrebi će biti moguće izvršiti rekonstrukciju.

•Traženje u nazivima predmeta

Traženje određenog teksta unutar naziva predmeta. Popis pronađenih predmeta biti će prikazan i kopiran u međuspremnik.

•Dodati grupu

Potreban je samo novi naziv grupe. Nazivi grupa i predmeta ne smiju se ponavljati.

•Preimenovati grupu

Potreban je samo naziv grupe. Nazivi grupa i predmeta ne smiju se ponavljati.

•Obrisati grupu

Moguće samo ako nema niti jednog predmeta u grupi. Ne brišu se predmeti.

•Importirati predmet(e)

Rekonstrukcija predmeta iz datoteka G4Z ili G5Z, arhiviranih iz GeoMIR4 ili GeoMIR5 programa. Izvršenje je potpuno automatsko.

•Eksportirati predmet(e)

Svi podaci vezani uz predmet biti će u potpunosti pohranjeni u datoteku G5Z. Potrebno je odabrati mapu u koju će predmeti biti eksportirani. Ako postoje veze na zajedničke TGO, stvara se datoteka u koju se ispisuju referencirane TGO. Arhiviranjem se predmeti ne brišu.

•Pohraniti predmet(e)

Odabrani predmeti biti će interno pohranjeni na isti način kao kada bi bili obrisani. Svrha ovakvog pohranjivanja je pamćenje stanja predmeta u određenom trenutku.

•Rekonstruirati predmete

Otvara se formular sa popisom svih pohranjenih i obrisanih predmeta, uz navođenje vremena brisanja/pohrane. Izabrani predmeti iz popisa mogu biti rekonstruirani ili definitivno obrisani.

•Skorašnji predmeti

Popis najskorije korištenih šest predmeta, koje je moguće direktno otvoriti.


Stvaranje novog predmeta

Pokretanje GeoMIR5 ››

Pri stvaranju novog predmeta neophodan je samo unos naziva dok su ostali podaci proizvoljni.

•Naziv za novi predmet

bilo kakav tekstualni opis predmeta

•Kratak naziv ili poslovni broj

Prefiks koji se nadodaje automatski pri ispisu podataka u neku datoteku

• Predložak predmeta

Početna svojstva predmeta, unaprijed određena

• Koordinatni sustav

•Tema kod.:

Jedna od dostupnih tema kodiranja, koja će biti početna

•Radna mapa

NE MIJEŠATI S MAPOM PODATAKA. Mapa gdje se nalaze podaci vezani iz predmet, npr. Datoteke s mjerenim podacima. Omogučava lakše pronalaženje podataka na disku.


Glavno sučelje GeoMIR5

Nakon što je izabran aktivni predmet, otvara se glavno sučelje iz kojeg su dostupne sve radnje i funkcije GeoMIR5-a. Grafičko riješenje pruža korisniku mogućnost podešavanja izgleda prema svojim potrebama jer su svi odjeljci dostupni u bilo kojem trenutku i moguće ih je razmjestiti po ekranu po želji. Tako posložen zaslon moguće je pohraniti kao predložak za buduće prodmete.

Desna tipka na mišu poziva kontekstni izbornik kojim je moguće pozvati formular Predmeti , prikazati informacije vezane uz program, zatvoriti GeoMIR5 te direktno pristupiti skorašnjim predmetima.

Pomicanjem miša preko ikona, pojavit će se tekst (hint) koji opisuje njihovu svrhu.

Dobra ideja je, nakon prvog startanja GeoMIR5-a, pozabaviti se sučeljem, pootvarati sve odjeljke, razmjestiti ih po zaslonu te pohraniti kao predložak .

Radnje su podijeljene logički po izbornicima.

U dnu glavnog sučelja, nalaze se dva odjeljka:

Lijevo - je "Log odjeljak", u koji se pri radu ispisuju razne poruke i obavijesti za korisnika.

Desno - informacije o predmetu i vlasniku licence


Izbornik Datoteka

Radnje i funkcije vezane za učitavanje ili ispis podataka dostupne su ovdje.

  • Predmeti
  • Određivanje mape predmeta
  • Učitavanje podataka instrumenta
  • Učitavanje
  • Ispis

Sumarno izvješće računanja površina - rezultati svih računanja površina ispisuju se u željenu CSV datoteku.

  • Izvještaji
  • Korisnički formati
  • Sažetak poligonskih vlakova
  • Zabilješke
  • Unos u dnevnik
  • Sadržaj dnevnika
  • Izlaz

Zatvaranje programa.


Učitavanje podataka instrumenta

Izbornik Datoteka ››

Poziv na formular za učitavanje podataka instrumenata:

Potrebno je odabrati o kojem se instrumentu radi te odabrati datoteke. Nakon izbora datoteka, njihovi nazivi vidljivi su u popisu kojim redoslijedom će biti učitane. Tek tada pritiskom na OK počinje učitavanje.

Prije učitavanja, GeoMIR5 pronalazi najveći broj detaljne točke predmetu, te ga prikazuje istaknutog u tekstu plavom bojom.

Utjecanje na brojeve detaljnih točaka tijekom učitavanja:

    • Ostaviti nepromijenjene

    • Prenumerirati, sljedeći najveću iz baze

Detaljne točke će biti prenumerirane sljedeći najveći broj iz baze - iz priložene slike bila bi točka s brojem 3608.

    • Počevši s brojem

Detaljne točke će biti prenumerirane počevši s unesenim brojem

Koordinate ne učitavati: kako se odnositi prema koordinatama pronaženim unutar podataka mjerenja

Program provjerava odgovaraju li mjerne jedinice (kutne i dužinske) učitanih podataka definiciji iz predmeta. Ako ne, pojavljuje se upozorenje.

Podešavanje mjernih jedinica opisano je svojstvima predmeta.


Učitavanje - ostali podaci

Izbornik Datoteka ››

Više raznih modula za učitavanje podataka.

GeoMIR5 uvodi novu generaciju formata zapisa u prilagođene XML datoteke, koji će biti korišteni za sve vrste podatka pohrenjenih unutar GeoMIR5 sučelja. Izvorni G4 formati ostaju u svrhu kompatibilnosti dok su izvorni G3 formati izbačeni.

•GeoMIR5 XML

Jedinstveni format zapisa za sve podake iz programa.

•Izvorni G4 formati

Učitavanje GeoMIR4 formata zapisa.

•Izvorni G4 KOR zajedničke TGO

Učitavanje GeoMIR4 KOR formata zapisa u zajedničke TGO

•Izvorni G4 KOR lokalne TGO

Učitavanje GeoMIR4 KOR formata zapisa u lokalne TGO.

•Izvorni G4 TAH

Učitavanje GeoMIR4 KOR formata zapisa.

•Izvorni G4 DT

Učitavanje GeoMIR4 KDPformata u detaljne točke.

• Preuzimanje podataka iz nekog drugog predmeta

• Korisnicki formati

• Koordinate


Preuzimanje podataka iz nekog drugog predmeta

Izbornik Datoteka ››

Direktno preuzimanje točaka geodetske osnove, tahimetrijskih podataka i izvještaja iz nekog drugog predmeta. U prvom koraku potrebno je izabrati predmet iz kojeg se preuzimaju točke te koja vrsta podataka se preuzima:

Preuzimanje točaka geodetske osnove:

Sljedeći formular prikazuje sve lokalne TGO iz odabranog predmeta:

Točke za preuzimanje potrebno je označiti, pritiskom na OK vrši se preuzimanje.

Važno: ako u predmetu u koji se točke učitavaju već postoji točka s istim brojem, ona neće biti preuzeta. Dodjeljivanjem prefixa utječe se na broj točke - prefix se jednostavno dodaje na broj točke.

Preuzimanje tahimetrijskih podataka:

Sljedeći formular prikazuje sva stajališta iz izabranog predmeta:

Stajališta za preuzimanje potrebno je označiti, pritiskom na OK vrši se preuzimanje. Ako je kvačica "Samo ORI" uključena, biti će preuzete samo orijentacije bez detaljnih točaka za označena stajališta.

Preuzimanje izvještaja:

Sljedeći formular prikazuje sve izvještaje iz izabranog predmeta:

Izvještaje za preuzimanje potrebno je označiti, pritiskom na OK vrši se preuzimanje.


Učitavanje korisnickih formata

Izbornik Datoteka ››

Učitavanje korisničkih formata prema postojećim definicijama. U prvom koraku potrebno je izabrati o kojem korisničkom formatu se radi:

U drugom koraku odabire se datoteka za učitavanje, daljnji tijek je automatski.


Koordinate

Izbornik Datoteka ››

Učitavanje koordinata iz datoteke. Kao prvo potrebno je odabrati datoteku, tada se pojavljuje formular:

Vrlo fleksibilan modul za učitavanje koordinata iz ASCII datoteke, gdje su vrijednosti podijeljene nekim razdjelnikom (razmak, zarez, točka-zarez).

Polja unosa određuju koji stupci će biti učitani a potrebno ih je odabrati pri svakom učitavanju. Ponuđeno:

BrojT, Y, X | Broj točke, y, x
BrojT, Y, X, H | Broj točke, y, x, h
BrojT, Y, X, H, sy, sx, Kod, Info1, Info2 | Broj točke, y, x, h, stand.odst y, stand.odst x, kod, info1, info2
BrojT, Y, X, H, OpisT, Vrsta | Broj točke, y, x, h, Opis točke, vrsta točke
BrojT, Y, X, H, Kod | Broj točke, y, x, h, kod
BrojT, Y, X, H, Kod, Info1, Info2 | Broj točke, y, x, h, kod, info1, info2
BrojT, Y, X, H, Kod->Info | Broj točke, y, x, h, neutralna točka s info1 tekstom
BrojT, Y, X, H, H2, Kod | Broj točke, y, x, visina terena, visina rova, kod

Prije učitavanja, GeoMIR5 pronalazi najveći broj detaljne točke predmetu, te ga prikazuje istaknutog u tekstu plavom bojom.

Vrstu točke je moguće odrediti za svaku pojedinu točku - moguće je kombiniranje detaljnih točaka i TGO unutar jedne datoteke.

Ako je potrebno neku točku izbaciti iz učitavanja, dovoljno je maknuti kvačicu u stupcu Aktivan (prvi stupac).

Točke po potrebi mogu biti prenumerirane. Potrebno je prvo označiti točke koje treba prenumerirati te pritisnuti tipku Prenumerirati točke. Pruža se izbor numeričke ( određivanjem početne točke ili uvečanje/umanjenje aditivnom konstantom ) te alfanumeričke ( određivanjem prefiksa ili sufiksa ) prenumeracije.

Prije samog učitavanja dobra je praksa provjeriti postoje li u bazi podataka već točke s istim oznakama. Provjera brojeva - Predmet provjerava samo lokalne TGO dok Provjera brojeva - Sve provjerava lokalne i zajedničke TGO. Točke koje se podudaraju biti će označene promjenom boje podloge, a postavljanjem kursora na neku od njih pojavit će se u ToolTip prozorčiću odstupanje.

Točke označiti kao nepromijenjive ima smisla ako se učitavaju točke podloge koje ne smiju biti slučajno prepisane.

Popravka nadmorske visine se dodaje svim točkama koje se učitavaju.


Izvještaji

Izbornik Datoteka ››

Tijekom rada GeoMIR5 ispisuje rezultate računanja ili razne zapisnike kao izvještaje, nekada poznate kao obrasce. Izvještaji su prilagođeni modernom načinu ispisa a njihov izgled oslanja se na klasične obrasce.

Pritiskom na desnu tipku miša na popisu izvještaja, otvara se kontekstni izbornik, putem kojega se dostupne sljedeće radnje:

  • Promjene

Otvara novi formular koji je u stvari jednostavan tekst editor koji omogućava direktnu promjenu podataka iz izvještaja. Tipkom "Pregled ispisa" otvara se preglednik za izvještaje .

  • Izbrisati

Brisanje označenih izvještaja

  • Izabrati sve

Označavanje svih izvještaja iz popisa

  • Naći u izvještajima

Traženje zadanog teksta u svim izvještajima. Unos teksta je osjetljiv na slovnik. Izvještaji u kojima je pronađen zadani tekst, biti će označeni u popisu izvještaja i napomenuti u Log odjeljku.

  • Povezati izvještaje u jedan

Odabrani izvještaji biti će povezani u jedan izvještaj. Pri povezivanju moguće je obrisati polazne izvještaje. Pogodno kako bi se smanjio broj stranica izvještaja.

  • Ispis

Preglednik za izvještaje (PrintPreview) iz kojega je moguće štampanje svih označenih izvještaja. Izbornik Štampa dostupan je i direktno pri računskim operacijama te još nekim radnjama.

  • Pohraniti u TXT datoteku

Pohrana označenih izvještaja u TXT datoteke, svaki izvještaj za sebe. Naziv datoteke se sastoji od datuma stvaranja te naziva izvještaja.

  • Pohraniti u RTF datoteku

Pohrana označenih izvještaja u RTFdatoteke, svaki izvještaj za sebe. Naziv datoteke se sastoji od datuma stvaranja te naziva izvještaja. Ovako pohranjeni izvještaji sadržavaju oblik stranice.


Preglednik za izvještaje

Izbornik Datoteka ››

Preglednik za izvještaje sliči preglednicima ( PrintPreview ) poznatih programa za obradu ili pregled teksta i na hrvatskom je jeziku. Osim pregleda teksta moguć je ispis na štampač, te u PDF i RTF datoteke. RTF datoteka može se otvoriti i dalje obrađivati u svim poznatim programima za obradu teksta.


Korisnički formati

Izbornik Datoteka ››

Korisnički formati služe za dvosmjernu komunikaciju s programom. Podržane su tablice TGO, DT te tahimetrije.

•Dodati novi

stvaranje novog korisničkog formata, potreban je naziv te izbor tablice. Na taj način stvara se novi korisnički format s predodređenim vrijednostima koje je naknadno moguće mijenjati.

• Promjene

•Izbrisati

brisanje korisničkog formata


Korisnički formati - promjene

Izbornik Datoteka ››

Sučelje za detaljno definiranje korisničkog formata. Prikazano je sučelje za točke geodetske osnove no za ostale tablice je sve isto osim ponuđenih polja.

Polje | vrsta podatka koji se upisuje u stupac
Lijevo | prisloniti na lijevi rub polja
Širina | koliko karaktera zauzima polje
Za prazno | upisuje se u polje ako nema vrijednosti u tablici
Razm.ispr. | koliko praznih mjesta se nadodaje prije samog podatka
Razm.iza | koliko praznih mjesta se nadodaje nakon samog podatka
Decimalnih mjesta | na koliko decimala zaokružiti vrijednost

Formular je sam po sebi vrlo intuitivan. Vizualno se određuje koja vrsta podataka se u koji stupac upisuje. Nepotrebni podaci se jednostavno ne definiraju, ili se unese vrijednost ".".

U dnu formulara se tijekom definiranja u realnom vremenu prikazuje primjer uzimajući u obzir definirane podatke.


Sažetak poligonskih vlakova

Izbornik Datoteka ››

Svaki izračunati poligonski ili visinski vlak, bez obzira da li je izvještaj pohranjen ili ne, upisuje se u sažetak poligonskih vlakova. S jedne strane, pruža dobar pregled što je u predmetu izračunato te omogućuje, dvostrukom klikom na određeni vlak, njegovu rekonstrukciju te ponovno računanje. Jednostrukim klikom na poligonski vlak, ispisuju se rezultati računanja.


Zabilješke

Izbornik Datoteka ››

Pogotovo u višekorisničkom sučelju je posebno zgodno, nakon obrade nekog predmeta ostaviti sebi ili nekome drugome koji će isti predmet naknadno obrađivati, zabilješku koja će se pojaviti pri samom otvaranju predmeta i to neupadljivo ali dovoljno jasno, u obliku oblačića iz stripova. Tako unesena zabilješka pojavljivat će se sve dok ne bude izrisana.


Unos u dnevnik

Izbornik Datoteka ››

Predstavlja manualan unos u dnevnik. Naslov mora biti unesen, sadržaj ne.


Sadržaj dnevnika

Izbornik Datoteka ››

Sva računanja se protokoliraju u dnevniku, i to za sve predmete i sve korisnike u istu bazu podataka. Takve informacije dobivaju na značaju u većim uredima gdje više korisnika, na raznim računalima, radi na istim predmetima. Dnevnik prikazuje vrlo pregledno protokolirano što je tko u kojem trenutku radio.

Osim sadržaja koji program automatski upisuje u podatke, korisnik može vlastoručno ubaciti neku informaciju vezanu uz predmet.

Filterom se ograničava broj prikazanih podataka, i to izborom iz koliko dana unatrag će biti prikazani izvještaji te treba li prikazati izvještaje samo iz trenutnog predmeta ili svih dostupnih predmeta. Filter se aktivira pritiskom na tipku Prikazati.

Pritiskom na tipku Ispis moguće je prikazane izvještaje pohraniti u TXT datoteku.


Izbornik Promjene

Obuhvaća sve radnje vezane uz promjene podataka unutar programa GeoMIR5. Mijenjati se mogu podaci točaka geodetske osnove, detaljnih točaka, podataka mjerenja te svojstva predmeta.

Kako su svi podaci pohranjeni unutar baze podataka, sučelje za njihovu promjenu je slično tržišno poznatim programima za rad s bazama podataka ( Access i ostale ) te tabličnim kalkulacijama( Excel itd ).

Prvi stupac slijeva ozančava status promjene. Sve dok je s lijeve strane retka koji je u obradi znak poput velikog slova i ( I ) podaci još nisu pohranjeni. Preaskom u novi redak slijeva se pojavljuje nešto poput znaka ( > ) što označava novi aktivan redak s time da su svi ostali podaci pohranjeni u bazi podataka.


Obrada TGO

Izbornik Promjene ››

Služi za pristup točkama geodetske osnove. Ovdje se vrši ručni unos TGO, njihova obrada, brisanje ili ispis a u tome pomažu različiti filtri te pretraživanja. Osim osnovnih podataka o koordinatama i broju točke, unutar baze podataka se pohranjuju mnogi drugi podaci; o točnosti, načinu te datumu računanja točke kao i neobavezni podaci o stabilizaciji te slovčanom nazivu neke točke. Pregled svih polja unutar baze podataka točaka geodetske osnove:

Naziv | obavezan, indeksiran podatak. Služi za sva pretraživanja unutar programa
Opis | neobavezan podatak, ako postoji ispisuje se u izvještajima umjesto naziva
Y , X , H | koordinate po osima
Vrsta | vrsta točke
SamoČitanje | ako je označeno, točka ne može biti prepisana tijekom računanja
Tekst | neobavezan podatak, prošireni opis točke

Osim ovdje navedenih podataka koje korisnik može mijenjati, tijekom rada se bilježe i podaci o datumu, točnosti i načinu računanja točke te veza s poligonskim vlakom u kojem su sračunate. Sve radnje dostupne su putem kontekst izbornika .


Obrada TGO - KI

Izbornik Promjene ››

Pregled radnji dostupnih kontekstnim izbornikom:

•Prebacivanje izvora podataka

Promjena zajedničkih i lokalnih točaka geodetske osnove obavlja se u istom ( ovom ) formularu. U naslovu formulara je prikazano koja tablica je aktivna a prvi izbornik odozgo služi za mijenjanje aktivne tablice.

•Izaberite sve

označavanje svih točaka unutar tablice. Ovime su obuhvaćene samo točke koje su prikazane u tablici – ako je uključen filter, točke koje nisu obuhvaćene filtrom neće biti zahvaćene izborom.

•Poništiti izbor svega

poništavanje izbora, niti jedan podatak neće biti označen.

•Preokrenuti izbor

točke koje nisu označene biti će označene i obrnuto.

•Traženje zapisa

traženje određene točke brojem i postavljanje kursora na nju

•Sužavanje - tekstualno

standardno su prikazane sve točke u tablici. Po potrebi se može suziti broj prikazanih točaka. Kako se vidi, sužavanje je moguće nazivom te vrstom TGO. Od uobičajenih Wildcard karaktera podržana je jedino zvjezdica.

•Sužavanje - koordinatama

Osim predhodno navedenog tekstualnog sužavanja, moguće se izvršiti sužavanje prikazanih koordinata na određeno koordinatno područje. U tu svrhu potrebno je unijeti koordinatu centra područja te za svaku os polovinu ukupne širine područja ( od unesene koordinate plus i minus unesena širina područja ).

•Prikazati sve TGO

poništavanje sužavanja točaka, sve točke će biti prikazne.

•Obrada TGO

prikaz i obrada podataka TGO (osim broja točke) putem formulara. Isti učinak se postiže direktnom promjenom unutar tablice.

Obrada pojedine TGO

•Nova TGO

unos nove točke putem formulara. Pri pokušaju unosa točke s brojem koji već postoji, GeoMIR5 javlja pogrešku. Formular je isti kao i pri obradi točke.

•Preimenovati

Promjena naziva točke. Dozvoljava se samo unos broja koji još ne postoji.

•Postaviti vrstu TGO

mijenjanje vrste svih označenih točaka putem formulara.

•Status "Samo čitanje/Promjenjive"

postavljanjem TGO parametra na "Samo čitanje", onemogućava se slučajno prepisivanje koordinata TGO tijekom računanja.

•Obrisati TGO

brisanje svih označenih točaka. Povratak obrisanih točaka nije moguć.

•Pohraniti u međuspremnik

označene točke biti će privremenu pohranjene u međuspremnik. Tako pohranjene točke moguće je učitati u tablicu detaljnih točaka istog predmeta ili u bilo koju drugu tablicu koja sadržava koordinate točaka (TGO ili DT nekog drugog predmeta, zajedničke TGO).

•Ubaciti iz međuspremnika

učitavanje točaka prethodno pohranjenih u međuspremnik.

•Ispis

ispis označenih točaka, u izvještaje ili datoteku ( GeoMIR5 XML ili korisnički definiran format ):

•Sortiranje

nekoliko načina za sortiranje točaka unutar tablice.

•Transformacija koordinata

Transformiranje koordinata izabranih točaka datumskom transformacijom ili prema predhodno izračunatim parametrima

•Prikazati informacije

Prikazivanje svih informacija o točci, koje nisu vidljive u tablici:


Obrada DT

Izbornik Promjene ››

Poput točaka geodetske osnove, i podatke detaljnih točaka je moguće mijenjati.

Pritiskom na desnu tipku miša, dostupne su sljedeće radnje:

  • Pronaći

Pronalaženje detaljne točke prema broju.

  • Unos nove detaljne točke

Manuelan unos detaljne točke

  • Izabrati sve - kratica CTRL + A

Izbor svih točaka u tablici.

  • Poništiti izbor svega

Poništenje odabira točaka, niti jedna točka u tablici neće biti izabrana.

  • Izabir grupe točaka

Izbor grupe točaka prema nazivu točke. Sintaksa unosa: <Početna točka grupe>/<Završna točka grupe>.

  • Izbrisati

brisanje označenih točaka. Povratak obrisanih točaka nije moguć.

  • Obrisati sve

brisanje SVIH detaljnih točaka. Povratak obrisanih točaka nije moguć.

  • Preimenovati

Promjena broja detaljne točke

  • Prenumeracija grupe točaka

Prenumeracija grupe točaka, predhodno izabranih pojedinačno ili izabirom grupe točaka, vrši se standardnim formularom za prenumeraciju detaljnih točaka .

  • Promjena koda detaljnih točaka

Promjena koda označenih detaljnih točaka. Korištenje je potpuno isto kao pri promjeni koda detaljnih točaka iz tahimetrije.

  • Spajanje dvije DT u jednu

Spajanje dvije detaljne točke u jednu s dvije visine

  • Visina H2 iz H

Stvaranje visine H2 unosom visinske razlike u odnosu na H. Moguće je izvršiti zamjenu mjesta visinama, tako da nova vrijednost bude H a stara H2

  • Pohraniti u međuspremnik

označene točke biti će privremenu pohranjene u međuspremnik. Tako pohranjene točke moguće je učitati u tablicu točaka geodetske osnove istog predmeta ili u bilo koju drugu tablicu koja sadržava koordinate točaka (TGO ili DT nekog drugog predmeta, zajedničke TGO).

  • Ubaciti iz međuspremnika

učitavanje točaka prethodno pohranjenih u međuspremnik.

  • Ispis

ispis označenih točaka, u izvještaje ili datoteku (GeoMIR5 XML ili korisnički definiran format )

Obrada pojedine DT

  • Transformacija koordinata

Transformiranje koordinata izabranih točaka datumskom transformacijom ili prema predhodno izračunatim parametrima


Obrada DT - Spajanje dvije DT u jednu

Izbornik Promjene ››

Grupiranjem detaljnih točaka stvara se iz dvije mjerene detaljne točke jedna sa dvije visine. Takav način spajanja točaka posebno je pogodan pri snimanju za katastar vodova jer priprema podatke za ispravan ispis u CAD modul, gdje točke vodova imaju dvije visine - visinu terena kao prvu i visinu voda kao drugu.

Takav način pripreme detaljnih točaka pogodan je i pri ispisu koordinata u izvještaje.

Pri izvršenju naredbe, u pretraživanje će biti uzete SVE detaljne točke iz baze podataka:

Potrebno je unijeti "Najveći razmak za parove DT", unutar kojega će točke biti razmatrane kao parovi. Naredba radi na dva načina, u ovisnosti odabira "Grupiranja preko kodova":

Ako se grupiranje preko kodova NE provodi

Ako se grupiranje preko kodova provodi:

Kod za H (teren): kodovi detaljnih točaka koji predstavljaju točke terena - unos zvjezdice "*" predstavlja sve kodove osim kodova voda.

Kod za H3 (vod): kodovi koji su korišteni za snimanje kodova.

Prikazani primjer pronalazi detaljne točke koje su snimljene kodom "88", provjerava sve ostale snimljene točke unutar 5 metara, te od najbliže preuzima visinu koju zapisuje pod H dok trenutnu visinu upisuje pod H2.


Samo udaljenošću točaka

Izbornik Promjene ›› Obrada DT - Spajanje dvije DT u jednu ››

Spajanje dvije detaljne točke u jednu s dvije visine. Prvo je potrebno unijeti Najveći razmak za spajanje DT. Sve detaljne točke, koje su unutar unesenog razmaka, stvaraju grupu točaka. Ako su unutar grupe više od dvije točke, dojavlja se pogreška.

Na ovaj način moguće je dvije neovisno snimljene detaljne točke prikazati kao jednu detaljnu točku s dvije visine, najčešće u svrhu prikaza točaka nekog voda.

Formular za spajanje svije detaljne točke u jednu:

Pri pokretanju formulara, svaki par točaka je posebno naveden. Unutar svakog para postoji točka A i točka B, s time da je točka A nižeg broja točke. Cilj je iz dvije točke A i B stvoriti novu točku N. Iz tablice je vidljivo koja točka je A a koja B. U stupcu N= određuje se koja točka, A ili B, će postati osnovna točka a koja preostala točka. Odabirom oznake "-", par točaka se preskače.

Osnovna točka - iz nje se preuzimaju koordinate i prva visina

Preostala točka - iz nje se preuzima druga visina

Tipka "A=viša" - sve točke s višom visinom H postaviti kao osnovne točke

Tipka "A=niža" - sve točke s nižom visinom H postaviti kao osnovne točke

Obrisati Preostalu točku iz predmeta - trajno brisanje Preostale točke iz predmeta


Stajališta

Izbornik Promjene ››

U ovom odjeljku prikazani su, redoslijedom učitavanja, svi podaci mjerenja učitani u GeoMIR5. Svaki redak ima potrebne podatke za stajalište ( linije snimanja, nivelmana ) te vezu s stvarnim podacima smještenima u bazi podataka. Dvostrukim klikom na stajalište, otvara s odjeljak s povezanim podacima i to uzimajući u obzir o kojoj se vrsti podataka radi.

Informacije o stajalištima:

Stajalište: oznaka ili broj stajališta

I: visina instrumenta (T, G)

Info1: Informacija o stajalištu

Datum: Datum snimanja

+/-: vrsta podataka i status stajališta: T-tahimetrija, G-girusi, O-ortogonal, N-geometrijski nivelman, M-plošni nivelman

MjerGr: informacija o mjernoj grupi


Stajališta - KI

Izbornik Promjene ››

Prikaz kontekst izbornika:

• Prikazati sva stajališta

poništavanje filtera.

• Filter

ograničavanje prikaza stajališta prema broju.

• Pronaći

Pronalaženje određenog stajališta prema broju te postavljanje na njega. Za razliku pd filtera, ovdje ostaju sva ostala stajališta vidljiva. Rezultat pronalaženja upisuje se u Log odjeljak što je pogodno ako se određeno stajalište pojavljuje više puta.

Izbor

  • Izbor - izaberite sve: Označavanje svih stajališta kao izabranih, kratica CTRL+A
  • Izbor - Poništiti izbor svega: Niti jedno stajalište neće biti izabrano
  • Izbor - pohraniti trenutni: Pohrana informacije o trenutno izabranim stajalištima
  • Izbor - učitati izbor: Označavanje stajališta kao izabrana, prema predhodno pohranjenoj informaciji
  • Izbor - učitati prethodni: Označavanje stajališta kao izabrana, prema predhodnoj informaciji

• Izbor - detaljno

Novo

  • Unos - tahimetrijsko stajališta
  • Unos - girusi
  • Unos - ortogonalna linija
  • Unos - geometrijski nivelman
  • Unos - Plošni nivelman

• Promjene

promjena podataka stajališta – već unaprijed prikazan formular.

• Izbrisati

brisanje označenih stajališta. Izbrisana stajališta ne mogu biti vraćena. U slučaju brisanja podataka girusa koji su bili stvoreni iz tahimetrije, tahimetrijski podaci će biti vraćeni u početno stanje.

• Prošireni podaci stajališta

Promjena proširenih podataka stajališta ( Datum, Info1, Info2, temperatura, tlak, vlažnost ) za označena stajališta.

• Spojiti dva stajališta (T)

spajanje podataka dvaju stajališta koji u tablici dolaze jedan iza drugoga u jedno. Podaci o stajalištu biti će preuzeti od prvoga.

• Spajanje grupa

• Prenumeracija TGO

• Ažurirati kodove DT iz tahimetrije (T)

izračunate detaljne točke pohranjuju se u zasebnu tablicu s izračunatim koordinatama te kodovima iz tahimetrije. Ako naknadno dođe do promjene koda unutar tahimetrijskih podataka, kod unutar detaljnih točaka možda nije više aktualan. Ako postoji sumnja u takav slučaj, potrebno je izvršiti ovu radnji ili ponovo sračunati detaljne točke. Ažuriraju se podaci za označena stajališta.

• Potraga za pogrešnim/nedostajućim dužinama (T)

jedna od radnji za kontrolu podataka mjerenja. GeoMIR5 uspoređuje sve mjerene dužine između dvije točke prema njihovim brojevima a ako postoje koordinate tada i s dužinom iz koordinata. Ako se pojavi nesuglasica, prijavljuje se. Pretražuju se podaci za označena stajališta.

• Pretraga za dvostrukim brojevima DT (T)

već je spomenuto da su detaljne točke unutar tahimetrijskih podataka poredane po redoslijedu učitavanja što može dovesti do pojavljivanja dvostrukih brojeva – slučaj koji tablica detaljnih točaka ne dozvoljava. Ova radnja prijavljuje sve točke koje se pojavljuju dva ili više puta u tahimetrijskim podacima. Pretražuju se podaci za sva stajališta.

• Prenumeracija DT (T)

• Promjena koda detaljnih tocaka

• Dubina voda putem koda

Unos dubine voda ( stupac označen sa h1 a predstavlja visinsku razliku od osnovne visine detaljne točke ) za sve točke sa označenih stajališta koje odgovaraju unesenom kodu. U za to pripremljenom formularu unosi se kod te dubina voda. Pri računanu detaljnih točaka, dobivena nadmorska visina se upisuje u stupac H2.

• Brisanje pripadajućih DT (T)

brisanje iz tablice detaljnih točaka – točke s označenih stajališta.

• Provjera kontrolnog pravca

Kontrolni pravac pri tahimetrijskom snimanju predstavlja vizuru na proizvoljnu daleku točku, i to jednom na početku te na kraju snimanja. Računanjem razlike te dva pravca znat će se ako je došlo do pomaka instrumenta tijekom mjerenja.

• Preračunavanje kutnih jedinica

Preračunavanje kutnih jedinica za odabrana stajališta. Određuju se ulazne te izlazne kutne jedinice. Moguće su sve kombinacije za podržane kutne jedinice .

• Girusi iz tahimetrije (T)

Stvaranje girusa iz tahimetrijskih podataka. Za izvršenje potrebno je u tahimetrijskim podacima vizure opažati u dva položaja instrumenta i u oba položaja upisati isti broj točke. GeoMIR5 pronalazi takve točke, računa jedan girus, stvara novo stajalište s girusnim podacima te popravlja tahimetrijske podatke.

• Tahimetrijski zapisnik

• Izvještaj o stajalištima

razlika između tahimetrijskog zapisnika i izvještaja o stajalištima je u tome, što izvještaj o stajalištima ne prikazuje mjerene podatke nego rezultate računanja, npr. područje detaljnih točaka te orijentirane smjerove za izabrana stajališta

• Računanje girusa(G)

izračunavanje girusa za izabrana stajališta

• Izrada izvještaja o girusima(G)

izrada prvog i drugog obrasca za izabrana stajališta

• Ispis GeoMIR5 XML

ispisivanje izabranih stajališta u jedinstveni GeoMIR5 XML format. Moguće je odlučiti radi li se u ispisu o svim podacima ili samo o podacima ORI

• Računanje ortogonalnih podataka(O)

Izračunavanje ortogonalnih podataka za izabrane linije snimanja.

• Računanje geometrijskog nivelmana(N)

Izračunavanje podataka geometrijskog nivelmana za izabrane linije snimanja.

• Računanje plošnog nivelmana(M)

Izračunavanje podataka plošnog nivelmana za izabrane podatke.

Računati

  • Priključak na visinu

  • Slobodno stajalište

  • Presjek natrag

  • Automatsko računanje (T)

  • Računanje DT – interaktivno (T)

  • Računanje DT – automatski (T)

  • Stvaranje objekata iz kodova (T)

  • Računanje DT presjecanjem naprijed (T)

• Stvaranje objekata iz kodova

Za odabrana stajališta biti će stvoreni objekti prema kodovima detaljnih točaka

• Definiranje statusa stajališta

Status stajališta može se postaviti na jednu od vrijednosti: 0, 1, 2, +. Ovaj podatak služi samo u svrhu preglednosti i nema utjecaja na rezultate računanja, a biti će prikazan u stupcu "+/-" .

• Definiranje mjerne grupe

Ako je na jednom predmetu radilo više mjernih grupa, ovdje je moguće voditi tu informaciju. Unosi se broj od 0 nadalje. Ovaj podatak služi samo u svrhu preglednosti i nema utjecaja na rezultate računanja, a biti će prikazan u stupcu "MjerGr" .

• Filtriranje tablica

u pravilu su prikazana sva stajališta u formularu, bez obzira radi li se o tahimetriji ili girusima. Filtriranjem je moguće utjecati na prikaz istih


Stajališta - izbor detaljno

Izbornik Promjene ››

Detaljan ( proširen ) izbor stajališta prema statusu stajališta ili datumu.

• Status stajališta

Označiti stajališta prema statusu.

• Datum

Padajućim izbornikom određuje se uvjet:

- Mjereno nakon ( uključujući datum )

- Računato nakon ( uključujući datum )

Datum mora biti unesen u prikazanom obliku DD.MM.GGGG.

Označavanjem Samo s sračunatim koordinatama, biti će označena samo stajališta koja odgovaraju uvjetu datuma i imaju sračunate koordinate.


Stajališta - unos tahimetrije

Izbornik Promjene ››

Unos tahimetrijskog stajališta u bazu podataka, i to nakon posljednjeg postojećeg stajališta.

U gornju tablica unose se osnovni podaci o stajalištu a u donju podaci o mjerenjima. Opažanja na točke vlaka označavaju se kodom "00" ( dvostruka nula ). Svi ostali kodovi predstavljaju opažanja na detaljne točke.

Olakšavanje unosa:

Broj točke - unosom znaka "+" ( plus ) u stupac Broj točke uvečava se predhodni broj točke za jedan i unosi u polje gdje je unesen znak "+".

Ponavljanje unosa - unosom znaka "*" ( zvjezdica ) u stupac Kod, Signal ili V, upisat će se predhodna vrijednost trenutnog stupca.


Stajališta - unos girusa

Izbornik Promjene ››

Unos stajališta s girusnim podacima u bazu podataka, i to nakon posljednjeg postojećeg stajališta.

Isti formular se koristi za unos te za naknadnu obradu podataka stajališta. Korisnik može utjecati na sljedeće podatke:

Pri unosu stajališta potrebno je unaprijed unijeti opažane točke te u koliko je girusa opažano. GeoMIR5 stvara potrebna "prazna" polja koja se naknadno unose podaci.

Nakon unosa girusnog stajališta potrebno je unijeti podatke girusnih opažanja .


Stajališta - unos ortogonala

Izbornik Promjene ››

Iako strogo gledano, ortogonalna linija snimanja nema ništa sa pojmom stajališta, GeoMIR5 obuhvaća i podatke snimanja ortogonalnom metodom pod odjeljak stajališta. Svrha tome je preglednost - to je ionako vrsta podataka koja se vrlo rijetko javlja u praksi.

Nakon unosa linije snimanja potrebno je unijeti podatke za liniju snimanja .

•Točka - poč:

početna točka linje snimanja

•Točka - zav:

završna točka linje snimanja

•Datum

•Info1

proizvoljna informacija


Stajališta - unos geometrijskog nivelmana

Izbornik Promjene ››

Iako strogo gledano, geometrijski nivelman nema ništa sa pojmom stajališta, GeoMIR5 obuhvaća i podatke snimanja geometrijskog nivelmana pod odjeljak stajališta. Svrha tome je preglednost.

Nakon unosa novog geometrijskog nivelmana potrebno je unijeti opažanja geometrijskog nivelmana .

• Točka - poč

Početna točka geometrijskog nivelmana

• Točka - zav

Završna točka geometrijskog nivelmana

• Datum

• Info

proizvoljna informacija

• Vrsta nivelmana

Tehnički ili precizni, za računanje dozvoljenih odstupanja


Stajališta - unos plonog nivelmana

Izbornik Promjene ››

Iako strogo gledano, plošni nivelman nema ništa sa pojmom stajališta, GeoMIR5 obuhvaća i podatke snimanja plošnog nivelmana pod odjeljak stajališta. Svrha tome je preglednost.

Nakon unosa novog plošnog nivelmana potrebno je unijeti opažanja plošnog nivelmana .

• Datum

• Info

Općenita informacija, obavezan podatak


Spajanje grupa

Izbornik Promjene ››

Spajanje grupa mjerenja u jedno stajalište. Unosi se broj stajališta za koje se želi spojiti grupe. Traženo stajalište mora biti barem dva puta mjereno i imati barem jednu zajedničku vizuru.

Zajedničke vizure prikazane su u odjeljku "Referentne ORI". Izborom jedne od njih određuje se referentna ORI koja služi za preračunavanje horizontalnih pravaca. Pri preračunavanju uzima se u obzir različita visina instrumenta, razlika se prenosi na visinu signala orijentacija.


Prenumeracija TGO

Izbornik Promjene ››

Prenumeracija točaka geodetske osnove putem dijaloga, vrši se za podatke s označenih stajališta. Tijekom prenumeracije, prenumeriraju se stajališta i orijentacije.

•Prenumerirati samo jednu točku

Prenumeracija jedne točno određene točke koja se pojavljuje u označenim stajalištima, bila ona stajalište ili orijentacija.

•Obuhvat točaka

Prenumeracije grupe točaka koje ulaze u uneseni obuhvat. Prenumeracija može biti izvršena numeričkim uvečanjem za unesenu vrijednost, te tekstualnim dodavanjem prefiksa ili sufiksa. Primer iz slike: sve točke iz označenih stajališta veće ili jednake 300 i manje ili jednake 399, bile one stajalište ili orijentacija, biti će uvečane za 100.


Prenumeracija DT

Izbornik Promjene ››

Prenumeracija DT

Previous Top Next

Prenumeracija detaljnih točaka putem dijaloga. Prenumeracija se provodi numerički a vrši za podatke s označenih stajališta.

•Dodati konstantu

dodavanje konstantne vrijednosti postojećem broju točke.

•Početna vrijednost

dodjeljivanje brojeva bez obzira na postojeće vrijednosti, počevši s određenim brojem. Mogu se uključiti umjeravane točke u prenumeraciju, tj. točke koje trenutno nemaju nikakav broj.

•Dodatni podaci

dodavanje istog prefiksa svim točkama.


Promjena koda detaljnih točaka

Izbornik Promjene ››

Formular za promjenu koda detaljnih točaka unutar tahimetrijskih podataka, vrši se za podatke s označenih stajališta.

•Pretražiti

Postojeća vrijednost koju treba promijeniti. Ako je ostavljeno prazno, nova vrijednost koda biti će unesena onim mjerenim detaljnim točkama, koje nemaju nikakav podatak unesen pod kod. U tom slučaju, vrijednost pod Mijenjati samo cjelokupan kod nema utjecaja.

•Zamijeniti sa

Nova vrijednost koda. Unos ovog podatka je obavezan.

•Mijenjati samo cjelokupan kod

Utječe na način promjene koda.

Ako je uključeno, nova vrijednost se unosi samo ako cijelokupna vrijednost postojećeg koda u potpunosti odgovara vrijsdnosti pod Pretražiti.

Ako nije uključeno, moguće je mijenjati samo dio koda, uzimajući u obzir definiciju trenutne teme kodiranja ( primjerice, kod 3509 biti će promijenjen u 8509 ).


Izrada tahimetrijskog zapisnika

Izbornik Promjene ››

Izrada tahimetrijskog zapisnika za izabrana stajališta.

Prikazati samo ORI

U zapisniku neće biti detaljnih točaka, samo orijentacija

Ispisati bez pohrane

Umjesto trajne pohrane u bazu podataka, biti će prikazan print-preview formular

Prikazati nepoznate ORI

Ako nije uključeno, biti će ispisane samo ORI poznatih koordinata

Vrsta izvještaja

Standardni G5:

2D + koordinate:


Obrada tahimetrijskih podataka

Izbornik Promjene ››

Obrada tahimetrijskih podataka vrši se, slično kao za TGO i DT, tablicom, s razlikom da podaci unutar tahimetrijskih podataka nisu indeksirani. Unutar tablice je vrlo jednostavno izvoditi promjene, sučelje je poput poznatih tabličnih kalkulatora. Zapisi koji pod Kod imaju vrijednost 00 ( dvostruka nula ) predstavljaju ORI.

Obrada tahimetrijskih podataka

•Prikazati samo ORI

sakriva detaljne točke u tablici, ostaju samo ORI

•Računanje ORI smjerova

izračunavaju se orijentirani smjerovi za trenutno stajalište – pod uvjetom da stajalište ima određene koordinate te samo za one ORI koje također imaju određene koordinate.

•ORI grafika

Prikazivanje ORI smjerova grafički. Ako orijentirani smjer za stajalište nije poznat, podaci se računaju lokalno.

• Pretraživanje: Naziv

• Pretraživanje: ostalo

•Pretraživanje: ORI mjerenim pravcem

Pretraživanje baze podataka lokalnih i zajedničkih točaka geodetske osnove za točkama koje padaju u zamišljeni trokut – prvi vrh trokuta je stajalište, dok se drugi i treći vrh računaju iz horizontalnog pravca označenog opažanja, plus/minus 3 stupnja i na udaljenosti od 20 km. Preduvjet za računanje je da polazna stajališta imaju otprije izračunate koordinate i orijentirane smjerove.

•Izbor - do promjene visine signala

Označavanje podataka, počevši od označenog retka pa sve do sljedeće promjene visine signala za stajalište ili do kraja stajališta, što prije nastupi.

•Ubaciti zapise

ubacivanje praznih redaka u bazu, direktno iza označenog retka

•Obrisati zapise

brisanje izabranih redaka iz baze

•Podijeliti stajalište

stvara se novo stajalište u bazi, koje preuzima sve podatke nadolazeće iza označenog retka

•Promjena visine signala

promjena visine signala označenim podacima.

•Nad.Vis staj. iz mjerenja

Računanje nadmorske visine stajališta iz mjerenja na točku poznate visine. Potrebno je označiti jedan mjereni podatak te unijeti njegovu nadmorsku visinu. Rezultat se ispisuje u samo Log odjeljak, bez ažuriranja baza podataka.

•Sredina dvije ORI

izračunava se sredina dvaju ORI – praktično ako se opaža lijeva te desna strana neke ORI

•Umnožiti kao ORI

Iza označenog retka ( samo jednog ) stvara se potpuno isti redak ali bez broja točke te označen kao ORI.


Tahimetrija - pretraživanje: Naziv

Izbornik Promjene ››

Pronalazi sve zapise ( iz cijele baze podataka, ne samo iz trenutnog stajališta ) koje ima određeni naziv tj. broj točke, i po potrebi, zamjenjuje ih s novom vrijednošću.

Ako se uključi Samo pri ORI opcija, brojevi detaljnih točaka neće biti uzimani u obzir tijekom pretrage. Rezultati pretrage unose se u Log odjeljak. Za postavljanje na traženi zapis, dovoljno je dvostruko kliknuti na rezultat pretrage u Log odjeljku.


Tahimetrija - pretraživanje: ostalo

Izbornik Promjene ››

Pronalazi sve zapise (iz cijele baze podataka, ne samo iz trenutnog stajališta) koji odgovaraju unesenim zahtjevima.

Pretraživanje se vrši za podatke označene kvačicom.

Za vrijednosti Kod, Info1, Info2 vrši se alfanumeričko pretraživanje a tražena vriednost mora biti indentična unesenoj.

Za vrijednost D/ vrši se numeričko pretraživanje (123.45) uz toleranciju (0.15).

Ako se uključi Samo pri ORI opcija, brojevi detaljnih točaka neće biti uzimani u obzir tijekom pretrage. Rezultati pretrage unose se u Log odjeljak. Za postavljanje na traženi zapis, dovoljno je dvostruko kliknuti na rezultat pretrage u Log odjeljku.


Obrada podataka girusa

Izbornik Promjene ››

Girusni podaci, za razliku od tahimetrijskih, imaju puno strožu formu te je i obrada tih podataka ograničena. Stoga treba obratiti pažnju pri unosu girusnih podataka. Promjenjiva polja su samo ona koja sadrže sirove podatke ( Hz pravci, V kutovi, duljine, visine signala ). svi ostali podaci su rezultat računanja te stoga nisu ručno promjenjivi.


Obrada ortogonalnih podataka

Izbornik Promjene ››

Formular za unos i obradu ortogonalnih podataka je standardne veličine od 100 redaka, što je i najveći iznos koliko ortogonalnih podataka može biti uneseno za jednu liniju snimanja. Referentne točke linije snimanja se ne unose.

Stupac Točka predstavlja broj za novu točku. Ako nije unesen, GeoMIR5 dodjeljuje broj po formuli: predhodna+1.

Stupac Kod određuje vrstu izračunate točke:

•Kod 00 : TGO vrste mala točka

•Ostali kodovi : detaljna točka s unesenim kodom

Ako kod nije unesen preuzima se predhodni. Ako su sve točke linije snimanja TGO, naslov pri izradi izvještaja glasit će Male točke na liniji/okomici.

Apscisa je je obavezan podatak - ako nije unesen, cijeli redak se ignorira. Posljednji podatak o apscisi mora biti očitanje za završnu referentnu točku linije snimanja. Ako nije poznat,potrebno je upisati 0.

Ordinata nije obavezan podatak, za točke na liniji ostaviti prazan.


Obrada podataka geometrijskog nivelmana

Izbornik Promjene ››

Formular za unos i obradu podataka geometrijskog nivelmana je standardne veličine od 400 redaka, što je i najveći iznos koliko opažanja može biti uneseno za jedan nivelmanski vlak.

U tablicu se naizmjence unose točke te opažanja među njima. U primjeru je unesen nivelmanski vlak između točaka 605 i 606 koji prolazi točkama 701 i 703 za koje treba izračunati visinu. Točke označene kao točka "." predstavljaju papučicu tj. nebitnu točku. U primjeru je pokazano kako izgleda niveliranje s dvije visine nivelira no za iznos visina nivelira nema ograničenja.

Podaci se unose onako kako se učitavaju s letve. Nakon završetka unosa definira se koeficjent letve pritiskom na desnu tipku miša. U primjeru je prikazan unos opažanja polucentimetarske letve. Klasično očitanje letve s centimetarskom podjelom bilo bi: 1.536m upisuje se 1536 a koeficjent letve je 1/1000.

Preporuča se unošenje očitanja sve tri niti jer omogučava kontrolu očitanja kao i računanje udaljenosti do letve.

Ako je poznata vrijednost samo srednje niti i udaljenost, unosi se srednja nit te udaljenost u metrima pod polje gornje niti. Takav slučaj prikazan je u primjeru a na taj način biti će prikazani podaci elektronskog nivelira.

Zad - očitanje zadnje letve, gornja nit - ili unesena udaljenost

Zad očitanje zadnje letve, srednja nit

Zad = očitanje zadnje letve, donja nit

Pred - očitanje prednje letve, gornja nit- ili unesena udaljenost

Pred očitanje prednje letve, srednja nit

Pred = očitanje prednje letve, donja nit

Faktor letve unosi se posebnim formularom, pritiskom na desnu tipku miša:

Primjerice, očitanje centimetarske letve s procjenjivanjem milimetra:

Vrijednost: 1.563

Unos u tab.: 1563

Faktor letve: 1/1000 [ mm ]

Izračunate točke biti će upisane pod točke geodetske osnove - ako točka pod tim brojem postoji biti će promijenjena nadmorska visina a ako ne postoji, biti će stvorena nova točka samo s podacima nadmorske visine.


Obrada podataka plošnog nivelmana

Izbornik Promjene ››

Formular za unos i obradu podataka plošnog nivelmana je standardne veličine od 200 redaka, što je i najveći iznos koliko opažanja može biti uneseno.

U tablicu se unose sva opažanja plošnog nivelmana. Točke poznate nadmorske visine moraju biti označene kodom "00" (dvostruka nula) u svrhu raspoznavanja od detaljnih točaka.

Predviđen je unos sve tri niti što je preporučljivo u svrhu kontrole unosa. Ako je poznata vrijednost samo srednje niti i udaljenost, unosi se srednja nit te udaljenost u metrima pod polje gornje niti. Takav slučaj prikazan je u primjeru.

Faktor letve unosi se posebnim formularom, pritiskom na desnu tipku miša ( isto kao pri geometrijskom nivelmanu ).

Izračunate točke biti će upisane pod detaljne točke - ako točka pod tim brojem postoji biti će promijenjena nadmorska visina a ako ne postoji, biti će stvorena nova točka samo s podacima nadmorske visine.


Svojstva predmeta

Izbornik Promjene ››

U ovom odjeljku vrši se detaljno podešavanje svojstava te postavaka za određeni predmet. Radi lakšeg snalaženja, podaci su podijeljeni u grupe.

Postavljanje zone projekcije na HTRS96/TM, GeoMIR5 zahtjeva da barem jedna relevantna TGO bude unesena u lokalne TGO kako bi računanje linearnog mjerila te iz istoga dobivene korekcije duljine mogli biti ispravno određeni. Isto tako, svojstvo Linearno mjerilo mora biti podešeno na Državni sustav dok svojstvo Udaljenost od meridijana nema utjecaja na računanje. Atmosferska korekcija te redukcija na nivo plohu mora ne ovise o linearnom mjerilu te će, ako su aktivirane, biti pribrojene na korekciju duljine za linearno mjerilo.

•Ostale postavke

Vrsta TGO za nove točke | sve nove TGO biti će ovdje navedene grupe
Polazna visina signala | početna vrijednost za visinu signala
Nedefinirana visina DT | pri kojoj visini signala će DT biti neodređene nadm. vis.
Potvrditi prepisivanje DT | kada uključeno, prepisivanje DT korisnik mora potvrditi
Duljina nula je pogreška | prijaviti duljine 0.0 za DT kao pogrešne
Duljina je prevelika preko | vrijednost iznad koje se prijavljuju duljine kao pogrešne
Prepis. točaka u izvj. | protokolirati svako prepisivanje TGO u izvještaj
Slijepi PV bez pov. viz. | sliepe PV računati bez povratne vizure iako postoji
vis. Instr: 0.5<i<2.0 | ako nije, dojavit će pogrešku
vis. signal: 0.3<l<6.0 | ako nije, dojavit će pogrešku

•Pristup podacima

Poslovni broj | početna vrijednost za imena datoteka pri ispisu
Radna mapa | mapa gdje se počinje pretraživanje pri otvaranju datoteka

•Izvještaji

Zamjena za Ne-Definirano | ako podatak nije definiran, ispisuje se ova vrijednost
Param. redukcija - prošireno | ispisivanje atmosferskih vrijednosti za redukcije
Decim.mj. za koordinate | broj decimala za koordinate pri ispisu izvještaja
Naziv pol. vlaka | ispisati naziv polig. vlaka u izvještaj
Decim.mj. za površine | broj decimala za površine pri ispisu izvještaja

•Korekcije mjerene duljine

Pri računanju redukcija u državnom sustavu, uzimaju se aktualne vrijednosti stajališta.

Atmosferska | računanje redukcije, da/ne
Nivo ploha mora | računanje redukcije, Ne vršiti/Lokalni sustav/Državni sustav
Nadmorska visina | za računanje redukcija u lokalnom sustavu
Konvergencija meridijana (Linearno mjerilo) | računanje redukcije, Ne vršiti/Lokalni sustav/Državni sustav
Udaljenost od dod.mer. | za računanje redukcija u lokalnom sustavu
Temperatura [°C] | vrijednost za temperaturu zraka u [°C], ako za stajalište nije drugačije određeno
Tlak zraka [mb] | vrijednost za pritisak zraka u [mb], ako za stajalište nije drugačije određeno
Vlažnost zraka [%] | vrijednost za vlažnost zraka u [%], ako za stajalište nije drugačije određeno

•Οdstupanja

Duljine <-> | granica grube pogreške pri računanju duljina nap.-nat.
Visinska raz. <-> | granica grube pogreške pri računanju visinskih raz. nap.-nat.
ORI smjer | granica grube pogreške pri računanju orijentiranog smjera

•Jedinice

Kutne jedinice | kutne jedince za predmet
Koord. sustav | kordinatni sustav za predmet
Koef. refrakcije | vrijednost koeficijenta refrakcije

•Add. Konstante

Os Y | aditivna konstanta po osi Y, dodaje se pri manualnom unosu TGO ili DT
Os X | aditivna konstanta po osi X, dodaje se pri manualnom unosu TGO ili DT

•Objekti

Polazna tema kodiranja | ponuđena tema kodiranja za nove predmete
Polazni kod | dodijeljeni kod točke ako nije drugačije određeno
Ulovi točku | promjer za sistemski kod Ulovi točku
Duljina zatvaranja – PL: | duljina zatvaranja za linijske objekte
Duljina zatvaranja - SY | duljina zatvaranja za znakovlje
Decim.mj. za atribute | broj decimalnih mjesta za vrijednosti u atributima blokova
Decim.mj. za DWG | broj decimalnih mjesta za ispis elemenata u DWG

• Položajne točnosti

Početna vr. za Drž pol. točke [cm] | Početna vrijednost
Početna vr. za trig. točke [cm] | Početna vrijednost
Početna vr. za ostale unensene točke [cm] | Početna vrijednost, ako =0 onda je nedefinirano


Predlošci predmeta

Izbornik Promjene ››

Predlošci predmeta su svojstva predmeta pohranjena pod određenim nazivom. Svrha predložaka predmeta je olakšavanje rada sa svojstvima predmeta pogotovo ako se radi za različite investitore gdje pojedina svojstva predmeta moraju biti posebno podešena.

Formular za svojstva predmeta ima sljedeće tipke:

•Novo

stvaranje novog predloška predmeta baziranog na svojstvima trenutnog predmeta. Potrebno je unijeti naziv za predložak.

•Promjene

svojstva trenutnog predmeta će biti upisana u izabrani predložak, to jest stari podaci biti će prepisani

•Izbrisati

brisanje izabranog predloška

•Učitati

svojstva iz izabranog predloška će biti učitana u trenutni predmet


Kategorije terena

Izbornik Promjene ››

Određivanje kategorije terena te korištenog instrumenta za računanje največih dozvoljenih odstupanja u poligonskim vlakovima.

Ako je označeno polje Pohraniti postavke kao predložak, ovdje određene vrijednosti biti će predložak za sve predmete gdje ove vrijednosti nisu bile promijenjene ( što znači i za postojeće predmete ako kategorija terena nije bila mijenjana ).


Izbornik Računati

Izbornik računati je stvarna svrha programa GeoMIR, sve ostale radnje samo pomažu kako bi ovdje išlo što lakše i brže. Rezultat računanja su:

•Detaljne točke

računanje detaljnih točaka – interaktivno ili automatski. Točke istog broja biti će bez upozorenja prepisane.

•Točke geodetske osnove

sve ostale radnje. Ne postoji li točka u bazi podataka, biti će stvorena nova s vrstom točke određenome unutar svojstava predmeta. Postoji li, pojavljuje se formular za odluku.


Ista TGO

Izbornik Računati ››

Ako nakon računanja, prilikom unosa u bazu podataka, GeoMIR5 ustanovi da točka s istim brojem kao novoodređena točka postoji, prijavljuje korisniku te pruža mogučnost izbora što dalje.

Grupa točaka predstavlja određenu cjelinu, npr. sve točke novo izračunatog poligonskog vlaka.

•Prepisati - NOVA umjesto stare

novi podaci prepisuju stare, za sljedeću točku grupe ponovno pitanje

•SVE prepisati - NOVA umjesto stare

novi podaci prepisuju stare, za cijelu grupu točaka

•Sredina iz nove i stare vrijednosti

samo pri računanju slobodnog stajališta moguće, računa aritmetičku sredinu stare i nove vrijednosti

Preskočiti - ostaviti STARU vrijednost

stari podaci ostaju u tablici, za sljedeću točku grupe ponovno pitanje

•SVE preskočiti - ostaviti STARE vrijednosti

Stari podaci ostaju u tablici, za cijelu grupu točaka

Tipka OK izvršava zadanu radnju, tipka Prekid prekida izvršenje radnje za cijelu grupu točaka.


Poligonski vlakovi - priprema

Izbornik Računati ››

Udružuje sve radnje vezane za računanje položajnih ili visinskih vlakova. Podržane vrsta vlakova:

Položajni:

obostrano priključen ( početna i završna poznata točka imaju ORI )

koordinatno priključen ( samo početna poznata točka ima ORI )

koordinatno ukopljen ( i početna i završna poznata točka točka bez ORI )

slijepi ( početna poznata točka ima ORI, završna nije poznata )

Visinski ( K-obrazac ):

obostrano priključen

slijepi

Računanje vlaka vrši se unosom redoslijeda točaka vlaka u za to predviđeno polje te nakon toga se odabire kakvu vrstu vlaka treba izračunati pritiskom na za to predviđeni simbol. Objašnjenje sintakse:

Iz gornje grafike lako je za zaključiti kako se unose točke u polje. Za olakšavanje unosa postoje dva znaka s posebnim značenjem:

+ : unosom znaka 'plus' umjesto prvog reda ( 5012114/11/14 ) dajemo programu zadatak da pronađe sve moguće vizure s stajališta 12.

< : unosom znaka 'manje od' u tijeku unosa točaka, GeoMIR5 unosi sve sljedeće točke vlaka do prvog grananja ili završetka vlaka.

Ovo je primjer unosa obostrano priključenog vlaka.

Pri unosu vlaka priključenog po koordinatama otpada posljednji red jer nema završnih orijentacija ali točka 1001 mora imati poznate koordinate.

Pri unosu vlaka uklopljenog po koordinatama otpadaju prvi i posljednji red jer takav vlak počinje i završava na poznatim točkama ali s njih nema orijentacija.

Pri unosu slijepog vlaka potrebni su samo podaci za računanje početnog smjernog kuta.

Pri računanju visinskih vlakova otpadaju podaci za računanje smjernih kutova, tj. unose se točke, iz gornjeg primjera, od 12 do 1001.

Računanjem položajnih vlakova, GeoMIR5 pokušava istovremeno izračunati i visinski vlak, ako početna/završna točka imaju definiranu visinu.

Nakon unosa točaka vlaka, potrebno je, pritiskom na željeni simbol, odrediti kakvu vrstu vlaka treba izračunati. U tome trenutku počinje proces računanja – završetak procesa može biti na dva načina.

Ako je došlo do pogreške/pogrešaka, iste će biti ispisane u Log odjeljak i proces računanja biti će prekinut – ako ne prikazuje se formular za detaljno podešavanje vlaka.

Izjednačenje vlaka vrši se razbacivanjem pogrešaka proporcionalno duljinama stranica vlaka. Ako je moguće, računa se kumulativna pogreška za svaku točku vlaka.

Ako je opcija Naslov poligonskog vlaka uključena, za svaki sračunati poligonski ili visinski vlak potrebno je unijeti naslov vlaka. GeoMIR5 nudi brojeve redom počevši od jedan.


Poligonski vlakovi - računanje

Izbornik Računati ››

Formular za detaljno podešavanje vlaka

•Padajućim izbornikom gore lijevo

određuje se kako izračunati vlak. Ponuđene vrste vlaka ovise o vrsti vlaka kojom je krenuto u računanje.

•Računati visinski vlak

da ili ne. Ako nije moguće, polje nije dostupno.

•Početni smjerni kut

utjecanje na vrijednost fSKp u rezultatima

•Završni smjerni kut

utjecanje na vrijednost fSKz u rezultatima

•Rezultati

ocjena točnosti i duljina vlaka, u uglatim zagradama su dozvoljena odstupanja

•Prikazati potpune izvještaje

ako je označeno, prikazuju se upozorenja i izvještaji ,ako nije samo upozorenja.

•Štampa

prikazivanje izvještaja u print-preview uz mogućnost štampanja

•Pohraniti izvještaje

ako je označeno, pohranjuju se izvještaji nakon računanja u bazu podataka. Vrijedi samo ako je pritisnuta tipka OK.

•OK

prihvaćanje izračunatih podataka, ažuriranje točaka i pohrana izvještaja ( ako označeno )

•Prekid

prekid računanja


Računanje detaljnih točaka - interaktivno

Izbornik Računati ››

GeoMIR5 izračunava orijentirane smjerove za sva označena stajališta, bez obzira imaju li detaljne točke ili ne. Moguće je izračunavanje orijentiranih smjerova za stajališta s girusnim podacima iako ona nemaju detaljne točke. Stajališta koja imaju izračunate orijentirane smjerove mogu biti korištena za automatsko računanje detaljnih točaka te presjeka naprijed.

Kako se vidi, za svako stajalište je moguće utjecati na orijentacije iz kojih se računa orijentirani smjer. Crveno su prikazana stajališta gdje pogreška orijentiranog smjera prelazi dozvoljeno odstupanje, žuto stajališta koja su u redu te zeleno stajališta za koja nije bilo moguće izračunati orijentirani smjer. U posljednjem slučaju biti će upisati upozorenja ispod tablice.

  • Izračunati orijentirane smjerove , bez DT

GeoMIR5 će itvršiti sve radnje osim računanja detaljnih točaka.

  • Računati

računanje koordinata TGO koje nedostaju – samo unaprijed, povratna vizura se ne uzima u obzir. Tablica se automatski osvježava. Novoizračunatim TGO moguće je odrediti vrstu tocke .

  • ORI najv. dozv.ods

određivanje granice za crvene/žute oznake pogreške orijentiranog smjera . Početno se uzima vrijednost iz svojstva predmeta.

  • OK

prihvaćanje promjena te prelazak na računanje točaka. GeoMIR5 preuzima odabir orijentacija te vrijednost orijentiranog smjera u bazu podataka stajališta. Dođe li do pogrešaka tijekom računanja detaljnih točaka, ispisuju se u Log odjeljak glavnog sučelja

  • Prekid

prekid računanja


Računanje detaljnih točaka - automatski

Izbornik Računati ››

Računanje detaljnih točaka za izabrana stajališta bez interakcije – prethodno moraju biti, iz interaktivnog računanja , izračunati orijentirani smjerovi, inače se dojavljuje pogreška.


Automatsko računanje

Izbornik Računati ››

Automatskim računanjem označenih stajališta GeoMIR5 pokušava, na osnovu postojećih koordinata te podataka mjerenja, polarnom metodom računanja, izračunati koordinate točaka koje još nisu izračunate. Postupak je automatski i iteracijski.

Nakon računanja pojavljuje se formular koji sadrži sažetak računanja te eventualne nelogičnosti ili pogreške. Tek pritiskom na tipku OK, izračunate koordinate biti će ažurirane u bazu podataka. Korisnik može odrediti koje vrste će biti nove točke.


Priključak na visinu

Izbornik Računati ››

Računanje nadmorske visine za odabrano stajalište. GeoMIR5 tada predlaže s kojih orijentacija je moguće preuzeti visinu. U polju za izbor orijentacija označuju se točke s kojih se preuzima visina.

•Štampa

prikazivanje izvještaja u print-preview uz mogućnost štampanja

•Pohraniti izvještaje

ako je označeno, pohranjuju se izvještaji nakon računanja u bazu podataka. Vrijedi samo ako je pritisnuta tipka OK.

•OK

prihvaćanje izračunatih podataka, ažuriranje točaka i pohrana izvještaja ( ako označeno )

•Prekid

prekid računanja


Slobodno stajalište

Izbornik Računati ››

Računanje koordinata za odabrano stajalište na koje nije bilo opažano s neke poznate točke. Stajalište mora biti izabrano u popisu stajališta. U polju za izbor orijentacija označuju se točke uključene u računanje. GeoMIR4 nudi dva različita načina za računanje koordinata:

  • Referentnom točkom

koristiti kada je opažano na najmanje dvije poznate točke s time da je na najmanje jednu morala biti mjerena duljina.

  • Transformacijom

koristiti kada je na najmanje tri poznate točke bila mjerena duljina. Koordinata stajališta računa se transformacijom koordinata – za tri poznate točke Helmertova, za više od tri Afina.

Postoje li prekobrojna mjerenja, dobivena koordinata postaje približna vrijednost za izjednačenje posrednih mjerenja Gaussovom teorijom najmanjih kvadrata popravaka. Iz izjednačenja dobivene vrijednosti sy i sx su standardna odstupanja kao ocjena točnosti.

  • Štampa

prikazivanje izvještaja u print-preview uz mogućnost štampanja

  • Pohraniti izvještaje

ako je označeno, pohranjuju se izvještaji nakon računanja u bazu podataka. Vrijedi samo ako je pritisnuta tipka OK.

  • OK

prihvaćanje izračunatih podataka, ažuriranje točaka i pohrana izvještaja ( ako označeno )

  • Prekid

prekid računanja


Presjek naprijed

Izbornik Računati ››

Računanje koordinata točke opažane sa najmanje dva stajališta. Nakon pozivanja radnje potrebno je unijeti traženu točku nakon čega GeoMIR5 sam pronalazi sva stajališta s kojih je opažano na traženu točku. Preduvjet je da stajališta imaju otprije izračunate koordinate i orijentirane smjerove .

Prve dvije označene točke iz popisa stajališta uzimaju se za računanje približne koordinate. U polju za izbor stajališta označuju se točke uključene u računanje. Moguća je promjena redosljeda točaka iz popisa stajališta jednostavnim povlačenjem odabrane točke.

Postoje li prekobrojna mjerenja, dobivena koordinata postaje približna vrijednost za izjednačenje posrednih mjerenja Gaussovom teorijom najmanjih kvadrata popravaka. Iz izjednačenja dobivene vrijednosti sy i sx su standardna odstupanja te elipsa pogreške kao ocjena točnosti.

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled računanja u apsolutnim koordinatama.

•Štampa

prikazivanje izvještaja u print-preview uz mogućnost štampanja

•Pohraniti izvještaje

ako je označeno, pohranjuju se izvještaji nakon računanja u bazu podataka. Vrijedi samo ako je pritisnuta tipka OK.

•OK

prihvaćanje izračunatih podataka, ažuriranje točaka i pohrana izvještaja ( ako označeno )

•Prekid

prekid računanja


Presjek naprijed - detaljne točke

Izbornik Računati ››

Računanje koordinata detaljnih točaka, za koje nije bilo moguće direktno mjerenje duljine, opažanih sa dva stajališta. Preduvjet je da polazna stajališta imaju otprije izračunate koordinate i orijentirane smjerove .

Detaljne točke koje je potrebno izračunati moraju biti opažane sa oba stajališta te u svrhu raspoznavanja moraju imati u stupcu Info1 unešenu jednoznačnu oznaku, kojom će biti prepoznati kao parovi. Ta jednoznačna oznaka biti će nakon računanja upotrijebljena kao broj izračunate detaljne točke.

Primjer:

Polazne točke geodetske osnove su 10 i 11, sa obje je opažana povratna vizura te smjerovi na tri detaljne točke koje treba odrediti presjekom naprijed.

Koordinate točaka geodetske osnove:

Opažanja sa stajališta 10:

Opažanja sa stajališta 11:

Prvo provesti uobičajeno računanje detaljnih točaka, te odmah zatim Računanje DT presjecanjem naprijed.

Smjerom DT 101 (staj. 10) i DT 104 (staj. 11) dobit će se DT 201

Smjerom DT 102 (staj. 10) i DT 105 (staj. 11) dobit će se DT 202

Smjerom DT 103 (staj. 10) i DT 106 (staj. 11) dobit će se DT 203

Izračunate koordinate detaljnih točaka

Detaljne točke pod brojevima 201, 202, 203 predstavljaju točke dobivene presjekom naprijed ( obratiti pažnju na stupac Info1 pod tahimetrijskim podacima ). Detaljne točke pod brojevima 101, 102, 103 imaju identične koordinate kao stajalište 10 dok detaljne točke pod brojevima 104, 105, 106 imaju identične koordinate kao stajalište 11.


Presjek natrag

Izbornik Računati ››

Računanje koordinata za odabrano stajalište na koje nije bilo opažano s neke poznate točke, samo pomoću kutova.

Prve tri točke iz popisa orijentacija uzimaju se za računanje približne koordinate.

Postoje li prekobrojna mjerenja, dobivena koordinata postaje približna vrijednost za izjednačenje posrednih mjerenja Gaussovom teorijom najmanjih kvadrata popravaka. Iz izjednačenja dobivene vrijednosti sy i sx su standardna odstupanja te elipsa pogreške kao ocjena točnosti.

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled s prikazanim vizurama u relativnim koordinatama.

•Štampa

prikazivanje izvještaja u print-preview uz mogućnost štampanja

•Pohraniti izvještaje

ako je označeno, pohranjuju se izvještaji nakon računanja u bazu podataka. Vrijedi samo ako je pritisnuta tipka OK.

•OK

prihvaćanje izračunatih podataka, ažuriranje točaka i pohrana izvještaja ( ako označeno )

•Prekid

prekid računanja


Transformacije koordinata

Izbornik Računati ››

GeoMIR5 podržava dva načina transformacije koordinata:

  • Računanjem lokalnih parametara preko identičnih točaka

Računanje parametara transformacije vrši se u zasebnom formularu odvojeno od samog procesa transformacije . Na taj način moguće je prvo izračunati parametre, pohraniti ih te naknadno po potrebi koristiti za transfrormacije. Pohrana parametara može biti u trenutni predmet ili vidljivo iz svih predmeta.

  • Međudatumska transformacija

Međudatumska transformacija omogučava HTRS96/TM<->HDKS preračunavanje koordinata korištenjem jednog od modela:

- jedinstveni parametri transformacije uz popravku distrozije. Rezultati odgovaraju rezultatima dobevenim softverom T7D u par milimetara.

- službeni parametri transformacije za homogena polja

Koordinate mogu biti transformirane u oba smijera.


Transformacija koordinata - računanje parametara

Izbornik Računati ››

Parametri se računaju iz parova istovjetnih točaka koje moraju biti pohranjene, bilo kao detaljne ili točke geodetske osnove.

Točke navedene u stupcu Polazne predstavljaju točke iz nekog lokalnog sustava a one u stupcu Završne točke u sustavu koji želimo dobiti. Navedene točke moraju postojati kao detaljne ili kao točke geodetske osnove. Detaljne točke je potrebno označiti zvjezdicom "*" prije broja točke u svrhu raspoznavanja ( primjerice, unesena vrijednost "101" predstavlja točku geodetske osnove a vrijednost "*101" detaljnu točku ).

Ako se sve ovdje unesene točke nalaze u bazi podataka, prikazat će se formular za računanje paametara:

•Padajuči izbornik u vrhu formulara

izbor vrste transformacije

•Stupac slijeva

Uneseni parovi točaka. U računanje se uzimaju samo točke s kvačicama slijeva.

•Stupac zdesna

Prikaz točnosti transformacije, u metrima:

syx: točnost svake pojedine koordinate

sp: točnost transformirane vrijednosti

Osim ovih prikaza točnosti, koordinate referentnih točaka iz polaznog sustava se transformiraju po dobivenim parametrima te uspoređuju s koordinatama istovjetnih točaka iz ciljnog sustava. Vrijednost fd predstavlja odstupanje tih koordinata. U praksi je to vrlo dobar način za pronalaženje točaka koje nisu homogene.

•Naziv za parametre

Već je spomenuto da je izračunate parametre potrebno pohraniti za daljnu uporabu. Pohrana se vrši pod ovde unesenim nazivom ( predloženi naziv je datum i vrijeme ). Označavanjem kvačice pri Pohraniti parametre kao zajedničke, parametri će biti pohranjeni kao zajednički te će biti vidljivi iz svih predmeta.

•Obrisati parametre

Nepotrebni parametri mogu ovdje biti obrisani. Potrebno je samo označiti željene parametre iz popisa i pritisnuti OK.


Transformacija koordinata - transformiranje

Izbornik Računati ››

Transformiranje koordinata vrši se direktnim izborom točaka koje je potrebno transformirati. Postupak je isti za točke geodetske osnove kao i za detaljne točke.

Primjerice, otvoriti formular za obradu točaka geodetske osnove, označiti točke za transformaciju, pritisnuti desnu tipku miša te odabrati Transformacija koordinata.

Parametri transformacije:

•Lokalno izračunati parametri

Iz padajučeg izbornika potrebno je izabrati parametre prema nazivu.

•Međudatumska transformacija

Potrebno je izabrati polazni i izlazni koordinatni sustav te po potrebi dodatne parametre. Dostupni su samo parametri vezani uz izabrani koordinatni sustav.

Ako se često vrši transformacija koordinata prema istim parametrima, savjetuje se pohrana podataka kao polaznih za druge predmete.

Oznake točaka nakon transformacije:

•Bez promjene

Polazne koordinate će biti prepisane s novodobivenima. Na taj način ne nastaju nove točke.

•Prenumeracija alfanumerički - dodati prefix

Polazne točke ostaju nepromijenjene, novodobivene vrijednosti će biti pohranjene kao nove točke.

Broj točke biti će dobiven tako da se polaznom broju točke doda alfanumerički prefiks ( primjerice, za polazni broj "125" i prefix "N_", nova točka će biti "N_125").

•Prenumeracija numerički - dodati vrijednost

Polazne točke ostaju nepromijenjene, novodobivene vrijednosti će biti pohranjene kao nove točke.

Broj točke biti će dobiven tako da se polaznom broju točke numerički pribroji unesena vrijednost ( primjerice, za polazni broj "125" i vrijednost "1100", nova točka će biti "1225").

•Prenumeracija numerički - novi početni broj

Polazne točke ostaju nepromijenjene, novodobivene vrijednosti će biti pohranjene kao nove točke.

Prvi novi broj točke će biti unesena vrijednost za svi daljnji uvećani za jedan.

Kutne jedinice koordinata

Ako je jedan od koordinatni sustava WGS84, potrebno je odrediti u kojim kutnim jedinicama su predočene koordinate.


Unos točaka

Izbornik Računati ››

Unos točaka je uobičajeni editor koji služi kao polazna točka pri određenim računanjima. U ovisnosti o vrsti računanja, mijenja se sintaksa unosa podataka a računanje se vrši izborom radnje u kontekst izborniku ( desna tipka miša ).

Računanje površina

Preuzimanje površina iz CAD-a

Elementi iskolčenja

Smjerni kut i duljina

Točka na pravcu

Presjek pravaca

Lučni presjek


Analitičko računanje površina

Izbornik Računati ›› Unos točaka ››

Analitičko računanje površina za točke unesene u polju Unos točaka. Osim unosa točaka ručno, moguće je preuzimanje pripremljenih površina iz ActCAD-a . Ovakav način računanja i ispisa pogodan je za prikaz u elaboratima. Sintaksa:

Izračunat će se površina za točke 100061, 100062, 100067, 100070. Obavezno je u prvi redak unijeti oznaku površine, u drugi redak kosu crtu ( / ) te nadalje točke koje omeđuju površinu. Zvjezdicom ( * ) se razlikuju točke TGO od DT. Nekoliko primjera unosa točaka:

101 - TGO

*101 - DT

102 - TGO

ili

101 - TGO

*

101 - DT

102 - DT

Oznaka površine može biti alfanumerička. Iako pri unosu mora biti u jednom retku, ispis može biti u više redaka - dovoljno je kao prijelom retka unijeti točku-zarez ( primjerice, unos Redak1;Redak2 biti će ispisan kao

Redak1

Redak2 ).

Decimalna mjesta površine ovise o broju decimalnih mjesta pri ispisu izvještaja ( svojstva predmeta, izvještaji, decimalna mjesta ), i to faktorom -2. Primjerice, ako je broj decimala pri ispisu izvještaja jednak dva, površina će biti ispisana cjelobrojnom vrijednošću.

Izvještaj može biti po želji pohranjen a u svakom slučaju biti će prikazan u PrintPreview formularu.


Elementi iskolčenja

Izbornik Računati ›› Unos točaka ››

Računanje elemenata iskolčenja za točke unesene u polju Unos točaka. Sintaksa:

Računaju se elementi iskolčenja sa stajališta 14, na orijentacijske točke 13 i 11 te detaljne točke 100355 i 100356. Nula će biti za točku 13. Ako stajalište i tražena točka imaju definiranu visinu, biti će izračunat i vertikalni kut za visinsko iskolčenje. Visina signala mora biti identična visini instrumenta.

GeoMIR5 računa duljine uzimajući u obzir obrnutu korekciju.

Zvjezdicom ( * ) se razlikuju točke TGO od DT. Nekoliko primjera unosa točaka:

101 - TGO

*101 - DT

102 - TGO

ili

101 - TGO

*

101 - DT

102 - DT


Smjerni kut i duljina ( osmi obrazac )

Izbornik Računati ›› Unos točaka ››

Računanje smjernih kuteva i duljina za parove točaka odvojenih kosom crtom "/". Izračunati podaci imaju svrhu izvještaja.

Ako obje točke para imaju definirane koordinate biti će izračunati smjerni kut i duljina te pohranjen izvještaj ( popularni TOB 8 ).


Točka na pravcu

Izbornik Računati ›› Unos točaka ››

Računanje koordinata točke koja leži na unesenom pravcu. Računa se udaljenost od druge unesene točke a postoje dvije mogućnosti:

- ako je udaljenost pozitivna, računa se udaljenost od druge točke udaljujući se od prve

- ako je udaljenost negativna, računa se udaljenost od druge točke približavajući se prvoj

Sintaksa:

Prvi redak - početna i završna točka pravca, odvojene znakom " / "

Drugi redak - udaljenost od druge točke, pozitivna ili negativna

Treći redak - oznaka nove točke

Napomena - točke s predznakom "*" su detaljne točke, bez predznaka su točke geodetske osnove.


Presjek pravaca

Izbornik Računati ›› Unos točaka ››

Računanje koordinata točke koja leži na presjeku dva pravca, bez obzira nalazi li se presjek unutar unesenih točaka ili u produžetku pravaca. Nema rješenja ako su pravci paralelni. Sintaksa:

Prvi redak - početna i završna točka prvog pravca, odvojene znakom " / "

Drugi redak - početna i završna točka drugog pravca, odvojene znakom " / "

Treći redak - oznaka nove točke

Napomena - točke s predznakom "*" su detaljne točke, bez predznaka su točke geodetske osnove.


Lučni presjek

Izbornik Računati ›› Unos točaka ››

Računanje koordinata točke koja leži na presjeku dvije kružnice. Nema rješenja ako se kružnice ne sjeku, jedno rješenje ako je presjek točno na pravcu, dva rješenja u svim ostalim slučajevima. Kao presjek se uzima točka s desna gledajući s prve točke prema drugoj. Sintaksa:

Prvi redak - prva točka te s nje odmjerena udaljenost, odvojeno znakom " / "

Drugi redak - druga točka te s nje odmjerena udaljenost, odvojeno znakom " / "

Treći redak - oznaka nove točke

Unesene udaljenosti biti će korigirane prema definiranim parametrima korekcije za duljine.

Napomena - točke s predznakom "*" su detaljne točke, bez predznaka su točke geodetske osnove.


Udaljenost između dvije TGO

Izbornik Računati ››

Prikazivanje svih udaljenosti između dvije točke geodetske osnove. Unos je u obliku P1/P2, gdje je P1 prva TGO a P2 druga TGO ( primjerice, 2/3 prikazuje udaljenosti između točaka 2 i 3).

Prikazuje se, ako je moguće izračunati, udaljenost iz koordinata kao i udaljenosti iz mjerenih podataka.


Udaljenost izmedu TGO iz koordinata

Izbornik Računati ››

Računanje svih mogućih udaljenosti iz svih lokalnih točaka geodetske osnove. Rezultati se prikazuju ispisom u datoteku ( predloženo SveUdaljenosti.TXT ), koju korisnih pohranjuje u mapu po želji. Izgled podataka:

38.451 :: 2 <-> 3

53.711 :: 2 <-> 145

79.129 :: 145 <-> 3

Podaci su sortirani po udaljenostima. Primjer pokazuje ispis kada se u lokalnim točkama geodetske osnove nalaze tri točke: 2, 3 i 145.


Izbornik Izjednačenje mreže

U GeoMIR5 je ugrađen trenutno aktualan geodetski matematički model izjednačenja podataka mjerenja Gaussovom teorijom najmanjih kvadrata popravaka!

Uvođenjem novog matematičkog modela može se reći da klasične računske operacije padaju stepenicu niže i trebale bi služiti samo za računanje približnih koordinata. U izjednačenje mreže ulaze sva opažanja u zajednički model - ako je više poligonskih vlakova vezano u mrežu ( čvorna točka ), sve orijentacije na daleke točke i slično.

Radi se samo o jednom od modela izjedačenja podataka mjerenja no međunarodno je najbolje prihvaćen jer slijedi pravila važečih zakonitosti statistike te ne samo da daje izjednačene koordinate neko i statističke ocjene točnosti koordinata i opažanja.

Jedna od takvih ocjena točnosti je i elipsa 95% razine povjerenja koja prikazuje položajnu nesigurnost te te predstavlja jednu od vrijednosti iskazivanja točnosti pozicioniranja ( DGU - pravilnik o načinu izvođenja osnovnih geodetskih radova ).

Sve formule i primjeri preuzeti su iz međunarodne literature te iz javnih praktičnih radova. U ovom uputstvu neće se ulaziti detaljno u teoriju izjednačena posrednih mjerenja te procesa matričnog izjednačenja, već će naglasak biti na procesu provođenja izjednačenja od strane korisnika.

Pretpostavka za izjednačenje Gaussovom teorijom najmanjih kvadrata je poznavanje približnih vrijednosti koordinata. Što su točnije približne koordinate to će biti bolje izjednačenje. Proces izjednačenja može biti sljedeći:

1- Koordinate točaka izračunati klasičnim računskim operacijama poput poligonskih vlakova ili slobodnog stajališta. Takvim pristupom korisnik može uočiti eventualne pogreške mjerenja te ih ispraviti.

2- Provesti izjednačenje.


Izjednačenje mreže 2D

Izbornik Izjednačenje mreže ››

U stručnoj literaturi postoji mnogo oprečnih mišljenja treba li izvoditi 2D ili 3D izjednačenje. U praksi se 3D model izjednačenja pokazao kao matematički nestabilan stoga GeoMIR5 koristi čisto 2D izjednačenje posrednih mjerenja.

Prije ulaska u izjednačenje potrebno je izračunati koordinate točaka jednim od klasičnih računskih operacija.

Računanje izjednačenja se pokreče se izborom stajališta koja će uči u proces izjednačenja. Stajalište može samo jednom biti odabrano! Primjerice, ako je na jednoj točci bilo više puta stajano, samo jedno može ući u izjednačenje. U takvom slučaju, moguće je izvršiti radnju Spojiti dva stajališta.

Nakon što su stajališta odabrana, izbornikom Izjednačenje mreže ili ikonom ž poziva se formular za proces izjednačenja, koje ima tri koraka:

1 - Opažanja

2 - Točke

3 - Odjeljak Parametri

Nakon što su sva tri koraka izvršena, pritiskom na tipku pokreće se proces izjednačenja. Nakon izjednačenja, u dnu formulara se ispisuje kratak rezultat izjednačenja.

Tipkom "Ispis" prikazuje se detaljan izvještaj .

Tipkom "Pohraniti" pohranjuju se nove koordinate u bazu podataka i ispisuje detaljan izvještaj.


Odjeljak Opažanja

Izbornik Izjednačenje mreže ›› Izjednačenje mreže 2D ››

Sličan je računanju detaljnih točaka a služi za isključivanje neželjenih opažanja iz procesa izjednačenja.

Podatak iz padajućeg izbornika iz dna slike služi sa određivanje granice grube pogreške, kako bi odstupanja bila prikazana crveno


Odjeljak Točke

Izbornik Izjednačenje mreže ›› Izjednačenje mreže 2D ››

Služi za određivanje koje točke idu u izjednačenje kao nepoznanice a koje kao poznate točke.

Prvo je potrebno pokrenuti ažuriranje popisa pritiskom na tipku. GeoMIR5 pretražuje sve podatke iz popisa stajališta ( prethodni odjeljak - opažanja ) i pokušava zaključiti koje točke spadaju u koju grupu. Točke koje će biti nepoznanice u drugom stupcu nisu označene, dok poznate točke imaju oznaku. Obavezno treba provjeriti i po potrebi popraviti rezultat pretraživanja.

Iz primjera će točke 108 i 110 uči u izjednačenje kao nepoznanice.

1. stupac - redni broj točke

2. stupac - neoznačene točke su nepoznanice

3. stupac - broj točke

4. stupac - položajna točnost za nepromjenjive točke

5. stupac - opis točke


Odjeljak Parametri

Izbornik Izjednačenje mreže ›› Izjednačenje mreže 2D ››

U prethodna dva odjeljka određeno je što se izjednačuje, ovdje je potrebno odrediti kako se izjednačuje.

Standardna odstupanja a-priori služe za računanje težina koje ulaze u matrično računanje. Vrlo je važno unijeti stvarne vrijednosti jer inače se dobije pogrešna slika o stanju mreže. Vrijednosti koje se ovdje unose, odnose se na instrument kojim je mjerenje provedeno.

Vrsta mreže:

•Uklopljena mreža

Najčešći slučaj kada se izjednačenje vrši za potrebe katastra i sličnih radova. Ono podrazumijeva da su ulazne poznate točke bezpogrešne te se mjerenja uklapaju u postojeću mrežu, najčešće državnu.

•Dinamička mreža

Pogodna za progušćavanje mreža gdje ulazne poznate točke imaju poznata standardna odstupanja. Neke države polaze od procijenjenih standardnih odstupanja kako bi nove točke dobile realnije popravke - no mišljenja o ovom načinu izjednačenja su podjeljena. Pravi rezultati se dobivaju samo ako ulazne poznate točke imaju standardna odstupanja dobivena iz nekog prethodnog izjednačenja. Ovim načinom izjednačenja i ulazne poznate točke dobivaju popravke a moguće je utjecati hoće li njihove popravljene koordinate biti ažurirane u bazi podataka.

•Slobodna mreža

Poseban način izjednačenja gdje se sve ulazne točke smatraju nepoznanicama te se sve popravljaju. Karakteristika ovog izjednačenja je da završne koordinate ovise samo o točnosti mjerenja bez ikakve ovisnosti o postojećim mrežama. Praktična uporaba bila bi pri izradi mikrotriangulacije ili neovisnih mreža visoke točnosti, a postupak bi trebao biti u dva dijela.


Izvještaj izjednačenja

Izbornik Izjednačenje mreže ›› Izjednačenje mreže 2D ››


Izbornik Objekti

Sve radnje koje se odnose na kodirano mjerenje detalja nalaze se u izborniku Objekti. Program GeoMIR5 omogućava korisniku definiranje tablica kodova za snimanje detalja te široku paletu mogućnosti podjele na detaljne listove po Državnom pravilniku kao i direktno prebacivanje istih podataka u CAD softver.

Objekti su sastavni dio programa GeoMIR5 koje klasični geodetski zadatak snimanja stvarnog stanja proširuje u toj mjeri da rezultat računanja nije više samo detaljna točka s brojem točke, koordinatom i visinom nego dio određenog objekta poput zgrade ili ceste te pruža mogućnost prijenosa podataka direktno u CAD alate. No, da bi se do jednog takvog rezultata došlo potrebno je prihvatiti kodirano snimanje detalja te definirati svaki kod posebno.


Općenito o kodiranju

Izbornik Objekti ››

Uvođenje kodiranog načina mjerenja stvarnog stanja znači pružiti geodetskom stručnjaku na terenu mogućnost samostalne izrade plana. Verzirani geodetski stručnjaci trebaju skicu samo za upisivanje dodatnih odmjeravanja ili informacija jer sve o mjerenim podacima nalazi se već u instrumentu. Postupak je jednostavan - prije snimanja svake detaljne točke treba upisati određenu informaciju u instrument koja jednoznačno određuje snimljeni objekt. Takva informacija naziva se kod detaljne točke a svi moderni instrumenti ( elektronički tahimetri ili totalne stanice ) pružaju mogućnost unosa kodova. Neki od instrumenata pružaju također mogućnost unosa određenih informacija za kodove ( npr. Leica ) tako da za jedan kod može biti definirano nekoliko informacija što povećava broj slobodnih kodova za definiranje. GeoMIR5 podržava takve informacije.

Kodiranje podržano softverom GeoMIR5:

Kako ne postoje standardi za snimanje podataka i za način njihova prikaza u grafičkim programima došlo je do razvoja velikog broja sistema za kodiranje i za kasniju obradu mjerenih podataka unutar grafičkog programa. GeoMIR5 pruža jedan od njih koji se pokazao u praksi kao jednostavan ali i kao sistem koji pruža jednostavno predstavljanje mjerenih objekata uz što manje hodanja. Karakteristike:

- sistemskim kodovima je rješeno završavanje objekata i razne konstrukcije

- na jednoj mjerenoj točci moguće je upisati više kodova

- više kodova mogu biti otvoreni u jednom trenutku

- jedan kod može predstavljati samo jedan objekt u jednom trenutku

- jedna mjerena točka može predstavljati više objekata, primjerice kraj zida, početak građevine

Ako jedna točka predstavlja više od jednog objekta, softver mora znati gdje završava jedan a gdje počinje drugi. Raspoznavanje kodova je moguće na dva načina – stalnom duljinom koda ili unosom razdjelnika. Način raspoznavanja kodova određuje se za temu kodiranja te unutar iste ne može biti mijenjan.

Pojam teme kodiranja:

Pojam teme kodiranja je osnova svih podataka o kodiranju a predstavlja definicije kodova te neke dodatne informacije potrebne za ispravan prikaz podataka. Najčešće se takve teme kodiranja određuju prema zahtjevima investitora pa je to i nekako najčešći način označavanja tema kodiranja, npr. ‘elektra’ ili ‘Katastar’. Korisnik može definirati neograničen broj tema kodiranja a one su vidljive iz svih predmeta.

Pojam predloška ( template ):

Svaka tema kodiranja zahtjeva CAD predložak - prazan crtež koji sadrži sve potrebne layere i definicije blokova. Tema kodiranja DGU_ZBIRKA1000 je vezana uz predložak koji je baziran na zbirci blokova izrađenih od strane DGU, sa nekim modifikacijama i dodacima. U njemu su blokovi definirani kao za mjerilo 1:1000, znači blokovi u mjerilu 1:500 imati će faktor omjera (scale factor) 0,5.

Pojam objekta:

U klasičnom mjerenju, mjerena točka je samo podatak o njenom broju i koordinatama a tek uz predočenje skice mjerenja ona postaje nosilac nekog topografskog podatka. Pri kodiranom mjerenju detalja kod detaljne točke preuzima na sebe ‘skicu’ i unaprijed se zna što će ona biti, rub kolika ili slivnik. Tako dobiveni topografski podatak naziva se objekt jer je složeniji podatak od samo jedne mjerene točke. GeoMIR5 dozvoljava definiranje tri osnovne vrste objekata:

- Točka : CAD POINT

- Blok objekt : CAD BLOCK

- Polilinija : CAD LwPolyline

Točka i blok objekt predstavljaju takozvane točkaste objekte.

Točka je najjednostavniji oblik prikaza jer je određen samo jednom točkom.

Blok objekt također ima jednu referentnu točku insertiranja, no može biti mjeren sa do tri detaljne točke. Primjer: okrugli šaht biti će snimljen samo s jednom točkom, slivnik standardne veličine sa dvije točke ( sredina i smjer ) a četvrtasti šaht nestandardne veličine s tri točke ( tri vrha šahta ). Točne definicije prepuštene su korisniku na izbor. U svrhu boljeg opisa i prikaza podataka, uz točkasti objekt moguće je dodatno prikazati popratni simbol ( AutoCAD BLOCK ), tekstualni podatak ( AutoCAD TEXT ) ili atribut ( AutoCAD ATTRIB ).

Linijskim objektom prikazuje se sve što se proteže u duljinu, primjerice rub kolnika ograda ili zgrada. Tako definiran objekt prikazan je putem CAD elementa LWPOLYLINE i može imati neograničen broj snimljenih točaka. U svrhu boljeg topografskog prikaza, uz linijski objekt moguće je dodatno prikazati popratne simbole na liniji ( AutoCAD BLOCK ), paralelne linije na željenoj udaljenosti ( AutoCAD POLYLINE ) te popratne simbole na paralelnoj liniji ( AutoCAD BLOCK ).

Dobro koncipiranom tablicom kodova ne postoji situacija koja bi bila nerješiva na terenu, što je jako bitno jer je terenski posao puno skuplji od uredskoga.

Dvije dodatne vrste objekata prisutne su u softveru GeoMIR5:

- geodetska točka

- sistemski kod

Geodetska točka je samo poseban vid točkastog objekta i definira se na isti način no one se ispisuju direktno iz baze podataka i nije ih moguće snimati.

Sistemski kod je kod koji sam po sebi nema vlastiti grafički prikaz ali utječe na izgled ispisanih objekta kojem je pridružen. Najvažniji i jedini sistemski kod koji je za svaku temu kodiranja obavezan je ‘Završetak objekta’ jer svaki kod koji je negdje otvoren mora biti negdje i zatvoren. Isto vrijedi i za točkaste objekte samo s jednom točkom koji bi teoretski mogli biti automatski zatvoreni no u svrhu otvorenosti sistema i olakšavanja definiranja kodova izbačen je takav automatizam. Ako objekt nije zatvoren, GeoMIR5 nije u stanju prekidati i ponovo otvarati linije te je vrlo bitno voditi računa u zatvaranju objekata.


Izrada teme kodiranja i definiranje kodova

Izbornik Objekti ››

Najnovija tema kodiranja je "DGE19" i dostupna je za preuzimanje na internet stranicama, odjeljak "Download/Dokumentacija i dodaci"

Primjeri u nastavku su bazirani na temi kodiranja "DGU_ZBIRKA1000".

Otvoriti izbornik "Objekti/Objekti svojstva", postaviti miš iznad gornjeg lijevog polja i odabrati "Dodati temu":

(sl. 1)

Izrada teme kodiranja

(sl. 2)

Naziv: jednoznačan, opisan i kratak naziv

Raspoznavanje kodova: ako jedna mjerena točka predstavlja više od jednog objekta softver mora znati gdje završava jedan a gdje počinje drugi. Raspoznavanje kodova je moguće na dva načina – stalnom duljinom koda ili unosom razdjelnika. Način raspoznavanja kodova određuje se jedinstveno za temu kodiranja. Primjer: Stambena ili javna zgrada je definirana kodom 11, terasa kodom 14. Na istom mjestu završava terasa i počinje zgrada, znači snima se jedna točka koja ima dva koda – 11 i 14. Kodnom listom DGU_ZBIRKA1000 bi to izgledalo ovako:

140911 – 14=terasa, 09=završetak objekta, 11=zgrada

to je primjer raspoznavanja kodova stalnom duljinom koda od dva karaktera.

Ista takva situacija, snimljena raspoznavanjem kodova razdjelnikom ";" izgledalo bi ovako:

14;09;11 – 14=terasa, 09=završetak objekta, 11=zgrada

Iz primjera se vide prednosti i nedostaci pojedinih načina kodiranja. U praksi se način iz prvog primjera pokazao kao najpraktičniji, te se koristi u svim primjerima ovog uputstva.

Stalna duljina koda može imati vrijednost 2 ili 3 – jednoznamenkasti kodovi su namijenjeni za ubacivanje točaka bez opažanja.

Infos na simbolima ignorirati – samo za specijalne slučajeve, ostaviti neoznačeno

Infos na polylinijama ignorirati– samo za specijalne slučajeve, ostaviti neoznačeno

postavke potvrditi sa OK, time je stvorena tema kodiranja.


Sistemski kodovi

Izbornik Objekti ›› Izrada teme kodiranja i definiranje kodova ››

Sistemski kod je kod koji sam po sebi nema vlastiti grafički prikaz ali utječe na izgled ispisanih objekta kojem je pridružen. Najvažniji i jedini sistemski kod koji je za svaku temu kodiranja obavezan je "Završetak objekta" jer svaki kod koji je negdje otvoren mora biti negdje i zatvoren. Ako objekt nije zatvoren, GeoMIR5 nije u stanju prekidati i ponovo otvarati linije te je vrlo bitno voditi računa u zatvaranju objekata. Sistemski kodovi softvera GeoMIR5:

Zatvoriti objekt – jedini obavezni sistemski kod, označava kada je objekt završen.

Početak luka – početak luka linijskog objekta

Završiti luk - završetak luka linijskog objekta

Okomito na segment – okomica na mjereni segment linijskog objekta

Stvoriti paralelogram – zatvaranje linijskog objekata s tri mjerene točke u obliku paralelograma

Spojiti s prvom točkom – zatvaranje linijskog objekta na prvu mjerenu točku istoga

Najbliža točka – skok na najbližu već snimljenu točku

Debljina objekta – debljina linijskog objekta koji je definiran paralelnom linijom

Točka objekta – općenita točka nekog objekta

Primjer unosa sistemskog koda za zatvaranje objekta: postaviti miš iznad gornjeg desnog polja i odabrati "Dodati kod".

Jedina obavezna informacija je Kod, u ovom slučaju "09".

Ostali sistemski kodovi mogu biti uneseni na isti način.

(sl. 3)


Geodetske točke

Izbornik Objekti ›› Izrada teme kodiranja i definiranje kodova ››

Geodetske točke se definiraju kao "Blok objekt" no njih ne treba kodirati na terenu već se one preuzimaju direktno iz baze podataka. Vrste geodetskih točaka podržanih softverom GeoMIR5:

Detaljna točka

Lokalna TGO

Lokalna TGO - mala

Lokalna TGO - grafička

Lokalna TGO - polarna

Državna TGO – priključna

Državna TGO – trigonometar

Državna TGO – reper

Državna TGO – GPS

Svrha razlikovanje točaka geodetske osnove je isključivo u njihovom CAD prikazu! Stoga svaka od njih mora imati zasebnu definiciju.

Detaljna točka kao blok biti će prikazana svugdje gdje je na terenu snimljena točka, bez obzira kojega koda. Primjerice, snimljeni ruba kolnika biti će prikazan kao CAD polylinija u određenom layeru a svaka lomna točka biti će prikazana blokom detaljne točke.


Točkasti objekt - Blok

Izbornik Objekti ›› Izrada teme kodiranja i definiranje kodova ››

Pošto se geodetska točka definira na isti način kao i "Blok objekt", slijedi primjer definiranja dalekovoda kao blok objekta, koji treba biti snimljen i prikazan u pravoj veličini. Jedina razlika je što se pri definiranju geodetske točke ne može izabrati Veza s detaljnom točkom, jer je ona sama po sebi geodetska točka.

Unos blok objekta: postaviti miš iznad gornjeg desnog polja i odabrati "Dodati kod".

Naziv: "Dalekovod"

Kod: "54"

Info1 i info2 ostaviti praznim

(sl. 4)

Duljina zatvaranja objekta: najveća dopuštena duljina ili širina objekta, preko te vrijednosti GeoMIR5 sam zatvara kod jer se smatra pogreškom.

Pridruženi faktori omjera – određuju kako GeoMIR5 prikazuje mjerila pri ispisu objekata. U slučaju korištenja predloška gdje faktor skaliranja ovisi o mjerilu, kao što je u našem slučaju, potrebno je sve ostaviti nepromjenjeno. U slučaju da pojedina mjerila imaju različite definicije kodova, primjerice različite blokove ili layere, ovdje je potrebno označiti sva mjerila koja će naknadno biti detaljno definirana.

Pritiskom na OK, stvara se novi kod i unosi u tablicu. Za Detaljno definiranje podataka, potrebno je dvostruko kliknuti na kod, što otvara formular za definiciju koda:

Layer – layer za unos bloka

Block – naziv bloka za unos

Veza sa detaljnom točkom – hoće li ovdje definirani objekt prikazati svaku pojedinu detaljnu točku iz koje je nastao.

Primjerice, okruglo okno snimljeno jednom točkom biti će prikazano jednom blokom samog okna te jednim blokom detaljne točke. Veliki dalekovodni stup, snimljen sa tri točke i svrhu prikaza u stvarnoj veličini, biti će prikazan sa jednim blokom samog dalekovodnog stupa te s tri bloka detaljnih točaka.

Ukoliko se izostavi, stvara se samo jedan blok objekt, bez prikaza detaljnih točaka iz kojih je objekt nastao.

(sl. 5,6,7)

Objekt je nakon n-t točke zatvoren – najveći broj detaljnih točaka sa koliko može objekt biti snimljen. Direktno utječe na korištenje registara P1, P2, P3.

Registri P1, P2, P3 – određivanje prikaza blok objekta u odnosu na količinu snimljenih točaka.

Za Faktor omera X_ i Y_, u padajućoj listi postoje četiri vrijednosti za izbor:

    • "1"
    • "Mjerilo/1000"
    • "Udaljenost P1-P2" – udaljenost prve i druge mjerene točke
    • "Udaljenost P2-P3" – udaljenost druge i treće mjerene točke

U gornjem primjeru, a za mjerilo 1:500, računski postupak je:

1.0 * (500 / 1000) -> 1.0 * 0.5 -> faktor omjera je 0.5.

Na ovaj način moguće je predvidjeti gotovo svaki slučaj iz prakse te zahtjeva digitalnih topografskih ključeva.

Kut zakreta može biti:

    • "0.0"
    • "Kut P1-P2" - smjer prve prema drugoj snimljenoj točci
    • "Kut P2-P3" - smjer druge prema trećoj snimljenoj točci

Točka unosa može biti:

    • "Točno T1" – prva mjerena točka
    • "Sredina T1-T2" – sredina između prve i druge mjerene točke
    • "Točno T2" – druga mjerena točka
    • "Sredina T2-T3" – sredina između druge i treće mjerene točke
    • "Točno T1" – treća mjerena točka
    • "Sredina T1-T2-T3" – sredina između sve tri mjerene točke

Registar P1 – prikaz bloka objekta kada je snimljen samo sa jednom točkom.

Registar P2 - prikaz bloka objekta kada je snimljen sa dvije točke.

Registar P3 - prikaz bloka objekta kada je snimljen sa tri točke.

Dodatni objekti – klik desnom tipkom miša na polje. ponekad je potrebno, prema zahtjevima digitalnog topografskog ključa, prikazati dodatni objekt uz glavni blok objekt.

1 - Novi blok – prikazivanje dodatnog blok objekta uz glavni blok objekt.

Layer – layer za unos bloka

Block – naziv bloka za unos

Kut zakreta – "0.0", "Prema glavnom objektu"

Faktor omjera – "0.0", "Prema glavnom objektu"

Pomak točke unosa od glavnog objekta prema osima uz korištenje konstante, koja može biti "1.0" ili "X_" faktor omjera glavnog objekta".

(sl. 8)

2 - Dodati tekst – prikazivanje tekst objekta uz osnovni blok objekt.

(sl. 9)

Layer – layer za unos teksta

Kut zakreta – 0.0 ili prema glavnom objektu

Visina Teksta – vrijednost pomnožena konstantom, "1.0" ili "Mjerilo/1000".

Koristiti aktivni stil teksta ili odrediti stil teksta. Savjetuje se korištenje aktivnog stila teksta.

Izlazni podaci – predstavljaju tekst koji će biti ispisan, a dobiva se spajanjem svih navedenih vrijednosti. Pod Osnovno moguć je izbor podataka vezanih uz same mjerene ili računske podatke, kao što su broj točke, nadmorska visina, informacija koda i slično. Primjerice, ako se za prefiks unese "DT", za sufiks "x" a pod Osnovno izabere "Broj točke", tada će ispisani tekst za detaljnu točku "101" imati vrijednost "DT101x", a za detaljnu točku "301" biti će "DT301x".

Pomak točke unosa od glavnog objekta prema osima uz korištenje konstante, koja može biti "1.0" ili "X_" faktor omjera glavnog objekta".

3 - Dodatni atribut – definiranje ispisa u određeni atribut bloka. Atribut bloka mora biti definiran u predlošku, tekst za ispis definira se na isti način kao za tekst objekt.

(sl. 10)

Layer – layer za unos teksta

Tag – jedinstvena oznaka atributa unutar bloka

4 – Obrada objekta – obrada podataka postojećeg dodatnog objekta

5 – Brisanje objekta – obrisati dodatni objekt


Linijski objekt - Polilinija

Izbornik Objekti ›› Izrada teme kodiranja i definiranje kodova ››

Polilinijama se predstavljaju svi mjereni objekti koji se protežu preko više mjerenih točaka. Nije ograničena količina mjerenih točaka po linijskom objektu.

Formular za unos novog koda isti je kao pri definiciji blok objekta, potrebno je samo u prvoj padajućoj listi odabrati polylinija.

Unos polilinije: postaviti miš iznad gornjeg desnog polja i odabrati "Dodati kod".

Naziv: "Rub kolnika"

Kod: "30"

Info1 i info2 ostaviti praznim

(sl. 11)

Pritiskom na OK, stvara se novi kod i unosi u tablicu. Za Detaljno definiranje podataka, potrebno je dvostruko kliknuti na kod, što otvara formular za definiciju koda:

(sl. 12)

Sloj – sloz za unos polilinije

Veza sa detaljnom točkom – ubacivanje bloka detaljne točke (definirane kodom iz padajućeg izbornika) na prijelome linijskog elementa.

Zamjenska debljina – pri definiciji kodova koji se prikazuju sa dvije paralelne linije, ovdje se definira debljina objekta ako nema druge informacije

Tip linije - (linetype) koji će biti korišten, mora biti definiran u predlošku (template).

Dodatni objekti – klik desnom tipkom miša na polje. Ponekad je potrebno, prema zahtjevima digitalnog topografskog ključa, prikazati dodatni objekt uz glavni blok objekt.

1 - Dodati paralelnu poliliniju – stvaranje paralelne polilinije uz mjereni objekt.

(sl. 13)

Layer – layer za unos polilinije

Pomak od glavne polilinije: vrijednost pomnožena konstantom, "1.0" ili "Mjerilo/1000". Za paralelu s lijeve strane, vrijednost za pomak mora biti negativna.

Veza s osnovnom polilinijom: na početku i kraju paralelne polilinije, povezuje se sa osnovnom polilinijom.

2 - Dodati prateće blokove – dodavanje blok objekata na mjereni objekt.

Uzduž osnovne polilinije, uz određen razmak, postavljenje priležećih blokova koji prate njezin smijer.

(sl. 14)

Priležeći Layer(i), Blok(ovi): određivanje do tri raličita bloka koji se naizmjence postavljaju na osnovnu poliliniju.

Pomak od glavne polilinije: poprečni pomak od glavne polilinije pomnožen konstantom, "1.0" ili "Mjerilo/1000". Ako je nula, blok leži na poliliniji.

Korak: razmak između blokova pomnožen konstantom, "1.0" ili "Mjerilo/1000".

Faktor omjera: faktor skaliranja pojedinog priležećeg bloka, pomnožen konstantom "1.0", "Mjerilo/1000" ili "Širina glavnog objekta".

Kut zakreta: "0.0" za insertiranje bez zakreta. "Isti kut rotacije" zakreće blokove prateći smijer osnovne polilijije, sve na istu stranu. "Izmenični kut rotacije" zakreće blokove prateći smijer osnovne polilijije, ali naizmjenično lijevo i desno.

3 – Obrada objekta – obrada podataka postojećeg dodatnog objekta

4 – Brisanje objekta – obrisati dodatni objekt


Primjer premjera detalja - direktno snimanje

Izbornik Objekti ››

Direktno snimanje

Skica prikazuje izmišljenu, ali u praksi moguću situaciju na terenu, sa detaljnim prikazom snimanja. Svaka mjerena točka je prikazana dvjema informacijama – brojem točke koji predstavlja redoslijed mjerenja te kodom detaljne točke – koje su međusobno odvojene dvotočkom. Primjeri su bazirani na temi kodiranja "DGE19".

Broj točke | Kod | Objašnjenje
1 | 30 | Rub kolnika. Početak koda nije potrebno posebno napomenuti.
2 | 20 | Zid.
3 | 20 | Zid.
4 | 30 | Rub kolnika.
5 | 30 | Rub kolnika.
6 | 30200911 | Završetak zida i ruba kolnika atributom "09" te početak zgrade.
7 | 6309 | Okruglo okno, završeno "09" u istoj točci.
8 | 1130 | Nastavak zgrade te početak ruba kolnika.
9 | 110609 | Stvaranje paralelograma "06" pri završetku "09" zgrade
10 | 3035 | Rub kolnika i razdvajanje vrste površine.
11 | 64 | Četvrtasto okno, položaj.
12 | 6409 | Četvrtasto okno, točka za smjer te završavanje "09".
13 | 30 | Rub kolnika.
14 | 30 | Rub kolnika, završetak "09". Prelazak na drugu stranu ceste.
15 | 30 | Rub kolnika.
16 | 350930 | Završetak razdvajanja vrste površine "09", rub kolnika.
17 | 22 | Ograda.
18 | 30 | Rub kolnika.
19 | 22 | Ograda.
20 | 30 | Rub kolnika.
21 | 22 | Ograda, završetak "09".
22 | 53 | Stup dalekovoda, prva točka simbola.
23 | 53 | Stup dalekovoda, druga točka simbola.
24 | 5309 | Stup dalekovoda, treća i završna točka simbola.
25 | 30 | Rub kolnika, završetak "09". Završetak snimanja.

Izdvojeno:

  • Prvo je snimjena jedna strana ceste, potom druga. U praksi se pokazalo kao najbolji način snimanja.
  • Svaki kod mora biti zatvoren, atributom "09".
  • Primjer korištenja više kodova na jednoj snimljenoj točci – DT 6, 10, 16.
  • Korištenje atributa kodova – DT 9, zatvaranje paralelograma.
  • Slučajevi zaboravljanja zatvaranja objekta, što bi bilo kad bi bilo:
    1. DT 7 – GeoMIR5 zatvara kod automatski, pošto je definiran za max 1 točku
    2. DT 12– GeoMIR5 zatvara kod automatski, pošto je definiran za max 2 točke
    3. DT 14 – DT 14 i 15 biti će spojene
    4. DT 24 – GeoMIR5 zatvara kod automatski, pošto je definiran za max 3 točke
    5. DT 25 – GeoMIR5 dojavlja da postoje nezatvoreni kodovi uz točnu napomenu gdje


Primjer premjera detalja - indirektno snimanje

Izbornik Objekti ››

Indirektno snimanje – stvaranje novih točaka umjeravanjem

U praksi je čest slučaj potrebe umjeravanja točaka, koje iz nekog razloga nisu vidljive instrumentom. Kako bi i u ovom slučaju crtanje skice bilo svedeno na minimum, uvedeni su posebni jednoznamenkasti kodovi, kojima se stvaraju nove točke u odnosu na neposredno prethodno snimljene. Za ovakav način umjeravanja, instrument mora podržavati unos koda te dvije informacije po točci.

Položajno umjeravanje se vrši korištenjem koda "5", informacije o smjeru te informacije o vrijednosti umjeravanja u milimetrima. Nove točke se stvaraju položajno u odnosu na posljednje dvije točke, visina će biti nedefinirana. Skica prikazuje izmišljenu, ali u praksi moguću situaciju na terenu, sa detaljnim prikazom snimanja.

(sl. 16)

Redosljed | Kod | Info 1 | Info 2 | Objašnjenje | Broj točke
1 | 1107 |  |  | Početak snimanja | 1
2 | 11 |  |  | Druga točka, za smjer | 2
3 | 5 | 503 | a | Umjeravanje, pravi kut nalijevo | 2A
4 | 5 | 504 | b | Umjeravanje, pravi kut nadesno | 2B
5 | 5 | 504 | c | Umjeravanje, pravi kut nadesno | 2C
6 | 5 | 503 | d | Umjeravanje, pravi kut nalijevo | 2D
7 | 11 |  |  | Nastavak snimanja instrumentom | 3
8 | 110709 |  |  | Završetak snimanja | 4

Točka umjeravanja se računa u odnosu na prethodne dvije točke, bez obzira bile one snimljene ili umjerene. Smjerovi podržani informacijom 2:

  • 501 – unaprijed ; 502 – unatrag ; 503 – lijevo ; 504 – desno

Nakon računanja, nove točke dobivaju alfanumeričke sufikse na posljednju opažanu detaljnu točku. GeoMIR5 pruža mogućnosti prenumeriranja kako bi brojevi točaka postali numerički.

Visinsko umjeravanje se vrši korištenjem koda "7", informacije o smjeru te informacije o vrijednosti umjeravanja u milimetrima. Nova točka će imati isti položajnu koordinatu kao i prethodna, sa promijenjenom visinom prema informacijama umjeravanja.

Način unosa je identičan unosu koda "5". Smjerovi podržani informacijom 2:

  • 701 – prema gore ; 702 – prema dolje


Stvaranje objekata iz kodova

Izbornik Objekti ››

Nakon što se izračunaju stajališta i detaljne točke, može se pristupiti stvaranju kodova iz tahimetrije. Pokreće se izbornikom "Objekti/Stvaranje objekata iz kodova" ili pritiskom na "Puzzle" ikonu. Podaci se povlače iz tablice detaljnih točaka.

Stvaranje objekata iz kodova izborom područja detaljnih točaka – ako niti jedno stajalište iz popisa nije označeno, otvara se formular za izbor područja točaka:

Detaljne točke i točke geodetske osnove mogu biti odabrane prema broju. Primjer prikazuje područje detaljnih točaka od 101 do 199 te točaka geodetske osnove od 31 do 45.

(sl. 17)

Stvaranje objekata iz kodova izborom stajališta iz popisa – treba voditi računa da detaljne točke snimljene GNSS metodom ne mogu biti odabrane na ovaj način. Ako je potrebno, moguće je poništiti izbor stajališta pozivanjem kontekst izbornika (desni klik mišem), te "Izbor/Poništiti izbor svega".

Izbor stajališta iz popisa, ovdje konkretno stajališta 31,32,35 i 37.

(sl. 18)

Stvaranje objekata – nakon izbora područja detaljnih točaka pojavit će se formular za stvaranje objekata.

(sl. 19)

Baza objekata je još jedan pojam uveden kroz softver GeoMIR, a predstavlja podatke koji su nastali stvaranjem objekata iz kodova. Konkretno, radi se o jednoj internoj datoteci koja služi za kasnije učitavanje objekata u CAD softver. Baza objekata je određena proizvoljnim nazivom te vezom uz temu kodiranja. Za polazne podatke se uvijek postavlja "Standard" kao naziv te pri stvaranju predmeta određena tema kodiranja.

Jedan primjer korištenja baza objekata iz prakse bila bi potreba, određeno mjerenje ispisati u više od jednog digitalnog topografskog ključa, primjerice za "Telekom" ili "Elektru".

Drugi primjer korištenja iz prakse bio bi stvaranje određenih područja objekata ili prikaz objekata samo za neke kodove.

Treći primjer korištenja bio bi promjena teme kodiranja, ako je pri stvaranju predmeta odabrana pogrešna tema kodiranja.

Općenito, ako je pri stvaranju predmeta odabrana ispravna tema kodiranja, najčešće neće biti potrebe za mijenjanjem polaznih podataka.

Dodati:

(sl. 20)

Naziv – za novu bazu objekata.

Tema kodiranja – izbor teme kodiranja

Preuzeti samo određene kodove – u slučaju ako je potrebno stvoriti objekte samo iz određenih kodova, primjerice rubova kolnika i zgrada.

Obrisati – brisanje odabrane baze objekata

Mjerilo – mjerilo crteža

Ispisati TGO – Stajališta – prikazivanje stajališta kao TGO u crtežu

Ispisati TGO – ORI – prikazivanje vizura kao TGO u crtežu

Ispisati okvire DL – prikazati detaljni list kao poliliniju u crtežu

Nakon što stvaranje objekata iz kodova bude završeno, GeoMIR5 dojavlja kako je prošlo. Postoje dvije moguće pogreške koje GeoMIR5 dojavlja, ako ih pronađe – nezatvoreni ili nedefinirani kodovi. O oba slučaja se prikaže na kojim točkama je došlo do koje pogreške.

Savjetuje se ispravljanje pogrešaka odmah unutar GeoMIR5 sučelja. Potrebno je obratiti pažnju da, ako se mijenjaju kodovi unutar tahimetrijskih podataka, potrebno je ponovo izračunati detaljne točke.


Preuzimanje kodiranih objekata u CAD softver

Izbornik Objekti ››

Nakon što su stvoreni objekti iz kodova, kako je objašnjeno u prethodnom poglavlju, moguće ih je učitati u CAD softver. Detaljno objašnjenje o postupku učitavanja kodiranih objekata u CAD softver je dostupno u odjeljku GeoMIR5 CAD modul, izbornik GeoMIR, G5 objekti .


Izbornik Grafika - G4CAD

Grafičko sučelje G4CAD je staro CAD sučelje koje se više ne razvija i biti će vremenom u potpunosti izbačeno iz GeoMIR5 softvera.

GeoMIR5 CAD modul , kao nasljednik, je razvijen za sve relevantne CAD platforme: ActCAD, AutoCAD, ZWCAD i BricsCAD.


Izbornik Grafika - Pregled

U nastavku navedenim računskim radnjama moguće je grafički vizualizirati podatke za računanje. Ovim izbornikom poziva se posljednji stvoreni pregled.

Izrada pregleda pri računskim operacijama:

•Poligonski vlakovi

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled s ucrtanim poligonskim vlakom i vizurama.

•Slobodno stajalište

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled s prikazanim vizurama u relativnim koordinatama.

•Presjek natrag

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled s prikazanim vizurama u relativnim koordinatama.

•Presjek naprijed

Dvostrukim klikom na polje predviđeno za izvještaj biti će otvoren pregled računanja u apsolutnim koordinatama.


Izbornik Alati

• Licencni formular

•Svojstva – lokalna -> Ishodišna

Pohrana svih svojstava trenutnog predmeta te korištenje istih kao polazna (ishodišna) svojstva pri stvaranju novih predmeta. Praktično za postavljanje jedinica, redukcija duljina te polazne teme kodiranja za sve predmete u budućnosti.

•G4 izgled zaslona: lokalno -> Ishodišno

Izgled zaslona i razmještaj formulara biti će pohranjeni kao predložak za sve u budućnosti stvorene predmete.

•G4 izgled zaslona: Učitati predložak

Izgled zaslona i razmještaj formulara u trenutnom predmetu biti će posloženi kao u predlošku.

•Provjera redukcije duljine

Redukcije mjerene duljine igra ključnu ulogu u točnosti računanja podataka. Ovom radnjom stiče se uvid u red veličine popravke. Unosi se mjerena duljina u metrima, rezultat su popravke iste duljine u ppm i metrima. Parametri redukcije preuzimaju se iz svojstva predmeta .

•Pročistiti predmete

Objašnjenje na kraju odjeljka o predmetima .

•Preuređivanje pokazatelja

Ovom radnjom vrši se preuređivanje pokazatelja baza podataka ( reindexing database ) a potrebna je samo ako dođe do problema pri ubacivanju novih podataka u bazu ili ako se pojave pogreške u brisanju podataka.


Licencni formular

Izbornik Alati ››

Jedinstveni licencni formular objedinjuje sve radnje vezane uz licenciranje programa GeoMIR5.

Nakon instalacije GeoMIR5 radi kao besplatna verzija GeoMIR5Free. Kako bi upoznavanje sa softverom bilo što kvalitetnije, svaki korisnik GeoMIR5Free verzije ima pravo na 20-o dnevnu probnu licencu koja otvara sve mogučnosti programa.

Dodjeljivanje probne licence je automatizirano i anonimno a jedino što je potrebno jest veza sa internetom.

Nakon startanja licencnog formulara u GeoMIR5Free verziji već je sve pripremljeno za zatraživanje probne licence:

Pritiskom na "Online zatražiti probnu licencu" stvara se veza sa bazom podataka i u istom koraku se licenca dodjeljuje. Probna licenca se odobrava samo jednom po računalu.

Tipkom "Online usaglaš." usaglašava se već postojeća licenca sa serverom ako iz nekog razloga ista nestane sa računala.

Korisnicima komercijalne verzije sa hardverskim ključem biti će prikazana informacija o vlasniku licence i serijskom broju.

Napomena: tijekom korištenja probne licence GeoMIR5 s vremena na vrijeme pristupa internetu u svrhu provjere datuma na računalu.


Izbornik Pomoć

•GeoMIR5 Pomoć

Ovo uputstvo, početna tema.

•O programu

Prikazivanje formulara sa podacima o trenutnom predmetu, licenci, programu GeoMIR5 i svim komponentama. U slučaju dojave grešaka, potrebno je navesti podatke o verzijama.


ActCAD

ActCAD je profesionalan 2D i 3D CAD softver, koji se temelji na tehnologijama IntelliCAD tehnologije Consortium (ITC), DS i prostornog WinTopo. ActCAD sadrži i alate kao što su biblioteka blokova, automatski konverter datoteka, konverter jedinica te mnoge druge alate za poboljšanje produktivnosti.

ActCAD u potpunosti kompatibilan sa DWG i DXF formatima datoteka, i podržava sve verzije DWG / DXF od R2.5 do 2016.

ActCAD je lagan, ali vrlo moćan profesionalni CAD softver. S jedne strane se koriste prednosti multi-threading i multi-core mogućnosti najnovijih računalnih sustava, s druge strane radi bez problema čak i na starijim računalima.

Uz sve to, ActCAD ima vlastiti API te je moguće programiranje od najjednostavnijih LISPova do složenih programa u C++. Uz eventualne manje preinake, gotovo svi postojeći LISP programe mogu biti migrirani iz AutoCAD-a u ActCAD.

GeoMIR5 modul podiže ActCAD još stepenicu više! Direktno preuzimanje koordinata i kodiranih objekata iz GeoMIR5 softvera, izrada digitalnog modela reljefa i slojnica, izrada poprečnih i uzdužnih profila te ispis koordinata u GeoMIR5 ili datoteku samo su dio proširenja. Ugrađena je podrška za novu zbirku kartografskih znakova baziranu na predlošku DGU-e – počevši od teme kodiranja za GeoMIR5 do izbornika u ActCAD-u za lakše crtanje i ubacivanje simbola u vodeći računa o strukturi i mjerilu.

Iz razloga licenciranja, ActCAD je posebna instalacija dostupna na ActCAD ili GeoMIR internet stranicama.

Izdvojeno:

  • Korištenje snage 64-bitne tehnologije
  • Podržane multi-threading i multi-core tehnologije
  • Velika brzina i performanse
  • Licence vrijede globalno i za stalno
  • Besplatna i brza tehnička podrška
  • Najbolji omjer cijene i kvalitete
  • 100% izvorno i legalno
  • Pretplata i nadogradnja po izboru
  • Najnovija CAD jezgra od ITC
  • Podržava sve DWG i DXF formate datoteka od R2.5 do 2017

Istaknuto:

Raster u DXF: ActCAD uključuje Wintopo raster (slika) u vektor (DXF) pretvarač

ActCAD biblioteke: 5000 ugrađenih CAD blokova za mehaniku, arhitekturu, elektriku itd. Također moguće stvaranje vlastitih biblioteka.

Prebacivanje licence: Aktiviranje i deaktiviranje te prebacivanje licence s jednog računala na drugo sebe više puta

Jednostavno učenje: Slično sučelje, naredbe, ikone, nadimci i kratice kao u popularnih CAD softvera

Prilagođavanje: korisničko sučelje, izbornici, alatne trake

Programski alati: TX, LISP, IRX, DIESEL, DCL, SDS, NET i COM

ActCAD Revizor i Converter: Revizija i ispravljanje pogrešaka u starim DWG / DXF datotekama u autmatskom načinu rada.

Pretvaranje iz jedne verzija DWG / DXF / DGN u drugu. I binarni i ASCII formati su podržani.


GeoMIR5 CAD modul

GeoMIR5 CAD modul je skup programa koji proširuju CAD sučelje - s jedne strane radi se o programima za povezivanje sa softverom GeoMIR5, s druge strane su to neovisni programi koji olakšavaju izradu elaborata prema određenim digitalnim topografskim ključevima.

Osim programa, G5 modul dodaje predloške (templates), tipove linija, šrafure i slične datoteke u CAD softver.

GeoMIR5 CAD modul je dostupan za sve relevantne CAD platforme: ActCAD, AutoCAD, ZWCAD i BricsCAD.

Direktno preuzimanje koordinata i kodiranih objekata iz GeoMIR5 softvera, izrada digitalnog modela reljefa i slojnica, izrada poprečnih i uzdužnih profila te ispis koordinata u GeoMIR5 ili datoteku samo su dio proširenja.

GeoMIR*Desktop CAD modul je usklađen sa sustavom DGE

Ugrađena je podrška za aktualnu zbirku kartografskih znakova baziranu na predlošku DGU-e – počevši od teme kodiranja za GeoMIR5 do izbornika u CAD-u za lakše crtanje i ubacivanje simbola u vodeći računa o strukturi i mjerilu.

Predložak (drawing template) , koji je sastavni dio instalacije GeoMIR5 modula za CAD softver, oslanja se na definicije blokova, slojeva i tipova linija na predložak državne geodetske uprave.

Za prikaz signatura građevina (zid, ograda, pokos) postoje dva načina: korištenje tipova linija te popratnih simbola uz linijski objekta. Iako je korištenje tipova linija sa signaturama vrlo praktično za crtanje jer je signatura vezana uz linijski objekt, prilikom otvaranja crteža na računalu gdje tipovi linija nisu definirani isti neće biti vidljivi. Stoga je napravljena naredba Signature - tip linije u simbole, koja se nalazi u izborniku Alati i služi za ubacivanje popratnih simbola na linijske objekte kako bi signature bile vidljive na svim računalima.

Omogućeno je direktno učitavanje slike sa GeoPortala .

Ugrađena je podrška za izradu katastarskih planova baziranih na strukturi Digitalnog katastarskog plana (DKP) učitavanjem GML datoteka iz sustava DGE, te brojnim radnjama i programima za lakšu izradu katastarskih planova. Veliki broj strukturnih informacija iz GML datoteka koristi se za direktno povezivanje broja čestice sa posjednicima, za izradu okvira i sastavnica te ispis novih podataka u GML datoteke. Osim toga, veliki broj dodatnih radnji olakšava i ubrzava izradu katastarskih planova.

Direktnim online povezivanjem sa sustavom DGE omogućena je kontrola kvalitete direktno iz crteža, uz neposredno prikazivanje upozorenja i grešaka.

Izrada analognog djela elaborata vrši se povezivanjem sa MS Word i MS Excel aplikacijama u svrhu direktnog prebacivanja podataka.

Uvijek je trenutni predmet iz GeoMIR5 softvera taj koji je modulom povezan sa CAD-om.

GeoMIR5 modul dodaje devet padajućih izbornika u ActCAD:

  • GeoMIR
  • DMR
  • DGU zbirka
  • DGE Točke
  • DGE Grafika
  • DGE Knjižno
  • SDGE servis
  • Prijavni list
  • Alati

Ovdje se može provjeriti što je novo - kronologija razvoja .


Izbornik" GeoMIR"

GeoMIR5 CAD modul ››

Izbornik "GeoMIR" sadrži sve radnje potrebne za komunikaciju sa softverom GeoMIR5, te još neke osnovne radnje koje nisu vezane uz neki poseban topografski ključ.

  • Učitavanje koordinata
  • G5 objekti
  • Skica mreže
  • Nova točka sa zaslona
  • Nove točke izborom grafičkih elemenata
  • Kopiranje točaka u G5 međuspremnik
  • Ispis točaka u datoteku
  • Stvaranje površine za ispis u GeoMIR5
  • Ispis površine u GeoMIR5 međuspremnik
  • Datumska transformacija
  • Mjerilo crteža
  • Stvaranje predloška iz crteža
  • Pomoć - upute za rad
  • Info - Prikazivanje trenutnog GeoMIR5 predmeta i vlasnika licence

Savjet: dobro bi bilo prvo proučiti teme o G5 točkama i mjerilu crteža .


Učitavanje točaka iz GeoMIR5 predmeta

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Učitavanje koordinata točaka iz GeoMIR5 predmeta, ako nije bilo korišteno kodirano mjerenje.

U ovisnosti od predloška (drawing template) kojim je otvoren crtež, koristiti će se specifični blokovi za prikaz točaka:

  • korištenje predloška uslađenog sa sustavom SDGE "g5_dge19.dwt", koji je sastavni dio instalacije: koristiti će se blokovi "tocke", "10301-1", "10302-1",, "10401-1", u ovisnosti o kojoj vrsti točke je riječ. Na ovaj način, točke se učitavaju prema tehničkim specifikacijama SDGE. Izuzetak je slučaj, kada je uključena opcija "Koristiti blokove 19999", kojom se prisiljava korištenje blokova "19999-1" za prikaz točaka.
  • korištenje predloška "zbirka_g5", koji je sastavni dio instalacije: koristiti će se blokovi prema definiciji vrste točke unutar softvera GeoMIR5. Kako je već spomenuto, predložak (drawing template) "zbirka_g5", koji je sastavni dio instalacije GeoMIR5 CAD modula, oslanja se na definicije blokova, slojeva i tipova linija na predložak državne geodetske uprave.
  • korištenje bilo kojeg drugog predloška: koristiti će se blok objekt iz sistema G5 točke .

Detaljne točke ( od / do , * za sve ): područje detaljnih točaka za učitavanje. Ako se učitavaju sve detaljne točke, potrebno je unijeti zvjezdicu. Ako se učitava određeno područje detaljnih točaka, potrebno je unijeti početnu i završnu detaljnu točku odvojenu znakom "/".

Primjerice, unosom "100/199" učitavaju se sve detaljne točke od 100 do 199, uključujući i njih.

Točke geod. osn. ( od / do , * za sve ): područje točaka geodetske osnove za učitavanje. Sintaksa je ista kao i za detaljne točke.

Zamjenska vrijednost za točke bez visine: biti će korištena za sve točke koje nemaju definiranu nadmorsku visinu. To vrijedi za 3D prikaz i za vrijednost atributa, ako je definiran.

Koristiti blokove 19999: prikaz točaka originalnim GeoMIR blokovima "19999-1", koji su pogodni za prikaz u 3D, kao i u mnogim slučajevima kada nije potrebna SDGE usklađenost podataka.

Stvoriti 3D Objekte: prikaz točaka u 3D. Kako SDGE ne odobrava prikaz točaka u 3D, potrebno je odabrati opciju "Koristiti blokove 19999" kako bi blokovi bili prikazani u 3D.

Prikazati proširene vrijednosti: prikazati dodatne atribute, ako su definirani.

Broj decimalnih mjesta za koordinate: na koliko decimalnih mjesta će biti zaokružene koordinate za insertiranje bloka

Broj decimalnih mjesta za atribute: na koliko decimalnih mjesta će biti prikazani atributi blokova, primjerice nadmorska visina.

Mjerilo crteža: postavljanje mjerila crteža


Učitavanje kodiranih objekata iz GeoMIR5 predmeta

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Kao prvo, potrebno je odabrati predložak ("Template drawing") koji sadrži definicije layera i blokova vezanih uz temu kodiranja podataka. Originalni "g5_zbirka.dwt" je predložak baziran na digitalnoj zbirci znakova Državne geodetske uprave i odgovara temi kodiranja "DGU_ZBIRKA1000".

1. Stvaranje novog crteža odabirom predloška:

Izbornik "File"

"New"

"Use Template Drawing"

"Select a template"

"Browse"

"zbirka_g5.dwt"

"Complete"

2. Učitavanje kodiranih objekata:

Izbornik "GeoMIR"

"G5 Objekti"

Mapa pohrane biti će preuzeta iz svojstava programa GeoMIR5, određena prilikom stvaranja predmeta.

U ovom formularu za preuzimanje objekata iz GeoMIR5 softvera, potrebno je odabrati prethodno stvorenu bazu objekata te upisati naziv datoteke.

Pritiskom na OK izvršava se stvaranje objekata u CAD formatu. Dođe li do pogrešaka, biti će dojavljene. Najčešća pogreška je ako neki blok, definiran u temi kodiranja, nije stvoren u predlošku. U tom slučaju, potrebno je stvoriti blok te nakon toga novi predložak.


Učitavanje točaka iz datoteke

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Direktno učitavanje točaka iz datoteke, bez potrebe za stvaranjem GeoMIR5 predmeta je idealno rješenje kada su definitivne koordinate točaka dostupne u ASCII datoteke i nema potrebe za stvaranjem objekata iz kodova. Vrijednosti u datoteci moraju biti po redu kako je prikazano u slici ispod. Razdjelni karakteri mogu biti prazno mjesto, zarez, točka-zarez ili tabulator.

U ovisnosti od predloška (drawing template) kojim je otvoren crtež, koristiti će se specifični blokovi za prikaz točaka:

  • korištenje predloška uslađenog sa sustavom SDGE "g5_dge19.dwt", koji je sastavni dio instalacije: koristiti će se blokovi "tocke", "10301-1", "10302-1",, "10401-1", u ovisnosti o kojoj vrsti točke je riječ. Na ovaj način, točke se učitavaju prema tehničkim specifikacijama SDGE. Izuzetak je slučaj, kada je uključena opcija "Koristiti blokove 19999", kojom se prisiljava korištenje blokova "19999-1" za prikaz točaka.
  • korištenje predloška "zbirka_g5", koji je sastavni dio instalacije: koristiti će se blokovi prema definiciji vrste točke unutar softvera GeoMIR5. Kako je već spomenuto, predložak (drawing template) "zbirka_g5", koji je sastavni dio instalacije GeoMIR5 CAD modula, oslanja se na definicije blokova, slojeva i tipova linija na predložak državne geodetske uprave.
  • korištenje bilo kojeg drugog predloška: koristiti će se blok objekt iz sistema G5 točke .

Nakon izbora datoteke, pojavit će se formular u kojem su prikazane vrijednosti koje će biti učitane. U slučaju da nešto nije u redu, moguće je prekinuti radnju i točke neće biti učitane.

Točke će biti vizualizirane blokom sa pripadajućim atributima. Koji blok će biti korišten, ovisi o predlošku koji se koristi.

Ukoliko se koristi predložak SDGE, pojaviti će se formular za odabir vrste, stabilizacije i nastanka točke.

Koristiti blokove 19999: prikaz točaka originalnim GeoMIR blokovima "19999-1", koji su pogodni za prikaz u 3D, kao i u mnogim slučajevima kada nije potrebna SDGE usklađenost podataka.

Stvoriti 3D Objekte: prikaz točaka u 3D. Kako SDGE ne odobrava prikaz točaka u 3D, potrebno je odabrati opciju "Koristiti blokove 19999" kako bi blokovi bili prikazani u 3D.

Broj decimalnih mjesta za koordinate: na koliko decimalnih mjesta će biti zaokružene koordinate za insertiranje bloka

Broj decimalnih mjesta za atribute: na koliko decimalnih mjesta će biti prikazani atributi blokova, primjerice nadmorska visina.

Mjerilo crteža: postavljanje mjerila crteža


Skica mreže

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Izrada skice mreže (skice poligonskih vlakova) iz odabranih stajališta iz softvera GeoMIR5. Prvo je potrebno odabrati za koja stajališta se izrađuje skica mreže:

Pri korištenju DGE predloška (drawing template), koriste se slojevi i blokovi propisani Zbirkom kartografskih znakova:

- stajališta se prikazuju blokom "10401-1" u sloju "sit_8_tocke"

- dogledanja se prikazuju blokom "dogledanja" u sloju "sit_zbirka_znakovi"


G5 točke

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

G5 točke su predviđene kao format prikaza točaka unutar GeoMIR5 CAD modula, neovisno o korištenom predlošku. Prikaz G5 točke vrši se blok elementom, koji je definiran u vanjskoj datoteci te je stoga primjenjiv na sve, čak i prazne, predloške. G5 točke nisu vezane uz pojam "DGE Točke".

Nova točka sa zaslona: unošenje grupe G5 točaka proizvoljnim izborom položaja u crtežu. Za prvu točku grupe potrebno je unijeti broj točke, ostale točke grupe će biti nastavno numerirane. Za prekid unosa potrebno je pritisnuti tipku Escape.

Nove točke izborom grafičkih elemenata: postavljanje grupe G5 točaka na odabrane grafičke elemente. Grafički elementi mogu biti linije, 2d i 3D polilinije i blokovi. Za prvu točku grupe potrebno je unijeti broj točke, ostale točke grupe će biti nastavno numerirane. Za prekid unosa potrebno je pritisnuti tipku Escape.

Kopiranje novih točaka u G5 međuspremnik: odabir G5 točaka za kopiranje u međuspremnik, iz kojeg je moguće preuzimanje u tablicu detaljnih točaka ili tablicu točaka geodetske osnove .

Ispis točaka u datoteku: odabir G5 točaka za pohranu u vanjsku TXT datoteku.

Broj decimalnih mjesta pri ispisu: 2, 3 ili 4

Ako je uključena opcija "Naziv datoteke automatski u istu mapu s crtežom", datoteka će biti stvorena bez interakcije, i to u istu mapu i s istim nazivom kao crtež.

Moguće je odabrati jedan od tri graničnika (znaka koji odvaja stupce): Razmak, točka-zarez ili zarez.


Analitičko računanje površina

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Analitičko računanje površina sa ispisom izvještaja za izradu elaborata moguće je unutar sučelja GeoMIR5.

No, površine je lakše i intuitivnije pripremiti unutar CAD sučelja. U tu svrhu je napravljen način za prebacivanje pripremljenih površina iz CAD softvera u GeoMIR5. Prebaciti je moguće jednu zatvorenu poliliniju koja mora imati numerirane točke na svim pregibima. Layer nije bitan jer se željena polilinija direktno odabire.

Izrada zatvorene polilinije je moguća standardnim CAD alatima, primjerice ručnim crtanjem polilinije od točke do točke. Kako bi proces stvaranja zatvorenih poligona bio još jednostavniji, napravljena je naredba "Stvaranje površine za ispis u GeoMIR5". Tom naredbom, koja se oslanja na funkcionalnost CAD naredbe "BPOLY" ili "BOUNDARY", unosom potrebno je samo odrediti točku koja se nalazi unutar željenog poligona te pritisnuti ENTER. Ako je matematički moguće, CAD softver će stvoriti zatvorenu poliliniju.

Bez obzira na koji način stvorena, polylinija površine mora na svim pregibima imati numeriranu točku, jer samo numerirane točke mogu biti prikazane u izvještaju za računanje površina. To mogu biti točke koje su preuzete iz GeoMIR5 predmeta, ili nove G5 točke stvorene u CAD softveru.

Kada su svi uvjeti za prebacivanje zadovoljeni (zatvorena polilinija koja mora imati numerirane točke na svim pregibima), naredbom "Ispis površine u GeoMIR5 međuspremnik" se odabire željena polilinija i podaci se pohranjuju u međuspremnik. Ako točke na pregibima još ne postoje u GeoMIR5 predmetu, biti će automatski dopisane.

Nakon što su podaci pohranjeni u među spremnik, potrebno ih je preuzeti u GeoMIR5.


Datumska transformacija

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Datumska transformacija crteža svih elemenata. Na ovaj način moguće je gotov crtež prebaciti iz jednog datuma u drugi.

Odabir parametara transformacije je identičan sučelju iz softvera GeoMIR5 koje je prethodno objašnjeno.

Blokove bez zakreta ostaviti takve: Datumskom transformacijom koordinata dolazi do promjene zakreta blokova, tekstova i sličnih elemenata, uzrokovano razlikom u koordinatnim sustavima. Ako je ovdje postavljena kvačica, svi blokovi koji su u polaznom koordinatnom sustavu bili bez zakreta, biti će nakon transformacije i rotacije nanovo postavljeni bez zakreta.


Mjerilo crteža

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Postavljanje i mijenjanje mjerila crteža.

Kroz sve programe, predloške i sisteme točaka, GeoMIR5 CAD modul je baziran na skaliranju blokova prema mjerilu, i to prema formuli

faktor skaliranja = mjerilo crteža / 1000

Primjerice, blok koji predstavlja okruglo okno, u mjerilu 1:1000 imati će faktor skaliranja 1 dok će u mjerilu 1:500 faktor skaliranja biti 0.5. Faktor skaliranja koristi se i za skaliranje tipova linija.

Primijeniti promjenu na postojeće elemente: ako je uključeno, svi postojeći elementi u crtežu biti će skalirani prema novom mjerilu.


Stvaranje predloška iz crteža

GeoMIR5 CAD modul ›› Izbornik" GeoMIR" ››

Predložak crteža, iz engleskog poznato kao Drawing Template, je prazan crtež koji sadrži definicije blokova, slojeva i drugih elemenata crteža. Stvaranjem predloška crteža olakšava crtanje, pogotovo kada se pretežno koriste isti blokovi, slojevi ili tipovi linija.

Primjerice, za preuzimanje kodiranih objekata iz crteža iz GeoMIR5 softvera, potreban je odgovarajući predložak. Pri instalaciji GeoMIR5 CAD modula, predložak je automatski instaliran , koji sadrži blokove definirane prema topografskom ključu Državne geodetske uprave.

Stvoriti novi predložak prema vlastitim potrebama je jednostavno.

Prvo je potrebno otvoriti crtež koji u sebi sadrži sve definicije blokova, slojeva i ostalih elemenata.

Nakon toga pokrenuti naredbu "GeoMIR5" / "Stvaranje predloška iz crteža", čime se otvara odgovarajući formular:

  • Ime za novi predložak (bez ekstenzije): ime (naziv) za novi predložak, bez DWG ili DWT ekstenzije.
  • Postaviti kao trenutan predložak: ako se uključi, novo stvoreni predložak biti će korišten pri svakom pokretanju CAD softvera te pri stvaranju novog crteža.


Izbornik "DMR"

GeoMIR5 CAD modul ››

Izbornik DMR sadrži sve radnje vezane uz izradu DMR-a, slojnica, profila i kubatura.

Navedeni zadaci predstavljaju pojednostavljeni prikaz stvarnog stanja terena. Iako bi idealan slučaj bio rad u tri dimenzije, iz praktičnih razloga, kojih je mnogo, geodetski planovi se crtaju u ravnini, a treća dimenzija se koristi prema potrebi.

  • Princip 2D -> 3D
  • Digitalni model reljefa DMR
  • Slojnice iz DMR-a
  • Profili - uzdužni i poprečni
  • Izrada bokocrta iz situacije
  • Kubatura iz dva reljefa


2D -> 3D

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

GeoMIR5 sadrži jedinstveni sistem za raspoznavanje prostornih 3D podataka iz postojećih 2D i 3D podataka.

Za izradu digitalnog modela reljefa i profila, GeoMIR5 CAD modul koristi interne i virtualne 3D objekte, dobivene iz 2D i 3D elemenata crteža:

Referentne visinske točke terena:

• 3D elementi: 3DPOINT i 3DBLOCK-INSERTION

• 2D element: BLOCK-INSERTION koji nosi informaciju o trećoj dimenziji u atributu – TAG oznaka atributa se definira od strane korisnika, predložene vrijednosti su H i VISINA

Linije prijeloma terena:

• 3D elementi: 3DPOLYLINE i 3DLINE

• 2D elementi: LWPOLYLINE i LINE čije prijelomne točke leže na jednoj od gore navedenih referentnih visinskih točaka terena.

Internim spajanjem navedenih elemenata crteža i stvaranjem virtualne 3D cjeline, dobiva se podloga za izradu modela reljefa i profila. Ovakav način raspoznavanja elemenata crteža identičan je za sve radnje unutar GeoMIR5 CAD modula.

Izbor elemenata crteža za stvaranje virtualne 3D cjeline je jednostavan i fleksibilan, a baziran je na odabiru layera u kojima se elementi crteža nalaze te određivanjem TAG-a atributa 2D blokova koji sadrže informaciju o visini.

Formular za stvaranje DMR-a:

Izdvajanje referentnih točaka:

  • Layeri koji sadrže referentne točke – navesti u kojim layerima se nalaze elementi crteža ( 3DPOINT, 3DBLOCK-INSERTION, BLOCK-INSERTION ).
  • TAG atributa bloka koji sadrži nadm. visinu – pojašnjeno u uvodu
  • Najniža dozvoljena nadm. visina: ako točka ima treću dimenziju manju od ovdje navedene, neće biti preuzeta kao referentna visinska točk

Izdvajanje linija prijeloma terena:

  • Layeri koji sadrže linije prijeloma terena - navesti u kojim layerima se nalaze elementi crteža ( LWPOLYLINE, LINE, 3DPOLYLINE, 3DLINE ).


Podizanje 2D crteža u 3D

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Podizanje 2D crteža u 3D koristi tehnologiju pojašnjenu u prethodnom poglavlju , za izradu novih 3D elemenata u postojećem crtežu. Ova naredba služi najviše korisnicima koji predaju geodetski snimljene crteže za vanjsku 3D obradu.

2D linijski elementi biti će prikazani elementima 3DLINE

2D točkasti objekti biti će prikazani elementima POINT

Slojevi će biti preuzeti od polaznih elemenata crteža, dodajući prefiks G5-3D.


Digitalni model reljefa

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Digitalni reljef terena se uobičajeno prikazuje prostornim trokutima, takozvanom TIN mrežom. Jedini način izrade TIN mreže koji je u stanju vjerno prikazati teren je onaj koji izrađuje TIN iz referentnih točaka i linija prijeloma terena. GeoMIR5 koristi upravo taj matematički model. Naime, linije prijeloma terena sprječavaju izradu trokuta koji bi presijecali linije prijeloma terena čime bi došlo do deformacije modela u odnosu na stvarno stanje na terenu.

Prije same izrade modela, dobro bi bilo obrubiti crtež i stvoriti granicu kako bi bila spriječena izrada trokuta koji na terenu ne postoje.

GeoMIR5 pruža mogućnost učitavanja ili ispisa DMR-a LandXML formatom, koji je kompatibilan sa Autodesk proizvodima.

  • Granica

Odabir polilinije kao granice za DMR ili za granicu područja računanja kubatura.

  • Stvoriti novi

Formular za stvaranje DMR-a

  • Vidljivost

Prikazati ili isključiti DMR trokute

  • Pohrana u G5 predmet

Pohraniti DMR u G5 predmet. Potrebno je unijeti jednoznačan naziv za reljef. Ovakav način pohrane reljefa je potreban za izradu kubatura iz dva reljefa.

  • Učitavanje iz predmeta

Učitavanje prethodno pohranjenog/pohranjenih reljefa iz GeoMIR5 predmeta

  • Pohrana u LandXML format
  • Učitavanje LandXML formata


Slojnice

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Izrada slojnica iz, u crtežu aktualnog, digitalnog modela reljefa.

  • Slojnice iz DMRa

Izrada slojnica iz, u crtežu aktualnog, digitalnog modela reljefa. Potreban je unos ekvidistancije. Ovako stvorene slojnice prikazane su 3D-Polyline elementom crteža, na ispravnoj nadmorskoj visini, bez spline-a. Najmanja dozvoljena ekvidistanca je 0,1m.

  • Visina slojnice u Text

Odabirom slojnice ispisuje se tekst s visinom slojnice na mjesto odabira. Slojnica se prekida na tom mjestu.

  • Nadodavanje SPLINE slojnicama

Nakon što se unesu tekstovi visina slojnica, ovako se stvara 2D polilinija sa Spline krivuljama za što vjerniji prikaz slojnica.


Poprečni profili

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Izrada poprečnih profila oslanja se na princip 2D -> 3D elemenata crteža.

Poprečni profili se izrađuju u nekoliko koraka, ovisno o potrebi korisnika. Potrebno je definirati barem jednu os poprečnih profila, koja će biti nosilac svih potrebnih informacija. Izrada poprečnih profila bez definicije osi nije moguća.

Općenito, postoje dva načina izrade poprečnih profila: poprečni profili na kojima je svaka točka direktno mjerena te poprečni profili koji se dobivaju presjekom mjerenih linija loma terena. GeoMIR podržava oba načina te ih po potrebi objedinjuje u jednu cjelinu.

  • Stacioniranje polilinije kao osi pop. profila

Odabir polilinije koja će postati os poprečnih profila te automatska izrada poprečnih profila prema zadanim podacima.

Korak među poprečnim profilima: svakih koliko metara postaviti poprečni profil

Širina pojedinog poprečnog profila: ukupna širina profila

  • Definiranje polilinije kao osi pop. profila

Odabir polilinije koja će postati os poprečnih profila, bez stacioniranja.

  • Izbor polilinije kao mjereni pop. profil

Direktan izbor polilinije koja predstavlja direktno mjereni poprečni profil. Može se raditi o 3D-Poliliniji ili o 2D poliliniji prema principu 2D -> 3D elemenata crteža.

  • Ubacivanje pop. profila na os

Ubacivanje poprečnog profila proizvoljnim odabirom mjesta na osi. Služi za ciljano progušćenje profila.

  • Obrisati poprečni profil

Brisanje odabranog poprečnog profila te brizanje povezivanja sa osi.

  • Iscrtavanje poprečnih profila

Nakon što su poprečni profili definirani prethodnim radnjama, ovime se iscrtavaju. U tu svrhu automatski se stvara novi crtež, u koji se iscrtavaju svi profili.

2D->3D za presjecanje linija terena

Parametri:

Mjerilo Hz: horizontalno mjerilo za profile

Mjerilo Ve: vertikalno mjerilo za profile

Korak za raz.usp.: određivanje koraka za računanje razine usporedbe

Nula poprečnih profila:

Nepromjenjeno: početak linije poprečnog profila

Prvi presjek: prvi računski presjek

Os profila: os profila

Prikazati slojeve presjecanih linija: ako je uključen, pri presjecanju linija principom 2D->3D, prikazati layer presječene linije

Vrijednosti u MM umjesto u CM: ako je uključen, vrijednosti visina i udaljenosti prikazuju se u milimetrima, inače u centimetrima


Uzdužni profili

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Izrada uzdužnih profila oslanja se na princip 2D -> 3D elemenata crteža.

Uzdužni profil preko mjerenih točaka: predstavljen polilinijom povučenom preko mjerenih točaka

Prvo je potrebno nacrtati poliliniju preko mjerenih točaka, koju je prilikom pokretanja radnje potrebno odabrati. Prva točka polilinije je ijedno i prva točka uzdužnog profila.

Formular je u potpunosti identičan prije opisanom formularu za iscrtavanje poprečnih profila, samo što "Izdvajanje linija prijeloma terena", "Nula poprečnih profila" i "Prikazati layere presjecanih linija" nemaju funkciju.

Uzdužni profil slobodnim presjekom DMR-a: Presjecanje DMR-a prostoručno povučeno polilinijom

U crtežu mora biti prisutan jedan DMR te prostoručno provučena polilinija preko istoga, koju je prilikom pokretanja radnje potrebno odabrati. Smjer polilinije je ujedno i smijer računanja presjeka DMR-a.

U oba slučaja automatski se stvara novi crtež, u koji se iscrtava uzdužni profil.


Izrada bokocrta iz situacije

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Naredba projicira mjerene točke na liniju projekcije i prikazuje ih u obliku profila. Kako radi ova naredba, najbolje se vidi iz priloženih slika.

Bokocrti se izrađuju jedan po jedan.

Početak iz situacije (gornja slika) - mjerene točke moraju odgovarati jednoj od struktura koje podržava GeoMIR5 - SDGE ili jedna od starijih varijanti. Polilinija projekcije (magenta boje u primjeru) se povlači prostoručno i u proizvoljnom sloju. Polilinija obuhvata točaka koje se projiciraju se također povlači prostoručno i u proizvoljnom sloju. Jedina pravilo koje se mora poštovati je da polilinija projekcije i polilinija obuhvata imaju isti početak.

Naredba podržava kodirano mjerenje, za izdvojiti je dvije mogućnosti:

  • polilinije koje su nastale kodiranim mjerenjem ili nacrtane u situaciji, biti će točno tako prikazane u bokocrtu
  • dodatne informacije odgovarajućim simbolom iz kodne liste, biti će prikazane u bokocrtu

Nakon što su polilinije projekcije i obuhvata točaka nacrtane, pokreće se naredba "Bokocrt iz situacije", gdje je prvo potrebno odabrati mjerilo crteža i korak razine usporedbe. Odabir položaja osi nema utjecaja.

Rezultat je automatsko stvaranje novog crteža (donja slika). Tako dobiven, crtež se može pohraniti i dalje dotjerivati CAD alatima.


Kubatura iz dva reljefa

GeoMIR5 CAD modul ›› Izbornik "DMR" ››

Računanje kubature razlikom dva postojeća, i u predmetu pohranjena, reljefa. Ako u crtežu već ne postoje, prije računanja potrebno je učitati dva prethodno pohranjena reljefa iz aktualnog predmeta.

Matematičko računanje kubature vrši se internom izradom velikog broja poprečnih presjeka oba reljefa, računanjem površine među njima, te množenjem sa razmakom između presjeka. Kako bi rezultat bio što točniji, reljefi se interno presjecaju svaki centimetar.

Za površinu unutar presjeka se uzima samo onaj dio, koji je pokriven s oba reljefa. Dodatno sužavanje područja računanja kubatura je određivanje granice područja računanja.

Granica područja računanja mora biti nacrtana zatvorenom polilinijom i pokrivati oba reljefa. Nakon toga izbornikom "DMR/Granica" odabrati poliliniju granice područja računanja.

Rezultat računanja je kubatura u prostornim metrima [m³]. Po želji, moguće je izraditi poprečne profile u svrhu izvještaja, kao dokaza o računanju.

Računanje presjeka: matematičko računanje presjeka, rezultat je u oba slučaja isti

Automatski s juga prema sjeveru: koristiti kada nije potrebno izraditi izvještajne profile

Određivanje osi profila izvještaja: približno određivanje osi za izvještajne profile, u svrhu što vjernijeg prikazivanja presjeka

Izvještaji:

Bez izrade izvještaja: bez izrade izvještajnih profila

Izrada poprečnih profila: sa izradom izvještajnih profila

Određivanje poretka za računanje: koji reljef je "prvi" a koji "drugi" glede oduzimanja površina

Parametri za profile izvještaja: samo pri izradi izvještajnih profila

Mjerilo Hz

Mjerilo Ve

Korak za raz.usp.

Presjek svakih m: svakih koliko metara prikazati izvjštajni poprečni profil

Primjer izvještajnog profila:


Izbornik "DGU Zbirka"

GeoMIR5 CAD modul ››

Izbornik "DGU zbirka" je napravljen u svrhu olakšavanja crtanja prema aktualnoj zbirci kartografskih znakova Državne geodetske uprave. Sve ovdje dostupne funkcije oslanjaju se na predložak koji je u sklopu instalacije GeoMIR5 CAD modula , a isti se oslanja na digitalnu zbirku blokova te tipove linija koje je izdala DGU.

Izbrornik je podjeljen na linije i simbole prema poglavljima unutar zbirke. Linije i simboli će prilikom odabira biti prikazani prema mjerilu crteža.

Formular za linijske objekte:

Moguće je odabrati jednu definiciju iz popisa - elementi koji će u sljedećem koraku biti odabrani, biti će prebačeni u sloj iz definicije.

Stvoriti kopiju odabranih elemenata: elementi odabrani u sljedećem koraku biti će duplicirani, tj. odabrani elemenat ostaje u svom sloju dok će biti stvoren novi elemenat u odabranom sloju. To je ispravan pristup izradi po specifikacijama SDGE, kada snimljeni je snimljeni elemenat istovremeno situacija i dio DKP-a.

Simboli umjesto tipova linija: pri crtanju elemenata situacije, primjerice zidova, topografske simbole prikazati kao blokove, a ne kao do sada, tipom linije

Formular za točkaste objekte:

Potrebno je odabrati jednu definiciju iz popisa i u sljedećem koraku odrediti mjesto insertiranja u crtežu:

  • određivanjem točke unosa lijevom tipkom miša, biti će unesen samo jedan blok - u ovisnosti o definiciji, određuje se i kut zakreta
  • pritiskom desne tipke miša, otvara se mogućnost odabira linijskih elemenata LWPOLYINE i LINE, na čije rubove će se unijeti blok bez zakreta

Promjena Slojeva:

Naredbom "Promjena slojeva" jednostavno se prebacuju elementi crteža u sloj iz liste. Naredba je posebno pogodna kada se prebacuje u neki od "sufiks-slojeva", prema tehničkim specifikacijama za izradu digitalnog elaborata, jer ako sloj ne postoji, biti će stvoren.

Uključiti 'ON' sve slojeve: naredba uključuje (ne odmrzava) sve slojeve i postavlja sloj '0' kao trenutni.


Predložak (template), tipovi linija i slično

GeoMIR5 CAD modul ›› Izbornik "DGU Zbirka" ››

Instalacija GeoMIR*Desktop sadrži uvijek aktualni predložak (drawing template), oslonjen na crtež izdan od državne geodetske uprave i proširen za GeoMIR potrebe. Trenutno ime predloška je

g5_dge19.dwt

i moguće je da će se vremenom mijenjati. Navedeni predložak sadrži blokove i slojeve prema Zbirci kartografskih znakova iz 2018 te blokove i slojeve potrebne za izradu crteža prema specifikacijama SDGE.

Osim blokova i slojeva, predložak sadrži četiri Layouta (dva A3 i dva A4) prema ogledom elaboratu iz primjera izdanog od strane DGU. Layouti iz primjera su prilagođeni GeoMIR softveru uvođenjem varijabli, koje se automatski ispunjavaju naredbom " Priprema za štampu prema graf. prik. "

Zamišljeno je da korisnici prema svojim potrebama preprave Layoute, unošenjem vlastitih podataka tvrtke te pohrane novo stanje u vlastiti predložak pod nekim drugim imenom. Naime, GeoMIR*Desktop instalacija uvijek prepisuje postojeći predložak.

Osim predloška crteža, GeoMIR*Desktop instalira i ostale datoteke koje je izradila Uprava a koji su potrebni za pravilan grafički prikaz – tipove linija, shape-ove te biblioteku boja.


Izbornik "DGE Točke"

GeoMIR5 CAD modul ››

Izbornik "DGE Točke" je napravljen u svrhu olakšavanja prikaza točaka prema tehničkom specifikacijama SDGE.

DGE točke se, prema tehničkim specifikacijama, prikazuju blokom "tocke". DGE Točka blok element sadrži sve potrebne atribute za naknadni ispis u CSV datoteku te za prolazak kontrole kvalitete.

Točke vodova se prikazuju također sa blokom "tocka", no tu varira ispunjavanje atributa "VISINA" i "VISINA_VODA":

  • ako je točka voda snimljena direktno na vodu, istoj se popunjava atribut "VISINA_VODA" i vizualizira visinom u boji voda
  • ako je točka voda detektirana, popunjavaju se oba atributa i vizualiziraju s dvije visine, od koje je donja u boji voda

Naredbe:

  • Stvaranje točaka
  • Prenumeracija točaka: za odabrane potojeće DGE točke, numerički

Dodati konstantu: dodavanje numeričke vrijednosti na postojeće brojeve detaljnih točaka

Početna vrijednost: prenumeriranje počevši sa zadanom vrijednošću

Samo točke bez broja: prenumeraciju izvršiti samo za točke bez postojećeg broja točke, uključujući "." točke

Nakon popunjavanja formulara program prvo predlaže odabir polilinije na kojoj leže točke za prenumeraciju. Ako nije predviđena prenumeracija sljedeći poliliniju, potrebno je pritisnuti ESC tipku i direktno odabrati točke za prenumeraciju.

Osnovna razlika je u redoslijedu dodjeljivanja brojeva točaka. Provlačenjem polilinije preko točaka može se utjecati na redoslijed dodjeljivanja brojeva točaka – brojevi će biti dodijeljeni sljedeći smjer polilinije. Bez odabira polilinije, odnosno direktnim odabirom točaka za prenumeraciju, redoslijed dodjeljivanja brojeva ovisit će o internom redoslijedu entiteta unutar CAD softvera.

  • Uređivanje atributa
  • Prihvaćanje učitanih DKP točaka: odabirom postojećih DKP točaka, iste se prebacuju u sloj "8_tocke-zamijenjeno" te se stvara identična kopija iste na sloju "8_tocke-novo" (SDGE!)
  • Skica u održavanje:
  • Zamjena vrijednosti BROJ - BROJ_U_ELABORATU: unutar GML-a postoje dva podatka za broj točke - BROJ i BROJ_U_ELABORATU. Ovom naredbom se prebacije prikazan broj unutar atributa između tih vrijednosti
  • Poligoni - iz post.blokova ili direktno: stvaranje ispravnih SDGE blokova za poligone (pomoćne točke) iz postojećih SDGE blokova "tocke" ili direktnim unosom.
  • CSV Napomena: CSV Datoteka prema SDGE propisima sadrži stupac napomena, no blok "tocke" ne sadrže odgovarajući atribut. Ovom naredbom moguće je unijeti podatak Napomena, koji je nevidljiv u bloku no pojaviti će se pri ispisu točaka u CSV i XLS datoteku.
  • Slojevi za podatak vrsta
  • Interpoliranje visina na osnovu DMR-a: Interpoliranje visina u atribute točaka (SDGE blok "tocke", atribut VISINA) na osnovu DMR-a. Interpolirana vrijednost se unosi samo ako je atribut prazan.
  • Prepoznavanje visina na osnovu TEXT-a: Prepoznavanje i unošenje visina u atribute točaka (SDGE blok "tocke", atribut VISINA) iz obližnjih TEXT/MTEXT elemenata. Nakon pokretanja naredbe, potrebno je unijeti toleranciju za najveće dozvoljene udaljenosti TEXT/MTEXT elemenata od bloka te odabrati točke za koje je potrebno izvršiti pretraživanje. Na kraju izvršenja, moguće je obrisati prepoznate TEXT/MTEXT elemente.
  • Određivanje točaka voda: odabirom DGE točaka ili polilinije koja ih spaja, prebacuje se atribut visine iz "VISINA" u "VISINA_VODA"
  • Detekt. točka voda - odabirom dvije DT: odabirom prvo točke voda a zatim točke terena, točka voda se popunjava atributom "VISINA"
  • Detekt. točka voda - dubinom voda: odabirom točaka voda te unosom dubine voda, točka voda se popunjava atributom "VISINA"
  • Dvije DT u jednu s dvije visine
  • Vizualiziranje kota terena: prikazivanje kote terena iz DGE točaka blokom "80101-1" u sloju "vsit_kote"
  • Vizualiziranje kote voda: prikazivanje visina voda za odabrane točke prema tehničkim specifikacijama. Moguć je odabir, hoće li se prikazati linija razlomka visina ili ne.
  • Vizualiziranje kote voda dubinom: Vizualiziranje kote terena+voda odabirom bloka "tocka" sa kotom terena i unosom dubine voda
  • Multi-promjena polož. Broja točke: višestruka promjena položaja atributa "TOCKA" bloka "tocke". Prvo se odaberu svi atributi kojima je potrebno promijeniti položaj, nakon čega se odredi pomak za PRVI odabrani atribut. Svi ostali atributi će biti pomaknuti za iste vrijednosti.
  • Multi-promjena polož. kote terena: višestruka promjena položaja atributa "VISINA" bloka "80101-1". Prvo se odaberu svi atributi kojima je potrebno promijeniti položaj, nakon čega se odredi pomak za PRVI odabrani atribut. Svi ostali atributi će biti pomaknuti za iste vrijednosti.
  • Učitavanje DGU točaka iz CSV datoteke
  • Ispis točaka u CSV datoteku


Stvaranje točaka

GeoMIR5 CAD modul ›› Izbornik "DGE Točke" ››

Izborom ove radnje, stvaraju se DGU točke na odabranim linijskim objektima i simbolima, ili slobodnim izborom na zasloni.

U prvom koraku, potrebno je odabrati elemente (linije, polilinije, blokove) na kojima će biti stvorene točke. Prekidom radnje bez odabira, moguće je slobodno odabrati poziciju u crtežu.

Ako su na simbolima te na prijelomima polilinija pronađene mjerene točke preuzete iz GeoMIR5 softvera, DGU točke preuzimaju njihov broj točke i visinu.

Iz elementa crteža 3DPOLYLINE preuzimaju se nadmorske visine, osim ako nije onemogućeno opcijom "Nadmorske visine ne preuzimati".

U slučaju stvaranja točaka za koje nije moguće automatski odrediti broj, program traži unos početne vrijednosti za automatsku numeraciju. Nakon stvaranja, posljednji broj točke se pamti za sljedeće korištenje naredbe.

Pri stvaranju točaka potrebno je unijeti polazne šifre za Vrstu, Stabilizaciju i Nastanak točke. Sve šifre moguće je naknadno izmijeniti.

Šifra Vrsta će biti određena elementom crteža - za simbole ulogu igra naziv bloka a za polilinije sloj. Ako za element crteža ne postoji detaljna definicija, preuzima se polazna vrijednost za šifru Vrsta.

Za atribute broja točke te nadmorskih visina, stvara se zaseban sloj kako bi bio moguće odrediti boju atributa.

Dodatne opcije pri stvaranju DGU točaka:

  • Prijelome bez mjerenih točaka preskočiti - sprječavanje izrade DGU točaka na prijelomima polilinija (vertex) na kojima ne postoji mjerena točka - vizualizirana nekim općenitim blokom.
  • Nadmorske visine ne preuzimati - sprječavanje preuzimanja podatka o nadmorskoj visini mjerene točke, ukoliko postoji, u DGE točku.
  • Visine točaka su na vodu - pri stvaranju točaka iz nekog proizvoljnog bloka, koji sadrži visinu, bez obzira koordinatno ili iz atributa, ista će biti prebačena u atribut "VISINA_VODA"
  • Prikazati kao točke situacije - ako je označeno, točke će biti učitane u sloj "sit_8_tocke", u protivnom u sloj "8_tocke_novo".


Uređivanje atributa

GeoMIR5 CAD modul ›› Izbornik "DGE Točke" ››

Naredba sadrži razne parametre za uređivanje atributa postojećih točaka u crtežu, bile to nove točke ili učitane.

Mogućnosti ove naredbe proizašle su iz potreba korisnika softvera pri radu sa SDGE pravilnikom.

Kvačicom se označava koje radnje trebaju biti izvršene za naknadno odabrane točke, moguće je izvršavanje više radnji u jednom koraku. Neke od radnji imaju i dodatne parametre poput vrste točke ili elaborata.

Poništavanje atributa znači brisanje postojeće vrijednosti i ostavljanje praznim.

Ako je kvačica uključena za:

  • Vrsta, Stabilizacija i Nastanak - vrijednost iz padajućeg izbornika biti će upisana u atribut
  • Elaborat - potrebno je unijeti tekst koji će biti upisan u atribut
  • Ažuriranje E i N - atributi E_MJERENO i N_MJERENO biti će upisani prema trenutnom položaju točke na dvije decimale
  • Poništiti atribut "ZIS_TOCKA_ID" - poništavanje atributa
  • Poništiti atribut "VISINA" - poništavanje atributa
  • Poništiti atribut "VISINA VODA" - poništavanje atributa
  • Poništiti atribute visine sa podatkom "0.00" - poništavanje atributa
  • Atributi VISINA i VISINA_VODA na dvije decimale - preračunavanje vrijednosti visina na dvije decimale
  • Uključiti učitane (iz GML-a) točke u odabir - ako nije zakvačena, naknadni odabir točaka će prihvatiti samo nove točke - ako je, onda sve točke (nove i učitane iz GML-a).

Poništavanje atributa visina točaka te preračunavanje na dvije decimale pogodno je pri kodiranim mjerenju, jer olakšava rješavanje specifičnosti pri stvaranju teme kodiranja i preuzimanja podataka.


Slojevi za podatak vrsta

GeoMIR5 CAD modul ›› Izbornik "DGE Točke" ››

Šifru Vrsta moguće je vrlo fleksibilno odrediti u odnosu na layere i blokove elemenata crteža. Primjerice da sve polilinije u layeru XYZ imaju šifru "21" ili svi blokovi ABC imaju šifru "14".

Padajućim izbornikom odrediti za koju šifru se određuju layeri ili blokovi.

Unutar tekst odjeljka "Layer(i)" potrebno je unijeti layere ili blokove elemenata crteža, po jedan u svaki redak, prema kojima će biti određena šifra Vrsta. Pri unosu naziva bloka, potrebno je upisati znak "~" prije samog naziva, kako bi se podatak razlikovao od naziva layera.

U slučaju višestrukog podatka vrsta - dvostrukom definicijom ili sudarom dvije ili više polilinija u jednoj točci, biti će preuzeta vrsta s najmanjom šifrom.

Primjer: Iz ove definicije proizlazi da će sve DGU točke koje se nalaze na polilinijama u layerima "40101-1" i "40102-1" dobiti šifru "51".

Primjer: Iz ove definicije proizlazi da će sve DGU točke koje se nalaze na bloku "19999-1" dobiti šifru "61".


Ispis DGE točaka u datoteku

GeoMIR5 CAD modul ›› Izbornik "DGE Točke" ››

Ispis DGE točaka u CSV i XLSX datoteku prema pravilniku za ispis koordinata u digitalnom obliku.

Nakon što se odaberu DGE točke za ispis, pojavljuje se formular sa tabličnim prikazom odabranih točaka za završnu kontrolu ispisa:

Vrijednosti u stupcima E,N te E0,N0 ovise o tome radi li se o preklopu ili uklopu.

Opcije:

  • Naziv datoteke automatski u istu mapu s crtežom - CSV datoteka će biti stvorena bez interakcije, i to u istu mapu i s istim nazivom kao crtež.
  • Ispisati direktno u Excel - odabrane DGU točke biti će direktno ispisane i pohranjene u Excel datoteku. Preduvjet je instaliran Microsoft Excel na računalu kao i dostupnost predloška . Datoteka će biti stvorena bez interakcije, i to u istu mapu i s istim nazivom kao crtež.
  • Ispisati samo točke za održavanje - u datoteke će biti izvedene samo točke za održavanje, one kojima je 15 <= vrsta < 50.
  • Ispisati za katastar vodova (bez E0 i N0) - u datoteku neće biti ispisani podaci o koordinatama za održavanje (E0 i N0).

Dodatna vrijednosti za polja, koja se upisuju za sve točke iz popisa:

Točnost [m] - točnost točaka u metrima

Pouzdanost [%] - pouzdanost točaka u %

Način transformacije - prema šifrarniku iz Tehn. specif. za određ. koordinata


Dvije DT -> jedna DT s dvije visine

GeoMIR5 CAD modul ›› Izbornik "DGE Točke" ››

Spajanje dvije detaljne točke u jednu s dvije visine. Prvo je potrebno unijeti Najveći razmak za spajanje DT u zasebnom formularu. Sve detaljne točke, koje su unutar unesenog razmaka, stvaraju grupu točaka. Ako su unutar grupe više od dvije točke, dojavlja se pogreška.

Na ovaj način moguće je dvije neovisno snimljene detaljne točke prikazati kao jednu detaljnu točku s dvije visine, najčešće u svrhu prikaza točaka nekog voda.

Formular za spajanje svije detaljne točke u jednu:

Pri pokretanju formulara, svaki par točaka je posebno naveden. Unutar svakog para postoji točka A i točka B, s time da je točka A nižeg broja točke. Cilj je iz dvije točke A i B stvoriti novu točku N. Iz tablice je vidljivo koja točka je A a koja B. U stupcu N= određuje se koja točka, A ili B, će postati osnovna točka a koja preostala točka.

Osnovna točka - iz nje se preuzimaju koordinate, broj točke i prva visina

Preostala točka - iz nje se preuzima druga visina

Kvačicom s lijeve strane može se određeni par točaka izbaciti iz postupka izrade nove točke s dvije visine.

Tipka "Sel: N = A" - odabranim podacima iz tablice će točka A biti postavljena kao Osnovna točka

Tipka "Sel: N = B" - odabranim podacima iz tablice će točka B biti postavljena kao Osnovna točka

Obrisati izvorni par točaka - nakon stvaranja nove točke s dvije visine, izvorni par točaka će biti obrisan iz crteža


DGE Grafika

GeoMIR5 CAD modul ››

Izbornik sadrži naredbe vezane uz izradu grafičkog dijela Digitalnog geodetskog elaborata , ograničene na grafiku bez korištenja knjižnih podataka.

Popis naredbi:

Učitavanje slike sa GeoPortala

Učitavanje GML datoteka (ZIP)

Brisanje Kat.Opć.

Poništavanje linije - odabirom linije DKP-a, primjerice granice čestice ili zgrade, ista će biti prebačena u sloj sa sufiksom "_ponisteno"

Znak pripadnosti - unos odgovarajućeg bloka

Zgrada - O - unos odgovarajućeg bloka

Zgrada - X - unos odgovarajućeg bloka

Zgrada X ili O iz šrafura - unos odgovarajućih blokova iz GML šrafura

Linijski objekti - prebacivanje bilo kojeg linijskog objekta u strukturu DKP-a, osim strukturnih linija.

Strukturne linije - prebacivanje bilo kojeg linijskog objekta u strukturnu linije prema strukturi DKP-a.

Simboli-blokovi - unos simbola/blokova prema strukturi DKP-a.

Šrafure - odabirom vrste šrafure i zatvorenih polilinija stvara se Solid Hatch ispravne boje za svaku odabranu poliliniju

Toponimi - odabirom vrste toponima iz popisa, isti se ubacuje u crtež.

Podaci kućnih brojeva - odabirom postojećih kućnih brojeva, pohranjuju se Šifra ulice (S_U) i Šifra naselja (S_N) atributi, koji se koriste pri unosu novih kućnih brojeva

Priprema za štampu prema graf. prik.

Slojevi prema grafičkom prikazu - odabirom vrste grafičkog prikaza program pali i gasi slojeve

Uključivane preth .izoliranih sloj. - uključivanje isključenih slojeva prethodnim naredbama

Odabir elemenata za DXF2GML

Ispis u DXF datoteku za DXF2GML

Parametri ispisa u GML datoteke

Ispis elemenata u GML datoteke - ispis elemenata crteža u GML datoteke prema zahtjevima urbanizma.


DKP-SDGE

GeoMIR5 CAD modul ›› DGE Grafika ››

Digitalni katastarski plan (DKP) osnova je za izradu grafičkog djela Digitalnog geodetskog elaborata prema pravilnicima Državne geodetske uprave.

GeoMIR se oslanja na DKP pri učitavanju GML datoteka dobivene SDGE aplikacijom, prikazujući teme iz GML datoteka DKP slojevima, a sve ostale informacije koje su sadržane GML datotekama, interno povezuje sa grafičkim elementima, kako te informacije ne bi bile izgubljene u CAD sučelju. Strukturne informacije koje nemaju grafički prikaz, primjerice podaci o posjednicima katastarskih čestica, vezane su interno uz bazu podataka crteža.

Ovako stvoren DKP sadrži mnogo više podataka, nego što sadrži DWG datoteka dobivena kroz FME aplikaciju.


Učitavanje slike sa GeoPortala

GeoMIR5 CAD modul ›› DGE Grafika ››

Učitavanje slike sa WMS servera GeoPortala Državne geodetske uprave direktno u crtež. Za izvršenje preuzimanja slike, potreban je pristup internetu. Nakon preuzimanja, slika će biti preuzeta u sloj "g5_geoportal".

Kao vrsta karte može biti odabran "DOF 2019", "DOF 2018", "DOF 2017", "DOF 2014/2016", "DOF 2011", "HOK" ili "TK25".

Formati datoteke - mogu biti JPEG, TIFF, GeoTIFF ili PNG, uz mogućnost odabira dodatnih parametara:

  • Za JPEG datoteke moguće je odabrati kvalitetu slike, gdje je vrijednost 10 najmanja a 98 najveća kvaliteta. Vrijednost 75 je najčešća.
  • Za TIFF i GeoTIFF datoteke moguće je odabrati vrstu kompresije, od kojih je LWZ kompresija najčešća. TIFF i GeoTIFF zauzimaju više prostora na disku od JPEG i PNG datoteke.
  • Za PNG datoteku ne mogu se odabrati dodatni parametri.

Pristup podacima - može biti anoniman ili korištenjem vjerodajnice. Slika preuzeta anonimnim pristupom imati će vodeni žig. Sve informacije vezane uz registrirani pristup, razlike anonimnog i registriranog pristupa te izdavanje vjerodajnice nalaze se na stranicama DGU Geoportala: http://geoportal.dgu.hr/#/menu/pomoc .

Razlučivost slike u DPI - moguć odabir vrijednosti 96, 150 i 300, pri čemu za sada treba preuzimati 96, jer veća razlučivost samo povećava datoteku bez da je slika oštrija.

Smještaj slike/slika - određivanje mape (direktorija) u koji će biti pohranjene preuzete slike:

  • U istu mapu gdje je crtež
  • U lokalnu podmapu (subdirectory) mape gdje je crtež, direktnim unosom naziva
  • U proizvoljnu mapu, odabirom iste - poziva se standardni formular za odabir mape

Informatički gledano, najbolja je druga varijanta, jer ukoliko se cijela mapa kopira ili sprži na CD/DVD, slike ostaju povezane sa crtežima.

Područje:

  • direktnim unosom vrhova četverokuta jedne slike - na zaslonu se unesu dva vrha četverokuta unutar kojeg se unosi jedna slika.
  • unosom poligona područja zahvata - nakon unosa poligona na koji obuhvaća područje, softver će popuniti isto rasterom manjih kvadratičnih slika. Veličinu slike je također moguće unijeti, a vrijednosti moraju biti zaokružene na metar u rasponu od 50 do 500 metara. Ovaj način je idealan za unos slika za nepravilne objekte poput cesta.

Zahvaljujem gospodinu Josipu Magdaleniću na ustupanju izvornog koda za pristup WMS serveru.


Učitavanje GML datoteka (ZIP)

GeoMIR5 CAD modul ›› DGE Grafika ››

Učitavanje GML datoteka, pohranjenih u ZIP datoteci dobivene iz SDGE aplikacije te stavljene na raspolaganje kao "Izvoz iz Geodetsko-Tehničkog dijela katastarskog operata", vrši se u ovom formularu:

pritiskom na tipku "> odabir ZIP datoteke".

Pri učitavanju, GeoMIR5 stvara crtež prema DKP strukturi, na prvi pogled sličan klasičnoj DKP datoteci. No, razlike postoje.

  • Vidljiva razlika je automatska izrada šrafura za sve zgrade.
  • Nevidljiva razlika je učitavanje velikog broja strukturnih podataka sadržanih u GML datotekama, koje služe za sve ostale radnje vezane uz DKP.

Prije učitavanja pritiskom na tipku "OK", moguće je odrediti:

  • Mjerilo, odabirom iz padajuće liste
  • Hoće li podaci biti učitani na postojeće stanje. U pravilu ova kvačica ostaje prazna, jer se GML najčešće učitava u praznu datoteku. U slučaju učitavanja nadopune GML-a, otvori se crtež u kojem već postoji učitan GML, te nakon odabira datoteke nadopune, aktivira se kvačica "Učitati na postijeće stanje"

U slučaju ako podaci sadržavaju više od jedne katastarske općine, može doći do progrešaka pri kontroli kvalitete. U tom slučaju crtež mora biti rapodjeljen po katastarskim općinama. Postupak:

  1. Crtež koji sadrži više katastarskih umnožiti, tako da za svaku katastarsku općinu postoji jedan zaseban crtež. Znači, sada imamo više istih crteža, za svaku KO po jedan.
  2. Otvoriti crteže jedan po jedan, naredbom "Brisanje Kat.Opć." te odabrati općine koje treba obrisati. Naredba provjerava sve elemente crteža i koristeći knjižne podatke, briše elemente.


Brisanje elemenata katastarske općine

GeoMIR5 CAD modul ›› DGE Grafika ››

Preuzete ZIP-SPP datoteke mogu sadržavati više od jedne katastarske općine. Podaci će uredno biti učitani u DWG, no često se podaci prekapaju, pogotovo točke koje su položajno identične ali imaju različite brojeve. Ako granica katastarske općine prelazi preko zgrade, pojaviti će se dvostruki centroidi. SDGE kontrola kvalitete ne predviđa takvu situaciju i izbacuje pogreške.

Pri digitalnom predavanju elaborata, potrebno je razdvojiti podatke, za svaku katastarsku općinu zasebno.

U tu svrhu napravljena je naredba za brisanje elemenata katastarske općine. Nakon pokretanja naredbe, potrebno je odabrati katastarsku općinu koja se briše iz crteža.

Predlaže se korištenje na sljedeći način:

- otvoriti crtež koji sadrži sve podatke, inicijalno učitan iz GML-a. Neka, recimo, sadrži katastarske općine A i B

- pokrenuti naredbu i odabrati jednu katastarsku općinu prikazanu u popisu, recimo B

- program briše sve elemente crteža katastarske općine B

- pohraniti crtež koji sada sadrži samo podatke katastarske općine A, recimo pod nazivom "KO-A"


Priprema za štampu prema graf. prik.

GeoMIR5 CAD modul ›› DGE Grafika ››

Naredba poziva formular u kojemu se odabire vrsta grafičkog prikaza te predmetna čestica. Iz tih podataka se preuzimaju podaci u katastarskoj općini, detaljnom listu i izvornom mjerilu. Ostali podaci potrebni u sastavnici unose se direktno i pamte se za daljnje korištenje, kako ne bi trebali biti unošeni svaki puta.

Nakon potvrde za izvršenje naredbe, program:

  • popunjuje sastavnicu trenutnog layouta
  • pali i gasi slojeve prema odabranom prikazu
  • zumira odnos layouta i modela prema mjerilu crteža

Predložak (drawing template) , koji je sastavni dio instalacije, sadrži četiri layouta u kojima se nalaze sastavnice i unutar njih takozvane varijable - tekstovi koji se pri izvršenju naredbe zamjenjuju onima iz formulara. Popis varijabli:

{mjerilo} - Mjerilo crteža

{katopc} - Nazik KO

{mbrko} - Matični broj KO

{detlist} - Detaljni list

{izvmjerilo} - Izvorno mjerilo

{izradola} - Izradio/la

{datum} - Datum

{elaborat} - Elaborat

{odgovosob} - Odgovorna osoba

{prikaz} - Vrsta prikaza

{investitor} - Investitor

Varijable mogu biti slobodno pomicane po layoutu, može biti mijenjana veličina, boja i slično. Bitan je samo tekst variable. Varijabla može biti samostalna ili dio teksta, a ako je nema na layoutu, neće biti ispisano ništa.

Na ovaj način, svaki korisnik može po svojim potrebama preurediti postojeće ili napraviti nove layoute, i na kraju pohraniti iste unutar predloška.

Slojevi se uključuju i isključuju naredbom "OFF", a ne "FREEZE", znači slojevi se isključuju a ne zamrzavaju.


DXF datoteka za DXF2GML

GeoMIR5 CAD modul ›› DGE Grafika ››

Priprema podataka za stvaranje DXF datoteke za konverziju u GML format za direktan unos u informacijski sustav e-Dozvola Ministarstva graditeljstva i prostornog uređenja. Priprema podataka slijedi upute Državne geodetske uprave.

Prvo je izbornikom "Odabir elemenata za DXF2GML" potrebno odabrati elemente crteža koje treba ispisati.

Slojevi za građevine će biti automatski određeni, pošto svaka građevina treba biti u zasebnom sloju. Za ostale objekte je moguće unijeti naziv sloja ili koristiti jedan od ponuđenih. Program pamti nove slojeve i pri sljedećem pokretanju biti će ponuđeni. Postupak odabira potrebno je provesti za svaku vrstu objekta pojedinačno.

Nakon odabira svih objekata, izbornikom "Ispis u DXF datoteku za DXF2GML" potrebno je odrediti naziv i mjesto pohrane gdje će DXF datoteka sa prethodno odabranim objektima biti ispisana.


Stvaranje GML datoteke za urbanizam

GeoMIR5 CAD modul ›› DGE Grafika ››

GeoMIR5 omogućava ispis sadržaja geodetskog projekta iz DKP strukture podataka direktno u GML datoteke prema zahtjevima urbanizma, bez potrebe za konverzijom putem DXF2GML Web aplikacije. Svi novi elementi DKP-a - oni koji su stvoreni nakon učitavanja iz GML datoteka i naredbama ( Linijski objekti, Strukturne linije, Simboli-blokovi ) prebačeni u ispravne DKP slojeve - biti će ispisani u jednu od datoteka:

CESTICE.GML - sadržaj sloja 1_kc_medja-novo , elemenat LWPOLYLINE , zatvorena u poligon

ZGRADE.GML - sadržaj sloja 2_zg-novo , elemenat LWPOLYLINE , zatvorena u poligon

STRUKLIN.GML - sadržaj sloja 4_sl_??-novo , elemenat LWPOLYLINE

TOCKE.GML - sadržaj sloja 8_tocke-novo, elemenat INSERT

Kako korisnik imao kontrolu pri postupku ispisa, naredbom Izoliranje novih GML podataka izoliraju se podaci pripremljeni za ispis u GML, što olakšava odabir elemenata.


DGE Knjižno

GeoMIR5 CAD modul ››

Izbornik sadrži naredbe vezane uz izradu grafičkog dijela Digitalnog geodetskog elaborata , koristeći knjižne podatke preuzete iz GML datoteka. Učitavanje mGML-a iz SDGE aplikacije, GeoMIR*Desktop učitava i "nevidljive" knjižne podatke, koji se gube prilikom konverzije u DXF putem SDGE aplikacije. Knjižni podaci se pohranjuju direktno u crtež. Sustav za pohranu i korištenje knjižnih podataka u potpunosti je rezultat razvoja našeg softvera i jedinstven je na tržištu.

Rezultat naredbi za rad sa knjižnim podacima:

  1. Ispis u MTEXT prema tehn. spec. za izradu DGE
  2. Ispis u MS Word ili MS Excel, u ovisnosti od naredbe

Popis naredbi:

Knjižni podaci elementa

Odabir predmetnih čestica

Poništavanje predmetnih čestica

Posjednici KČ. u MTEXT - odabirom broja čestice, program će ispisati vezane posjednike

Uporaba KČ u MTEXT - odabirom broja čestice, program će ispisati vrstu uporabe čestice u MTEXT

Uporaba KČ u blok "uporaba" - odabirom broja čestice, program će ispisati vrstu uporabe čestice u blok

Posjednici i uporaba kat.čest. u MTEXT - odabirom brojeva čestica, program će ispisati vezane posjednike i vrstu uporabe čestice u MTEXT

Posj:indik.+ pomak

Broj indikacije - odabirom brojeva čestica, program će ispisati redne brojeve indikacija unutar kružnice

Površine KČ iz GMLa - odabirom brojeva čestica, program će ispisati atributne i grafičke površine, preuzete iz GML-a, i prikazati u editoru

Posjedovni list za KČ - odabirom čestica izrađuje se posjedovni list u Word datoteci

Identifikacije Z.K. čestica - odabirom čestica izrađuje se Excel datoteka sa identifikacijama Z.K. čestica

Pozivi i potpisna lista - Sučelje za automatiziranu izradu pisama, primjerice poziva i potpisnih lista


Pojam predmetne čestice

GeoMIR5 CAD modul ›› DGE Knjižno ››

Pojam predmetne čestice uveden je kao osnova za odabir čestica pri pozivanju raznih naredbi. Sučelje za rad sa predmetnim česticama nudi dvije naredbe:

"Odabir predmetnih čestica" - prvo se nudi odabir brojeva katastarskih čestica iz crteža (blok "kc"). Ukoliko se u ovom trenutku pritisne tipka ESC, program nudi korisniku direktan unos brojeva čestica formularom:

Polja će biti prazna ukoliko se po prvi puta definiraju predmetne čestice u crtežu, odnosno biti će prikazani već unešeni podaci. Posebnu pažnju treba posvetiti katastarskoj općini, ukoliko ih ima više u crtežu.

Nakon unosa predmetnih čestica, na jedan ili drugi način, program sam pronalazi susjedne čestice. Algoritam pronalaženja susjednih čestica pronalazi sve čestice koje dodiruju odabrane predmetne čestice, čak i one koje dodiruju odabrane predmetne čestice u samo jednoj točci. Nakon pronalaženja susjednih čestica, popis čestica se prikazuje na komandnoj liniji i pritiskom na OK pohranjuju se podaci.

"Poništavanje predmetnih čestica" -briše se odabir iz crteža.

Pokretanjem neke od naredbi koje podržavaju odabir čestica ovim načinom, primjerice naredba za izradu poziva i potpisnih lista, pojaviti će se ovakav formular:

Na taj način nije potrebno uvijek klikati na brojeve čestica već odabrati iz popisa. Ukoliko je potrebo odabrati čestice koje nisu niti predmetne niti susjedne, može se kliknuti na četvrtu mogućnost "Manualno odabrati čestice".


Popis posjednika s indikacijama u MTEXT

GeoMIR5 CAD modul ›› DGE Knjižno ››

Naredba koja objedinjuje nekoliko radnji u jedan korak.

Korisnik prvo odabire brojeve čestica, potom unosi početni broj za indikaciju i na kraju a odabire poziciju u crtežu za ispis posjednika.

Program unosi brojeve indikacija neposredno uz brojeve čestica te ispisuje posjednike sa odgovarajućim brojevima indikacija na željenu poziciju u crtežu.


Izrada pisama i potpisnih lista

GeoMIR5 CAD modul ›› DGE Knjižno ››

Izrada pisama odabirom čestica je skup naredbi, napravljenih kako bi se olakšala izrada raznih pisama osobama vezanim uz katastarske čestice.

Nakon odabira čestica, poziva se formular za vizualno spajanje osoba:

Knjižni podaci preuzeti iz GML-a sadrže Imena i adrese osoba, no one su često u opisnom obliku i ne mogu biti direktno korištene za izradu pisama. Nadalje, iako se radi o istim osobama, katastarski i ZK podaci se vode odvojeno, što otežava postupak.

Osobe označene crnom bojom su u obliku kako su učitane, bez promjene. Klikom na osobu, u strukturnim poljima u desnoj strani formulara s desne strane se pojavljuju sirovi strukturirani podaci, pri dnu se nalaze dva opisna polja koja nije moguće mijenjati. Cilj je popuniti strukturna polja kako bi bila moguća izrada pisama. To se radi manualnim unosom podataka - u tu svrhu je napravljeno nekoliko naredbi, dosupnih tipkama, koje olakšavaju prevođenje opisnih podataka podataka u strukturne. Nakon što su podaci uređeni i eventualno osoba određena kao pravna (kako bi u potpisnoj listi bila dodana potrebna polja), potrebno je pohraniti promjene za svaku osobu posebno, tipkom "Ažuriranje". Tipke i značenje:

"Opisno > Strukt.": pokušava raspoznati podatke i iz opisnih prebaciti u strukturne

"Čitljivo": strukturni podaci su najčešće pisani velikim slovima, ova naredba ih pretvara u kombinaciju velikih i malih slova

"Naselje > Pošt. Broj": opisni podaci u pravilu ne sadržavaju poštanski broj, ova naredba pokušava pronaći poštanski broj iz naziva naselja

"Ažuriranje": Nakon što se opisni podaci pretvoreni u strukturne, potrebno je ovom tipkom te podatke ažurirati. Nakon ažuriranja, osoba se označava zelenom bojom.

Stupac "Čestice" sadržava brojeve čestica vezanih uz osobu, gdje su ZK čestice označene zvjezdicom. Ukoliko ima više redaka koji su u stvari ista osoba, moguće je Drag-and-drop postupkom povući broj čestice nekoj drugoj osobi.

Pritiskom na tipku "OK", pohranjuju se podaci o osobama i poziva se formular za izradu pisama:

Popis osoba je sličan prethodnom, samo što je sada potrebno odabrati osobe za izradu pisama. Zelenom bojom su označene osobe koje su vizualno uređene.

Odjeljak "Dokumenti" prikazuje koji su dokumenti do sada bilo korišteni. Za to predviđenim tipkama se odabiru datoteke, koje su podloge za izradu pisama. Ukoliko je potrebno izraditi potpisnu listu za osobe, potrebno je zakvačiti tu opciju.

Pritiskom na "OK" pokreće se izrada pisama.

MS Word datoteke koje se koriste kao podloge za izradu pisama moraju sadržavati sljedeće tekstove, kako bi program popunio mjesta:

{IME}

{PREZIME}

{ULICA}

{KBR}

{POSTBROJ}

{NASELJE}

{DRZAVA}

{KATCEST} - Posjednik na k.č.:

{ZKCEST} - Vlasnik na k.č.:

Ostatak sadržaja je proizvoljan. Primjer datoteke je sadržan u instalaciji softvera:

Rezultat je jedna MS Word datoteka koja sadrži sva pisma, zatim po jedna potpisna lista sa predmetne i susjedne čestice.


Ispis popisa posjednika u MS Word

GeoMIR5 CAD modul ›› DGE Knjižno ››

Odabirom katastarskih čestica, softver pronalazi katastarske podatke o istima te ispisuje posjednike, pravni odnos te detaljne podatke o načinu korištenja dijelova čestica te atributne površine.

Navedeni podaci se oslanjaju na knjižne podatke učitane SDGE ZIP datoteke .

Ispis se oslanja na predloške, koji su sastavni dio instalacije a mogu biti i po potrebi prilagođavani vlastitim potrebama.


Identifikacija ZK čestica u crtež i MS Excel

GeoMIR5 CAD modul ›› DGE Knjižno ››

Odabirom katastarskih čestica, softver pronalazi katastarske i ZK podatke o istima te ispisuje posjednike, vlasnike te površine. Oznaka i korištenje zemljišta ovdje nisu detaljno navedene.

Nakon odabira čestica, pojavljuje se formular kojim se određuje način vizualiziranja brojeva ZK čestica u odnosu na razliku u površini između katastarskog i ZK stanja:

Brojevi ZK čestica se vizualiziraju blokom "kc". Opcije:

  1. svi brojevi ZK čestica biti će ispisani u sloj "1_kc_broj_ZK"
  2. površine koje su identične u katastarskom i ZK stanju (unutar tolerancije), biti će upisane u zaseban sloj "1_kc_broj_ZK_ident".

Prema želji, broj ZK čestice može biti zatvoren u zagradu - kvačicom u za to predviđenom polju.

Navedeni podaci se oslanjaju na knjižne podatke učitane SDGE ZIP datoteke .

Primjer ispisa u Excel:

Ispis se oslanja na predloške, koji su sastavni dio instalacije a mogu biti i po potrebi prilagođavani vlastitim potrebama.


Izbornik "SDGE servis"

GeoMIR5 CAD modul ››

Izbornik "SDGE veza" objedinjuje radnje spajanja na sustav DGE online putem HTTPS protokola. Softver GeoMIR*Desktop služi kao klijent koji šalje zahtjev serveru sustava DGE. Komunikacija se oslanja na javno objavljen protokol komunikacije naziva "SDGE REST API", koji je objavljen od strane Državne geodetske uprave i dostupan je svakom korisniku prilikom prijave u odjeljku pomoć.

Stvaranje uvjeta za korištenje naredbi za spajanje na SDGE servis:

1. Stvaranje servisnog korisničkog računa unutar SDGE korisničkog računa

2. Unos dobivenih pristupnih podataka (servisni ključ i lozinku) u GeoMIR*Desktop

Pristupni podaci moraju biti uneseni kako bi veza sa SDGE serverom mogla biti uspostavljena.

Naredbe sadržane u izborniku:

  • Kontrola kvalitete
  • Evaluiranje XLS datoteke - odabirom postojeće XLS datoteke dobivene kontrolom kvalitete, poziva se formular rezultata kontrole
  • Pristupni podaci servisu


Kontrola kvalitete

GeoMIR5 CAD modul ›› Izbornik "SDGE servis" ››

Preduvjet za izvršenje naredbe kontrole kvalitete crteža je stvaranje i unos pristupnih podataka . Za prikaz rezultata kontrole mora biti instaliran Microsoft Excel. Naredba radi po principu:

Jedan otvoren crtež - jedna naredba - rezultat kontrole vizualiziran u isti crtež

Ovom naredbom koriste se službeni alati Državne geodetske uprave, putem sustava DGE, za kontrolu kvalitete DXF datoteke. Za usporedbu:

Klasičan pristup kontroli kvalitete:

  1. Izvoz crteža u DXF
  2. Logiranje u sustav SDGE
  3. Pokretanje formulara za kontrolu kvalitete
  4. Unos podataka uz odabir katastarske općine iz tri padajuća izbornika
  5. Odabir DXF datoteke
  6. Pokretanje kontrole i informacija o rezultatu
  7. Preuzimanje i pohranjivanje ZIP datoteke sa rezultatima kontrole
  8. Procesuiranje rezultata kontrole - XLS datoteka sa informacijama te DXF datoteke sa vizualiziranim upozorenjima i greškama. Upravo ovaj dio je zna potrajati jer zahtjeva studiranje XLS datoteke te eventualno učitavanje DXF datoteka u svrhu vizualiziranja rezultata kontrole.

Sve prethodno navedene radnje svedene u u jednu naredbu GeoMIR*Desktop softvera.

Tijekom izvršenja naredbe za kontrolu kvalitete, softver GeoMIR*Desktop komunicira sa SDGE servisom i razmjenjuje podatke i datoteke. U tu svrhu stvara se mapa (direktorij) unutar mape aktivnog crteža, naziva u formatu "KK_ggggMMdd-ssMMss" (GodinaMjesecDan-SatMinuteSekunde, primjerice "KK_20190814-143329"). Svako pozivanje kontrole kvalitete stvara svoju mapu, kako bi tijek kontrole bio transparentan. Mapa se koristi za pakiranje DXF datoteke te za preuzimanje ZIP datoteke rezultata kontrole.

Pokretanjem naredbe otvara se formular za unos parametara kontrole . Formular izgledom u potpunosti odgovara formularu iz SDGE sučelja. Nakon potvrde pokretanja kontrole, stvara se online veza za SDGE servisom i razmjenjuju se podaci.

Mogući odgovori SDGE servisa:

  • Pogreška pri pristupu SDGE servisu: veza sa SDGE servisom nije uspostavljena, provjeriti pristupne podatke. Softver prekida izvršenje naredbe.
  • Nije utvrđeno ili Provjera prekinuta: rezultat kontrole nije dostupan, problem je u servisu SDGE. Softver prekida izvršenje naredbe.
  • Ispravno, Ispravno s upozorenjima ili Neispravno: rezultat kontrole je dostupan i softver nastavlja njihovim prikazom.

Ukoliko je rezultat kontrole dostupan, softver nudi mogućnost prikaza rezultata kontrole pregledno u tablici. U ovom trenutku korisnik može prekinuti naredbu ako ne želi prikaz rezultata kontrole.

Ponekad se odgovor servisa ne poklapa sa podacima iz XLS datoteke, stoga se savjetuje nastavak izvršenja, bez obzira na odgovor.

U nastavku izvršenja, softver preuzima ZIP datoteku sa rezultatima kontrole i oslanja se na priloženu XLS datoteku (za prikaz rezultata kontrole mora biti instaliran Microsoft Excel). Naposljetku se otvara formular koji prikazuje rezultate kontrole pregledno u tablici te pruža mogućnost vizualiziranja grešaka i/ili upozorenja direktno u trenutni crtež.

Iz opisanog se jasno vidi koliko je ovaj način kontrole kvalitete crteža jednostavniji i brži, bez gubljenja na kvaliteti.


Formular parametara kontrole

GeoMIR5 CAD modul ›› Izbornik "SDGE servis" ›› Kontrola kvalitete ››

Formular za određivanje parametara kontrole kvalitete izgledom i funkcionalnošću sliči formularu sa SDGE portala.

Katastarska općina: ukoliko je trenutni crtež nastao učitavanjem GML-a softverom GeoMIR*Desktop, ovaj podatak će biti ispunjen i neće biti potrebno mijenjati ili unositi podatke. U svim drugim slučajevima, potrebno je unijeti Matični broj katastarske općine. No, kako često isti nije poznat, pomoć pruža dohvat podataka o katastarskim općinama sa sustava DGE. Konkretno, U polje treba unijeti najmanje tri slova tražene katastarske općine (primjerice SLAVO) te pritisnuti na tipku "> pretraga". Rezultat pretrage će biti upisan u listu dostupnu pritiskom na strelicu dolje, treba samo još odabrati ispravnu.

Naziv kontrole: softver unosi tekst kakav je u primjeru, no isti može biti proizvoljno promijenjen

DXF datoteka:

  • Stvoriti DXF datoteku iz crteža - samo vidljivi elementi: automatski se stvara DXF datoteka samo iz vidljivih elemenata (uključeni slojevi) crteža iz MODEL-Space (bez layouta), i šalje na kontrolu
  • Stvoriti DXF datoteku iz crteža - svi elementi: automatski se stvara DXF datoteka iz svih elemenata iz MODEL-Space crteža (bez layouta), i šalje na kontrolu
  • Odabrati DXF datoteku - u slučaju da niti jedna od dvije prethodne varijante ne odgovara, korisnik može unaprijed prirediti DXF datoteku koju treba provjeriti. Nakon pritiska na tipku OK i pokretanja provjere, potrebno je odabrati DXF datoteku.

Pritisak na tipku OK pokreće provjeru.

Svi ostali parametri kontrole u potpunosti odgovaraju onima sa SDGE portala.


Formular rezultata kontrole

GeoMIR5 CAD modul ›› Izbornik "SDGE servis" ›› Kontrola kvalitete ››

Rezultat provedene kontrole kvalitete je ZIP datoteka, koja sadrži DXF datoteke sa pogreškama i XLS datoteku sa detaljnim informacijama. Upravo podaci iz XLS datoteke preuzimaju se u ovaj formular.

Status kontrole u prikazanom formularu preuzima se iz XLS datoteke. Savjetuje se uvijek provjeriti ovaj podatak jer se ponekad razlikuje iz odgovora servisa prije prikazivanja ovog formulara.

U sljedeća dva retka su navedene količine grešaka i upozorenja. Podatak "grafika" prikazuje koliko njih ima grafičku poziciju u crtežu i mogu biti vizualizirani TEXT elementom.

Upozorenja i Greške bez grafičkog prikaza prikazuju se u popisu - greške se označavaju crvenom a upozorenja plavom bojom.

Tipka "Prikazivanje XLS datoteke rezultata kontrole" poziva Excel i otvara XLS datoteku sa detaljnim informacijama.

Padajućim izbornikom određuje se način vizualizacije grešaka i upozorenja, izbor se mora potvrditi pritiskom na tipku "OK":

  • Preskočiti vizualizaciju
  • Vizualizirati samo greške
  • Vizualizirati sve

Pritiskom na tipku "Prekid" preskače se vizualizacija grešaka i upozorenja.


Stvaranje servisnog korisničkog računa

GeoMIR5 CAD modul ›› Izbornik "SDGE servis" ››

Ova uputa za stvaranje servisnog računa preuzeta je iz publikacije "SDGE REST aplikacija" koju je objavila Državna geodetska uprava.

Za pristup korištenju SDGE-u potrebno je za postojećeg korisnika kreirati autentikacijski ključ i lozinku koja se koristi za prijavu na servise.

Klikom na logiranog korisnika dolazi se do sučelja gdje se upisuju podaci za servisni pristup.

Korisnik generira jedinstveni ključ i upisuje proizvoljnu lozinku (može biti jednaka kao i ona za login u sustav).

Pritiskom na tipku "UPIŠI", podaci se pohranjuju u sustav DGE. Sada je potrebno te iste podatke upisati u GeoMIR*Desktop u formularu Unos pristupnih podataka.


Unos pristupnih podataka

GeoMIR5 CAD modul ›› Izbornik "SDGE servis" ››

Pristupni podaci SDGE servisu, dobiveni stvaranjem servisnog računa unutar SDGE aplikacije, potrebno je unijeti i pohraniti u GeoMIR*Desktop kako bi se osigurao pristup servisima SDGE REST aplikacije.

Potrebno je unijeti Servisni ključ te lozinku dva puta, kako ne bi došlo do pogreške.

Nakon unosa pristupnih podataka, potrebno je pokrenuti provjeru pristupa istoimenom tipkom.

Nakon uspješno provedene provjere, omogućava se pristup tipci OK, kojom se pohranjuju pristupni podaci. Softver GeoMIR*Desktop pohranja pristupne podatke lokalno na računalo. Lozinka se pohranja u šifriranom obliku i može biti dešifrirana samo iz GeoMIR*Desktop softvera.

Moguće pogreške pristupu SDGE servisu:

  • Pogrešno uneseni pristupni podaci - servisni ključ i lozinka
  • Internet nije dostupan
  • Strogo podešen firewall ili anti-virusni sustav. CAD softver bi trebao imati pristup internetu.
  • Pogreška u SDGE sustavu


Izbornik "Prijavni list"

GeoMIR5 CAD modul ››

Za izradu prijavnog lista i iskaza površina napravljen se skup naredbi, koje čine cjelinu.

Osnova sustava naredbi je takozvana „prijava“, koja je, pojednostavljeno rečeno, poveznica između novog i starog stanja. Za svaku „prijavu“ pojedinačno se zatvara površina, a u crtežu može biti više „prijava“.

Preduvjet za izradu prijavnog lista je učitavanje GML-a.

Podaci za staro stanje preuzimaju se iz knjižnih GML podataka, koji se učitavaju istovremeno sa grafičkim podacima DKP-a iz GML-a.

Novi podaci se određuju stvaranjem HATCH elemenata crteža, za sve dijelove čestica, uključujući zgrade. Nakon što su stvoreni, pridodaju im se knjižni podaci direktnim unosom. HATCH elementi

novog stanja koriste se u dvije svrhe – za vizualiziranje i izračun površine novog stanja, te izdvajanjem vrhova i povezivanjem sa informacijama o detaljnim točkama (bilo postojećim iz DKP-a, bilo novo izmjerenima), za popis rubnih točaka pri iskazu površina.

Redoslijed naredbi za izradu prijavnog lista:

1. Stvaranje nove prijave odabirom čestica starog stanja

2. Stvaranje HATCH elemenata direktnom CAD naredbom. Obratiti pažnju na uključene slojeve!

3. Dodjeljivanje knjižnih podataka novom stanju

4. Ako ima više „prijava“, ponoviti od 1 do 3 za sve „prijave“, nakon toga dalje na 5

5. Nadorada prijava – nadopuna ili raspodjela površina na staro stanje

6. Ispis prijavnog lista povezivanjem sa Excel sofverom

Radnja/Naredba | Odabire se | Unosi se | Preuzima se iz GML-a
Nova prijava | Broj postojeće KČ (block „kc“ ili MTEXT) | Opis, služi kao indeks za sortiranje | Podaci o vlasništvu, atributnoj površini, dijelovima čestica
Novo stanje za prijavu | HATCH elemenat novog stanja | Knjižni podaci novog stanja | -
Nadorada prijava | - | Naknadna obrada prijava, utjecanje na površine novog stanja nadopunom ili raspodjelom | -
Ispis u Excel | - | - | -
Slojevi za HATCH | Uključivanje i isključivanje slojeva koji bi mogli ometati ispravnu izradu HATCH elemenata | - | -

Moguće je stvaranje prijavnog lista samo sa starim stanjem.

Informacija o površinama iz GML-a: GML sadrži, među ostalim knjižnim podacima, informacije o atributnim površinama čestica, dijelova čestica te građevina. Te informacije se nalaze u raznim datotekama jer se preuzimaju iz raznih tablica baze podataka OSS aplikacije. Za neke čestice, površina dijelova čestica se ne poklapa sa ukupnom površinom čestice!

Prilikom nadorade prijava, takvi slučajevi će biti posebno istaknuti – naime, površina čestice uvijek je ispravna.


Nova prijava

GeoMIR5 CAD modul ›› Izbornik "Prijavni list" ››

Nova "prijava" se stvara odabirom broja čestica starog stanja. To može biti „kc“ blok iz DKM-a ili MTEXT stvoren GeoMIR naredbom „Brojevi KČ kao MTEXT“. Nakon odabira jednog ili više brojeva čestica, otvara se formular za unos opisa "prijave".

Opis "prijave" je podatak prema kojem se, ako postoji više "prijava" u crtežu, sortiraju "prijave" za ispis u Excel. Sortiranje se vrši alfanumerički.

Softver automatski iz broja čestica starog stanja preuzme prvu i sam predloži broj. Pri tome se za broj čestice nadopuni nulama na pet polja te dopiše podbroj, koji se nadopuni nulama na tri polja. Tako će čestica 123/45 biti prikazana kao 00123045 a čestica 123 kao 00123000. No, to je samo preporuka softvera, ključ prijave može biti bilo koji podatak. Potrebno je obratiti pažnju na sortiranje – kako se radi o alfanumeričkom sortiranju, „2“ će biti ispred „12“, zato softver unosi nule.

Stvaranjem nove "prijave", ista će postati aktivna – što znači da će svi elementi novog stanja biti pripojeni isključivo toj "prijavi".

Moguće je stvaranje prijavnog lista samo sa starim stanjem.


Novo stanje za prijavu

GeoMIR5 CAD modul ›› Izbornik "Prijavni list" ››

Novo stanje za prijavu određuje se HATCH elementom.

Prije pokretanja ove naredbe, potrebno je stvoriti HATCH elemente klasičnom CAD naredbom za svaki dio novog stanja posebno – sve uporabe i zgrade. U svrhu što točnije izrade HATCH elemenata, napravljena je naredba „Slojevi za HATCH“, koja naizmjence uključuje i isključuje slojeve, koji bi mogli ometati ispravnu izradu HATCH elemenata. Naime, neka signatura ili block elemenat bi mogli negativno utjecali na stvaranje HATCH elemenata.

Redoslijed stvaranja te ispuna HATCH elemenata ne igraju ulogu. U pravilu, mogu se odmah napraviti HATCH elementi za sve elemente novog stanja, bez obzira kojoj „prijavi“ će pripadati.

Pokretanjem naredbe za novo stanje za prijavu, potrebno je odabrati jedan HATCH elemenat za koji će biti uneseni knjižni podaci. Pri tome treba voditi računa da se novo stanje uvijek unosi za aktivnu „prijavu“.

Potrebno je unijeti barem jedan podatak. Broj posjedovnog lista se preuzima od starog stanja i može biti odabran iz padajućeg menija i biti promijenjen.

Broj katastarske čestice, opisna adresa i posebni pravni režim se slobodno unose.

Uporaba se može odabrati iz padajućeg menija, gdje su odvojeni opis i šifra uporabe. Tekst može biti i slobodno unešen.

Mjerilo se može odabrati iz padajućeg menija ili unijeti. Ako je mjerilo "1", u iskazu površina se piše da su izvor mjerene koordinate.

Želi li se prikazati (vizualizirati u crtežu) broj čestice i način uporabe, potrebno je uključiti tu opciju.

Moguće je stvaranje prijavnog lista samo sa starim stanjem bez unosa novog stanja.


Nadorada prijave

GeoMIR5 CAD modul ›› Izbornik "Prijavni list" ››

Sadržaj svih prijava pregledno su dostupni u ovom formularu. Osim što se može provjeriti sadržaj svih prijava iz crteža, moguće je dodatno utjecati na izgled ispisa prijavnog lista.

Dvostrukim klikom na ključ prijave (ID) prijave u lijevom stupcu formulara, prikazati će se sadržaj odabrane prijave.

Staro stanje: prikazuju se čestice i djelovi čestica starog stanja. U pravilu, suma površina djelova čestica (stupac „P dio“) trebala bi biti ista sumi površina čestica (stupac „P čest“). No, kako te površine nisu uvijek usklađene, zna doći do razlike među njima. U tom slučaju, potrebno je preuzeti "Prijepis posjedovnog lista" sa stranice https://oss.uredjenazemlja.hr , te provjeriti podatke.

Novo stanje: prikazuju se podaci novog stanja. U pravilu, suma površina novog stanja morala bi odgovarati sumi površina starog stanja. U protivnom, površina novog stanja biti će prikazana crvenom bojom uz prikaz odstupanja u površini.

Postoje dva načina, kojima se može utjecati na ispis prijavnog lista:

  • Proširivanje novog stanja nadopunom na staro stanje: uključivanjem ove opcije, biti će stvoren dio novog stanja pod nazivom „Nadopuna“, površine koja se dobije razlikom suma površina starog stanja minus suma površina novog stanja.
  • Pri manjim odstupanjima, moguće je raspodjeliti odstupanje – to se vrši označavanjem kvačicom površina (stupac "Rasp") novog stanja, na koje se želi raspodijeliti odstupanje.


Ispis u Excel

GeoMIR5 CAD modul ›› Izbornik "Prijavni list" ››

Ovime se vrši ispis prijavnog lista i iskaza površina u Excel. Ispis nije moguć u neki alternativni office paket.

Ispisuju se tri datoteke:

  1. Prijavni list u A3 formatu sa dva WorkSheet-a: zaglavlje i unutarnja stranica (KAT)
  2. Prijavni list u A4 formatu sa tri WorkSheet-a: zaglavlje, novo stanje i staro stanje (KAT)
  3. Iskaz površina u A4 formatu sa dva WorkSheet-a: katastar i ZK

Ispis se oslanja na tri predloška, koji su sastavni dio instalacije softvera:

  • „prij_list_kt_g5_A3.xltx“ – predložak za prijavni list u formatu A3, oslonjen na formular izdan od strane DGU
  • „prij_list_kt_g5_A4.xltx“ – predložak za prijavni list u formatu A3, oslonjen na formular izdan od strane DGU
  • "iskaz_pov_g5_A4.xltx" – predložak za iskaz površina, oslonjen na formular izdan od strane DGU

Predložak je moguće promijeniti prema svome nahođenju, naredbom „ Alati/Predlošci Word i Excel “. No, treba voditi računa da se ne mijenjaju pozicije stupaca i redaka, jer će doći do pogreške u ispisu podataka. Modifikacije su moguće SAMO za područje Zaglavlja ili Fusnote.

Prije pokretanje naredbe, potrebno je osigurati da slojevi koji sadrže detaljne točke, bile one učitane iz GML-a ili novo stvorene DGU točke, budu uključeni. U protivnom, u iskazu površina neće biti podataka o rubnim točkama novog stanja.

Nakon stvaranja, datoteke se automatski pohranjuju istu mapu, gdje se nalazi crtež sa „prijavama“. Ime datoteke se automatski određuje, i izgleda ovako:

<naziv dwg-a>_<PLA3, PLA3 ili IP>_<vrijeme izrade – datum, sat, minute sekunde>.xls


Izbornik "Alati"

GeoMIR5 CAD modul ››

Alati predstavljaju praktične funkcije za lakše crtanje.

Uključivanje i isključivanje broja i nadmorskih visina mjerene točke vrši se promjenom interne informacije o vidljivosti atributa. Ako se atributi nalaze u zasebnom layeru, isti mora biti uključen.

  • Promjena smijera polilinije
  • Poliliniju na pregibu prekinuti: Odabir točke na poliliniji - na najbližem pregibu će polilinija biti prekinuta
  • Element na točci prekinuti: element crteža (Polilinija, linija, krivulja) biti će prekinuti na odabranom mjestu
  • Nitni križ prema elementu: odabirom elementa crteža, postavlja se smjer nitnog križa (crosshair). Izborom u prazno postavlja se na WCS
  • Spojiti elemente na poliliniju: elementi crteža spajaju se na odabranu poliliniju
  • Preračunavanje geometrije elem. na CM
  • Spojiti liniju na liniju u CM
  • Crtanje u CM (SMAP=0.1)

  • Zakretanje crteža u Layoutu

  • Zamjena blokova istima
  • Jedinice za skaliranje insertiranih elemenata - Metri, centimetri, milimetri...ActCAD nema taj parametar unutar UNITS naredbe

  • Pretvorba svih POLYLINE2D -> LwPOLYLINE
  • Pretvorba POLYLINE3D -> LwPOLYLINE
  • Pretvorba LwPOLYLINE -> POLYLINE3D
  • Pretvorba LwPOLYLINE -> LINE

  • Polylinija -> Linija + pika: pretvaranje odabranih Polylinija u Linije+Pike. Polazne polylinije se ne brišu već postaju nevidljive
  • Vidljivost: Polylinija ili Linija+pika: vidljivost vezanih objekata Polyinija ili Linja+Pika - ili Polilinije ili Linje+Pike

  • Front pojedinačno: Ispis fronta u crtež. Moguć je izbor linije, segmenta polilinije ili odabirom krajnjih točaka.
  • Front odabirom elemenata: polaganje frontova na sve segmente odabranih elemenata linije ili polylinije.
  • Koso odmjeranje: Ispis kosog odmjeranja u crtež odabirom krajnjih točaka.
  • Apscisno odmjeranje: određivanje apscisne linije početnom i završnom točkom te odabiranje točaka za odmjeravanje apscisom i ordinatom.

  • Detaljni listovi: prikaz detaljnih listova i opisa elementima LWPOLYLINE i TEXT
  • Okviri i opisi : izrada okvira i opisa
  • Decimetarska mreža: Unos križića decimetarske mreže za određeno područje.
  • Opis križića: Opis decimetarskog križića, unos pripadajućih koordinata.
  • Znak za sjever: Unos znak za sjever.

  • Signature - tip linije u simbole: ubacivanje popratnih simbola na linijske objekte kako bi signature bile vidljive na svim računalima.

  • Vidljivost slojeva - tematski: zamrzavanje i odmrzavanje slojeva tematski, prema unaprijed određenim parametrima
  • Promjene na atributima blokova
  • Raspoznavanje atributa
  • Predlošci Word i Excel: određivanje smještaja predložaka na računalu, pri korištenju promijenjenih predložaka


Zakretanje crteža u Layoutu

GeoMIR5 CAD modul ›› Izbornik "Alati" ››

Zakretanje crteža u Layoutu često je potrebno u svrhu što boljeg korištenja korisnog prostora pri štampanju. Ovim pristupom se ne mijenja pozicija i zakret modela, nego samo prikaz istoga u Layoutu. Naredna je prilagođena GeoMIR*Desktop Layoutima, jer osim što zakreće crtež, zakreće i znak sjevera.

Kut zakreta se računa unosom referentne točke zakreta crteža (1), unosom smjera trenutnog zakreta crteža (2) te unosom smjera novog zakreta crteža (3). Nakon zakreta crteža i smjera sjevera, Layout izgleda ovako:


Zamjena blokova istima

GeoMIR5 CAD modul ›› Izbornik "Alati" ››

Zamjena blokova istima je na neki način prerađena CAD naredba ATTREDEF. Nažalost, u ActCAD-u ista ne radi kako treba.

Naredba ne radi ništa drugo nego unosi iste blokove na isto mjesto. Na taj način dolaze do izražaja eventualne promjene u atributima blokova. Nakon pokretanja, pojavljuje se formular u kojem je moguće podesiti kako će atributi nakon ponovnog unosa biti prikazani:

Položaj atributa preuzeti iz definicije: ako je označeno, položaj atributa biti će preuzet iz definicije bloka. Ako je položaj atributa bio promijenjen, i atribut treba ostati na novom položaju, potrebno je maknuti kvačicu.

Visinu teksta atributa preuzeti iz definicije: ako je označeno, visina teksta atributa biti će preuzeta iz definicije bloka. Ako je visina teksta atributa bila promijenjena, i ta nova visina treba ostati sačuvana, potrebno je maknuti kvačicu.

Boju atributa preuzeti iz definicije: ako je označeno, boja atributa biti će preuzeta iz definicije bloka. Ako je boja atributa bila promijenjena, i ta nova boja treba ostati sačuvana, potrebno je maknuti kvačicu.

Sloj atributa preuzeti iz definicije: ako je označeno, sloj atributa biti će preuzet iz definicije bloka. Ako je sloj atributa bilo promijenjen, i atribut treba ostati u novom sloju, potrebno je maknuti kvačicu.


Okviri i opisi

GeoMIR5 CAD modul ›› Izbornik "Alati" ››

Naredba služi za izradu okvira unutar MODEL_SPACE područja crteža. Formular je intuitivan i pruža korisniku potpunu kontrolu ispisa podataka. Za sada se ispisuju samo tekstualni podaci.

Ako se u crtežu nalaze elementi učitani iz GML datoteka, softver popunjava podatke o katastarskoj općini te nudi odabir čestica. Kvačicama uz pojedini tekstualni odjeljak određuje se hoće li podatak biti ispisan ili ne.

Naslov: Ispisuje se gore po sredini okvira. Neki naslovi su predloženi, no moguće je definirati vlastite. Sljedeći redak se određuje znakom ";" (točka zarez).

Čestica: Ispisuje se lijevo gore. Odabir jedne od ponuđenih čestica ili unos.

Kat.općina: Ispisuje se lijevo gore. odabir jedne od ponuđenih općina ili unos.

Datum: Ispisuje se lijevo gore. Predlaže se trenutni datum, moguća je promjena

Format: Format okvira.

Gore lijevo 1: Ispisuje se lijevo gore.

Klasa/Ur.broj: Ispisuje se lijevo gore.

Gore lijevo 3: Ispisuje se lijevo gore.

Dolje lijevo: Ispisuje se lijevo dolje.

Gore desno: Ispisuje se desno gore.

Dolje desno: Ispisuje se desno dolje.

Dolje sredina: Ispisuje se dolje po sredini.


Promjene atributa unešenih blokova

GeoMIR5 CAD modul ›› Izbornik "Alati" ››

Ova naredba je predviđena za uređivanje atributa mjerenih točaka, njihovo prikazivanje te ispis vrijednosti kao tekst. Promjene se izvršavaju samo za mjerene točke, koje se pri pokretanju naredbe odaberu.

Atributi: potrebno je označiti za koje atribute će biti izvršene promjene, višestruk izbor je moguć.

Promjene: vrsta promjene koja će biti izvršena za označene atribute odabranih mjerenih točaka:

  • Vidljivost: promjena vidljivosti atributa - za vidljive atribute potrebno je uključiti kvačicu, za nevidljive isključiti
  • Visina teksta: promjena visine teksta atributa unosom nove vrijednosti
  • Boja: boja atributa odabirom boje, prema sloju, prema bloku ili naknadnim pozivanjem formulara za odabir boje

Stvoriti kopiju atributa kao TEXT nakon promjene: u pojedinim slučajevima su blokovi atributa nepraktični za prikaz, pogotovo kada je potrebno zakrenuti vrijednost rai boljeg prikaza na planu. U takvim slučajevima je TEXT element bolja varijanta. Ovom naredbom se stvara TEXT element istog sadržaja i na istoj poziciji kao atribut, u sloju iste boje kao sloj atributa.

Primjer: postaviti sve atribute mjerenih točaka nevidljivima te nadmorske visine prebaciti u TEXT radi daljnje obrade:

  1. Pokrenuti naredbu prvi puta: odjeljku Atributi označiti sve kvačice, u odjeljku Promjene odabrati Vidljivost s isključenom kvačicom
  2. Pritisnuti OK i odabrati mjerene točke iz crteža
  3. Pokrenuti naredbu drugi puta: odjeljku Atributi označiti Nadmorska visina, u odjeljku Promjene odabrati Vidljivost s isključenom kvačicom, te uključiti kvačicu na Stvoriti kopiju atributa kao TEXT nakon promjene
  4. Pritisnuti OK i odabrati mjerene točke iz crteža


Raspoznavanje atributa

GeoMIR5 CAD modul ›› Izbornik "Alati" ››

Određivanje atributa blokova za raspoznavanje broja točke, prve i druge nadmorske visine te najniže dozvoljene tj. važeće nadmorske visine. Ovdje odreženi parametri su globalni, znači vrijede za sve naredbe unutar CAD modula gdje je takvo raspoznavanje potrebno.

neke naredbe koje koriste raspoznavanje atributa:

Nova točka sa zaslona

Nove točke izborom grafičkih elemenata

Kopiranje točaka u G5 međuspremnik

Ispis točaka u datoteku

Dvije DT -> jedna DT s dvije visine

Ispis površine u GeoMIR5 međuspremnik

Stvaranje DGU točaka

Prikaz točaka vodova sa dvije visine

Vidljivost broja točke i nadmorskih visina


MS Office povezivanje

GeoMIR5 CAD modul ››

Izrada knjužnog djela elaborata vrši se povezivanjem sa MS Word i MS Excel aplikacijama u svrhu direktnog prebacivanja podataka.

Za izvršenje automatskog prebacivanja podataka na računalu moraju biti instalirane Microsoft Word i Microsoft Excel aplikacije. Automatizacija putem alternativnih office paketa nije moguća.

Svaka naredba automatizacije koristi određeni predložak - u ovisnosti o naredbi to su DOTX za MS Word i XLTX za Excel. Prilikom instalacije modula, instaliraju se i prazni predlošci oslonjeni na naputke Državne geodetske uprave.

Personalizacija predložaka, primjerice radi ubacivanja vlastitog zaglavlja:

  • Otvoriti originalni predložak, koji se nalazi unutar mape "dokumenti/geomir5"
  • Unijeti preinake SAMO u područje Zaglavlja ili Fusnote. Glavni dio dokumenta mora ostati nepromijenjen!
  • Pohraniti novi predložak, pod istim ili nekim drugim imenom.
  • Ako je predložak pohranjen pod drugim imenom, potrebno je iz izbornika "Alati" pokrenuti naredbu "Predlošci Word i Excel" te ih odrediti, formular je prikazan u nastavku teksta

Naredbe za Office automatizaciju dostupne iz Izbornika "DGE Knjižno" :

  • Posjedovni list za čestice
  • Izrada prijavnog lista i iskaza površina
  • Identifikacije ZK čestica odabirom DKP čestica

Naredbe za Office automatizaciju dostupne posredno iz neke druge naredbe:

  • Ispis DGU točaka u datoteke

Formular za određivanje predložaka, dostupan iz izbornika "Alati/Predlošci Word i Excel":

Pritiskom na strelicu desno od imena datoteke, moguće je odrediti predložak.


Digitalni katastarski elaborat

GeoMIR5 CAD modul ››

01. rujna 2018 pušten je u rad Sustav digitalnih geodetskih elaborata.

Tehničke specifikacije koje određuju izradu Digitalnog geodetskog elaborata unose veliki stupanj standardizacije pri izradi elaborata, kojima će biti obavezno poštovanje sustava blokova i slojeva, te izgleda grafičkog dijela elaborata. Istovremeno, određuju jedan vrlo strog Digitalni topografski ključ koji u potpunosti mora biti poštivan. Elaborati, koji ne prođu online kontrolu kvalitete, odbijaju se u samom početku.

Novost je predložak crteža (drawing template) , koji se instalira i postavlja kao trenutni. Isti se oslanja na biblioteku simbola napravljenih od strane Državne geodetske uprave, a proširen je za sve potrebne slojeve i tipove linija.

Najveći dio naredbi unutar CAD modula već je bio pripremljen za taj način rada, samo su slojevi prilagođeni. Neke od naredbi razvijene su samo u svrhu izrade Digitalnog geodetskog elaborata.

DKP-GML / G5 sDGE - provjera sadržaja - naredba je još u razvoju a cilj je postići naredbu koja bi bila interna verzija kontrole kvalitete. U ovom trenutku se vrše sljedeće radnje:

  • provjera koordinata linija i blokova, kako bi se pronašle iste koje nisu na CM točnosti, nego točnije. Istina, to se ispravlja ispisom DXF-a na dvije decimale, ali tada može doći do razlike u površinama.
  • zamrzavaju se GeoMIR konstrukcijski slojevi, poput HATCH-eva prijavnog lista te polaznih mjerenih točaka. Tako, zamrznuti ne ispisuju se u DXF.

DKP-GML / sDGE - ispis u DXF - ispis vidljivih slojeva u DXF za SDGE. Nije potrebna nikakva interakcija, točnost se automatski podešava na dvije decimale i ispisuje se datoteka u istu mapu u kojoj se nalazi crtež.

Alati / Preračunavanje geometrije elem. na CM - naredba odobrava odabir LINE, LWPOLYLINE i BLOCK-INSERT elemenata crteža i zaokružuje njihovu geometriju na CM

Alati / Crtanje u CM (SMAP=0.1) - sustav DGE ne prihvaća podatke ispod CM točnosti. Kako je već napomenuto, to se može riješiti ispisom u DXF, no u tom slučaju može doći do razlike u površinama. Najbolje je ucrtavati sve nove podatke CM točnošću. Ova naredba uključuje SNAP na 0.01.

Alati / Spojiti liniju na liniju u CM - vezano uz CM točnost, poseban slučaj je kada se postojeća granica čestice dijeli. U tom slučaju nastaje nova točka na liniji, no ona tada dobiva matematičke koordinate, koje su točnije od CM. Ovom naredbom se odabire polazna linija te nova linija koja staru dodiruje - rezultat su tri nove linije, dvije predstavljaju staru liniju i jedna novu, s timeda su sve rubne koordinate linija na CM.


Dodaci

Copyright © 1998-2021 - geomir.software, vl. Miroslav Mareković. Sva prava pridržana.


Dodatak A - za lakši početak

Dodaci ››

Instalacija GeoMIR5,Za lakši početak namjenjena je svim novim korisnicima programa GeoMIR5, kako bi lakše i brže savladali rad s programom. To je instalacija odvojena od samog programa i preporuča se instalirati samo na računalo gdje GeoMIR5 još nije bio instaliran.

Preporuča se, nakon instalacije programa GeoMIR5, isti NE pokrenuti nego izvršiti instalaciju GeoMIR5 Za lakši početak.

Instalacija GeoMIR5 Za lakši početak ažurira GeoMIR5 kako bi instalirani podaci bili odmah dostupni.

Sadržaj instalacije:

•nekoliko demo predmeta

•dvije teme kodiranja s odgovarajućim predlošcima

Dvije teme kodiranja, HR_TK i HR_TK2. Razlika je u prikazivanju nekih linijskih objekata, primjerice zidova.

U temi kodiranja HR_TK prikazani su polilinijom i popratnim blokovima koji predstavljaju topografsku oznaku.

U temi kodiranja HR_TK2 prikazani su određenim tipom polilinije, tako da je topografska oznaka vezana uz poliliniju i nema više potrebe za popratnim blokovima.

•dva korisnička formata

1. Poligoni - za učitavanje/ispis točaka geodetske osnove

2. Detaljne - za učitavanje/ispis detaljnih točaka


Dodatak B - radionica moj prvi predmet

Dodaci ››

Cilj ove radionice je savladavanje početnih teškoća i nejasnoća u radu s programom GeoMIR5. Biti će prikazan cijelokupan tijek obrade predmeta od učitavanja podataka mjerenja do ispisa rezultata računanja. Teme:

•stvaranje novog predmeta

•podešavanje svojstava predmeta

•učitavanje mjerenih podataka

•obrada mjerenih podataka

•pretvaranje tahimetrije u giruse ( jedan girus )

•unos polaznih koordinata točaka geodetske osnove

•računanje točaka geodetske osnove

•računanje detaljnih točaka

•ispis rezultata u izvještaje i datoteke

Preduvjet za ispravno praćenje radionice je instalacija datoteka za lakši početak, koje su sastavni dio pune instalacije programa.

Radionica će obuhvatiti tijek navedenih radnji, detaljno pojašnjenje pojedinih radnji biti će dostupno kraticama .

Datoteke Podaci_radionica.gts te poligoni.TXT dostupne na službenoj internet stranici unutar datoteke Dodaci_primjeri.


Priprema

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Za početak, napravit ćemo jednu mapu na disku koja će nam predstavljati radnu mapu. To je mapa u koju ćemo staviti podatke mjerenja, koordinate te na kraju u nju ispisati rezultate računanja. Dobra je navika imati mapu za svaki predmet posebno a način organizacije prepušten je korisniku.

U ovoj radionoci će ta mapa biti jednostavno nazivana {mapapredmeta}.

U tu mapu postaviti datoteke Podaci_radionica.gts te poligoni.txt ( dostupne na internet stranicama geomir.org unutar datoteke Dodaci_primjeri).

Pokrenuti GeoMIR5 te dvostruko kliknuti na bilo koji ponuđen predmet čime će isti biti postavljen kao radni.


Stvaranje novog predmeta

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Za stvaranje novog predmeta potrebno je prvo pozvati formular za rad s predmetima , i to na jedan od načina:

- pritiskom na prvu ikonu s lijeva

- izborom Datoteka/predmeti s glavnog izbornika

- desni klik na praznu površinu te izbor Predmeti

U ovom formuaru za rad s predmetima moguće je stvarati, brisati, preimenovati predmete te grupe predmeta.

Svaki predmet mora pripadati jednoj grupi predmeta. Rezervirana je grupa pod nazivom STANDARD, koju nije moguće brisati.

Za naše svrhe stvori ćemo novu grupu predmeta: prvo označiti bilo koju postojeću grupu predmeta, desni klik, izabrati dodati grupu, upisati Radionice te potvrditi pritiskom na OK. U popisu predmeta je vidljiva grupa Radionice.

Sada je potrebno stvoriti novi predmet: označiti grupu Radionice, desni klik, izabrati dodati predmet.

Tako se otvara formular za stvaranje novog predmeta . U ponuđenim poljima upisati sljedeće:

Naziv za novi predmet: | moj prvi predmet
Kratak naziv ili Poslovni broj: | 201406
Predložak predmeta: | ostaviti .Standard
Koordinatni sustav: | izabrati HTRS96/TM
Tema kod.: | izabrati HR_TK2
Radna mapa: | dvostruki klik na bijelo polje otvara formular za izbor mape, izabrati onu koju smo prethodno stvorili {mapapredmeta}.

Potvrditi podatke pritiskom na OK. Ovako stvoren, predmet još uvijek nije postavljen kao radni. Izbor radnog predmeta postiže se dvostrukim klikom na naziv predmeta iz popisa.


Podešavanje svojstava predmeta

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

GeoMIR5 je opširan geodetski softver, razvijen za najpreciznije radove pa sve do jednostavnih tahimetrijskih snimaka. U svrhu bolje kontrole ulaznih i izlaznih podataka te same kontrole tijeka računanja, postoji veliki broj svojstava i parametara.

Sva svojstva predmeta su dostupna na jednom mjestu, izbornikom Promjene/Svojstva predmeta. Najtoplije preporučamo svim korisnicima, dobro proučiti što se u svojstvima može podesiti.

U našem slučaju, podesit ćemo dva najvažnija svojstva koja direktno utječu na računanje. Ova radionica sadrži podatke u HDKS te že i svojstva shodno tome biti

Znači, otvoriti formular Svojstva predmeta, podesiti veličinu jer je u startu uvijek malo premali, izabrati poglavlje Jedinice, pod kutne jedinice izabrati Stup. sexag.

Drugo vrlo važno svojstvo su korekcije mjerene duljine, i to u najvećoj mjeri korekcija na nivo plohu mora te korekcija radi konvergencije meridijana. Naime, shodno koordinatnoj projekciji, mjerena duljina mora biti projicirana na nivo plohu mora a u račun korekcije ulaze nadmorska visina terena i udaljenost od dodirnog meridijana. Te dvije korekcije utjeću jedna na drugu i ne bi smjela biti jedna korištena ako druga nije korištena. Primjerice, korekcija duljine mjerene na 600mnm biti će potpuno drugačija ako je dodirni meridijan 1km ili 15 km udaljen.

Korisnik ima mogučnost utjecanja ja računanje korekcije na tri načina:

• ne vršiti

korekcije neće biti računate. Koristiti samo ako je mjerni instrument podešen da sam radi korekcije.

• lokalni sustav

korekcije će se vršiti prema vrijednostima navedenim pod srednja nadmorska visina i udaljenost od meridijana.

• državni sustav

korekcije će se vršiti prema vrijednostima koordinata i visina točaka koje se trenutno računaju. Preduvjet je da su koordinate unesene u skladu s koordinatnim sustavom. Obavezo podesiti za koordinatni sustav HTRS96/TM.

Vrijednosti je moguće podesiti unutar Promjene / svojstva predmeta, odjeljak redukcije.

Ovako podešena svojstva predmeta želimo zadržati za sve nove predmete koje ćemo ubuduće stvarati - iz glavnog izbornika potrebno je izabrati Alati/Svojstva - lokalna -> ishodišna te potvrditi pritiskom na OK.


Učitavanje mjerenih podataka

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Učitavanje mjerenih podataka vrši se učitavanjem datoteke koja je dobivena prebacivanjem podataka s mjernog instrumenta na računalo. GeoMIR5 ne učitava podatke direktno s instrumenata !!

Svako proizvođač instrumenata ima i svoj format zapisa mjerenih podataka koji se često vrlo brzo mijenjaju. Ako niste sigurni koji format ima vaš instrument ili je li uopće podržan, kontaktirajte nas bez premišljanja. U slučaju da vaša stanica nije podržana, nadogradit čemo filter za učitavanje podataka mjerenja u roku od par dana - naravno besplatno.

U našem slučaju radi se o Topcon GST600 formatu. Učitavanje se vrši formularom za učitavanje podataka mjerenja dostupnim:

- pritiskom na drugu ikon s lijeva

- izborom Datoteka/Učitavanje podataka instrumenta s glavnog izbornika

U gornjem dijelu izbornika vršimo izbor formata podataka, u našem slučaju TOPCON GTS-600. Ispod toga je tipka nazvana Pretraživanje, koja poziva standardni formular za izbor datoteke. Ako je mapa predmeta točno unešena, formular za izbor datoteke trebao bi biti već postavljen u mapi gdje se nalazi tražena datoteka, u našem slučaju Podaci_radionica.gts. Moguće je izabrati više od jedne datoteke - potrebno je držati tipku CTRL pritisnutu pri izboru. Pažnju treba obratiti na redosljed - posljednje odabrana datoteka biti će prikazana prva na popisu datoteka nakon izbora. Nakon potvrde izbora, izabrane datoteke biti će prikazane u žutom polju redosljedom učitavanja. Tek sada, izborom tipke OK, datoteke će biti učitane u GeoMIR5.

Tijekom učitavanja, može se pojaviti ovaj formular:

Ako se označi kvačica Prenumeracija DT pri učitavanju, nove detaljne točke biti će prenumerirane, počevši od najveće detaljne točke iz baze podataka.

Može se desiti da GeoMIR5 dojavi pogrešku u kutnim jedinicama. Potrebno je obratiti pažnju o svojstvima predmeta.

U popisu stajališta su dopisana učitana stajališta, označena slovom T ( tahimetrija ).

Podaci mjerenja učitavaju se nastavno na postojeće podatke u bazi podataka.


Obrada mjerenih podataka

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

U ovom trenutku su podaci mjerenja učitani u GeoMIR5 i više nema razlike s kojeg mjernog instrumenta podaci dolaze.

Od samog početka je GeoMIR5 postavljen na čvrste temelje. Svaki predmet predstavlja jednu zasebnu bazu podataka. Na taj način je otvoren put i velikim predmetima od desetak tisuća detaljnih točaka i nekoliko tisuća točaka geodetske osnove - gornja granica ne postoji. I pri najvećim predmetima nema vidljivog gubitka brzine rada programa.

Osim velikog broja podataka, prednost baze podataka je mogućnost promjene učitanih vrijednosti, poglavito brojeva točaka ili kodova jer pri radu na terenu dolazi do pogrešaka. Mijenjanje podataka vrlo je slično radu s tabličnim kalkulacijama.

Za promjene podataka stajališta ( poput oznake stajališta ili visine instrumenta ), na popisu stajališta desni klik na željeno stajalište, izbornik Promjene ili peta ikona slijeva s formulara popisa stajališta.

Za promjene podataka mjerenja sa željenog stajališta potrebno je dvostruko kliknuti na željeno stajalište. Otvorit će se formular sličan tabličnim kalkulacijama gdje je moguće mijenjati sve podatke.

U našem slučaju, dvostruko kliknuti na stajalište P1 ( drugo odozgo ). Mjereni podaci koji imaju kod 00 ( dvostruka nula ) predstavljaju orijentacije na točke geodetske osnove ( ukratko ORI ) a svi ostali su detaljne točke.

Znamo da je jedan unos broja orijentacije bio pogrešan, i to onaj četvrti odozgo, gdje umjesto oznake P3 treba biti P2. Postaviti se na željeno polje, promijeniti vrijednost te prelaskom u neki drugi redak potrditi promjenu. Podatak je trenutno ažururan - iz toga proizlazi da nije potrebno razmišljati o nekakvom "save file" ili "save project". GeoMIR5 to radi sam po sebi.


Pretvaranje tahimetrije u giruse ( jedan girus )

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Računanje vlakova vrši se preuzimanjem mjerenih podataka te računanje veznih i prijelomnih kuteva te duljina. Podaci mogu, u ovisnosti od načina mjerenja, biti preuzeti iz girusnih podataka ili tahimetrije.

Vlakovi iz tahimetrije su vlakovi snimani u polugirusu a orijentacije su opažane u istom radnom procesu kada i detaljne točke. Kako je spomenuto, mjerenja na točke geodetske osnove ( orijentacije, skračeno ORI ) ounačena su unutar tahimetrije s kodom "00".

Za girusna mjerenja postoji posebna tablica koja omogučava izjednačenje jednog ili više girusa. Girusni podaci su potpuno odvojeni od tahimetrije a filter za njihovo učitavanje postoji samo za LEICA instrumente.

No, "međunačin" snimanja u jednom girusu dostupan je iz tahimetrijskih podataka. Praksa je sljedeća - tijekom snimanja detalja dovoljno je u dva položaja instrumenta snimiti orijentacije na točke geodetske osnove i to tako da u oba položaja točka ima isti broj. GeoMIR5 ima ugrađenu radnju koja iz takvih mjerenja prebacuje podatke u tablcu girusnih podataka, izjednačava jedan girus te izjednačene podatke vraća natrag u tahimetriju.

Podaci koje smo učitali snimani su upravo takvim načinom. Za izradu girusa, potrebno je označiti sva stajališta iz popisa, desni klik, izbornik Girusi iz tahimetrije te potvrditi.

Podaci su sada ponešto izmjenjeni:

- pojavila su se nova stajališta, označena slovom G ( girusi ). Dvostrukim klikom na neko od njih, otvara se formular za obradu girusnih podataka .

- u tahimetriji su originalna mjerenja dobila u stupcu kod oznaku "//" a nova izjednačena mjerenja, preuzeta iz girusnih podataka, sada imaju oznaku "00".

Nakon što su stvoreni iz tahimetrije, girusne podatke treba izračunati i to označavanjem istih iz popisa stajališta ( Oznaka "G" u stupcu "+/-" ) te pritiskom na desnu tipku miša izabrati Računanje girusa.


Unos polaznih koordinata točaka geodetske osnove

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Osim podataka mjerenja, za računanje vlakova su potrebne početne i završne koordinate točaka geodetske osnove.

Tablica koordinata točaka razlikuje se od tablice mjerenih i girusnih podataka. Naime, unutar jednog predmeta ne mogu postajati dvije točke s istim brojem jer su koordinate indeksirane brojem točke. To vrijedi za točke geodetske osnove i za detaljne točke.

U našem slučaju, potrebne točke geodetske osnove imamo u nekakvom opčenitom obliku, gdje su vrijednosti upisane redosljedom Broj točke, Y,X,H. Učitavanje pokrenuti iz glavnog izbornika Datoteka/Učitavanje/Koordinate ili trećom ikonom s lijeva iz glavnog izbornika. Izabrati datoteku poligoni.txt te potvrditi izbor.

U otvorenom formularu za učitavanje koordinata točaka podesiti vrijednosti prema slici:

Pritiskom na OK, točke će biti učitane u bazu podataka.

Već je prije spomenuto kako je svaki predmet jedinstvena baza podataka. Iz toga proizlazi da točke geodetske osnove iz jednog predmeta nisu vidljive u nekom drugom predmetu. U svhu izbjegavanja ponavljanja podataka te olakšavanja smještaja točaka geodetske osnove, uvedene su Zajedničke točke geodetske osnove, koje su smještene u zasebnu bazu podataka, vidjlivu iz svih predmeta. Točke geodetske osnove, pohranjene unutar predmeta, nazivaju se Lokakne točke geodetske osnove.

Formular za obradu točaka geodetske osnove dostupan je Ikonom 6 iz glavnog izbornika. Naslov formulara daje do znanja koja tablica se obrađuje - lokalne ili zajedničke točke geodetske osnove. Moguće je kopiranje točaka iz tablice u tablicu.

Osim ovdje opisanog, unos koordinata točaka geodetske osnove moguć je na još nekoliko načina:

- direktnim unosom u formularu za obradu točaka geodetske osnove

- iz raznih predloženih formata datoteka

- iz datoteke vlastitog, korisničkog formata

- iz nekog drugog predmeta

- iz grafičkog sučelja G4CAD


Računanje točaka geodetske osnove

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Računanje vlakova unutar programa GeoMIR5 je drugačije od većine drugih softverskih rješenja i to po pitanju sintakse i redosljeda radnje:

1. - unos redolsljeda točaka u formular za računanje vlakova

2. - izbor vrste vlaka za računanje

3. - ako je računanje moguće, završna odluka o računanju

Kako bi tijek bio što bolje prikazan, simulirat ćemo neke pogreške. Skica vlaka izgleda ovako:

Točke T35C, PT16 i P4 su poznate po koordinatama, strelice označavaju opažane pravce. Iz skice proizlazi da se radi o vlaku priključenom po koordinatama sa još dva slijepa vlaka. U formular za računanje vlakova upisat ćemo ( namjerno pogrešno ) sljedeće:

te pritisnuti drugu tipku slijeva. GeoMIR5 odmah prijavljuje pogrešku - "Računanje ne može biti provedeno! Molim, provjerite LOG podatke". Sve detaljne informacije nalaze se u takozvnom LOG odjeljku, što je u stvari onaj žuti prostor u dnu glavnog sučelja. U našem slučaju radi se o sljedećem:

Racunanje :: Poligonski vlak prikljucen po koordinatama

** Upozorenje:Posljednja povratna vizura za stajalište < P4 > nije pronadena !

Racunanje :: Poligonski vlak prikljucen po koordinatama

** Stajalište < PT16 > , smjerni kut ne može biti izracunat. Potrebna ORI nije pronadena !

Redak započet kao "** Upozorenje" nije pogreška nago kako GeoMIR5 sam kaže, upozorenje. No, sljedeći redak sa zvjezdicama, "** Stajalište ..." objašnjava o čemu se radi. Ovdje se može raditi o dvije pogreške - ili smo nešto pogrešno upisali u formular za računanje vlakova ili je pogrešno uneseno u tahimetriji. U našem slučaju, znamo da se radi o pogrešnom unosu pa će sada biti ispravno upisano. Unijet ćemo jednostavno u prvi redak, umjesto oznake "T33c" znak "+" ( plus ). Na taj način dajemo nalog programu, pronaći sve moguće orijentacije iz mjerenih podataka te ih upotrijebiti u računanju. Nakon promjene pogrešnog podatka te ponovnog pritiska na drugu tipku slijeva, pojavit će se formular za detaljno podešavanje vlaka . U našem slučaju, rezultat je loš:

Pretpostavit ćemo da se radi o početnoj vizuri na pogrešnu točku. Nažalost, računanje vlaka priključenog po koordinatama neće biti moguće - jedini izlaz je računanje vlaka uklopljenog po koordinatama ( treća tipka slijeva ). To je poligonski vlak koji nema mjeren niti početni niti završni vezni kut, a početni smjerni kut računa se indirektno. Znači, potrebno je ovdje pritisnuti na Prekid, izbaciti znak plus iz formulara za računanje vlakova te pritisnuti treću tipku slijeva. Sada su rezultati dobri:

i mi ćemo prihvatiti rezultate računanja pritiskom na tipku OK. Ako je kvačica Pohraniti izvještaj(e) označena, izvještaj će biti pohranjen.

Ako izračunate točke već postoje u bazi podataka, prikazat će se formular u kojem je moguće odlučiti kako postupiti - prepisati točku ili istaviti staru vrijednost.

Još je potrebno izračunati slijepe točke S1 i S2. Unos u formular za računanje točke S1 biti će ovakav:

a za točku S2 ovakav:

+

P2

S2

a potrebno je pritisnuti četvrtu tipku slijeva. U formularu za detaljno podešavanje vlakova potrebno je tipkom OK potvrditi računanje.

U našem slučaju, početne točke PT16 i P4 imale su poznatu nadmorsku visinu pa je vlak istovremeno bio izjednačen i visinski. Kvačicom Računati visinski vlak unutar formulara za detaljno podešavanje vlaka uključujemo ili isključujemo istovremeno računanje visinskog vlaka.

Moguće je i odvojeno računanje visinskih vlakova, i to:

- peta tipka slijeva: obostrano prilkučen visinski vlak

- šesta tipka slijeva: slijepi visinski vlak

Način unosa u formular za računanje vlakova je istovjetan unosu pri računanju poligonskih vlakova ,samo bez početnih i završnih orijentacija.

Osim poligonskih vlakova, točke geodetske osnove moguće je sračunati na još nekoliko načina.

- Slobodno stajalište

- Presjek naprijed i natrag

- Automatsko računanje

- trigonometrijsko računanje visine


Računanje detaljnih točaka

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Nakon što su točke geodetske osnove izračunate, moguće je izračunati detaljne točke.

Kao i točke geodetske osnove, detaljne točke su indeksirane prema broju točke što znači da imati dvije detaljne točke s istim brojem nije moguće. Pri mjerenju velikog broja točaka treba imati to na umu jer pri računanju detaljnih točaka, ako točka s istim brojem već postoji, ne dojavljuje se već automatski upisuje nova vrijednost. Moguće je provjeriti ima li višestrukog numeriranja točaka u popisu stajališta .

U našem slučaju, izvršit ćemo prenumeraciju detaljnih točaka prije računanja. Potrebno je u popisu stajališta označiti sva tahimetrijska stajališta ( slovo T na kraju retka ), desni klik mišem, Prenumeracija DT. U otvorenom forularu za prenumeraciju detaljnih točaka potrebno je odabrati Osnovne vrijednosti: Početna vrijednost te u redak ispod upisati 1001. Na taj način biti će sve detaljne točke sa označenih stajališta prenumerirane, i to počevši s brojem 1001.

Može se krenuti s računanjem. Potrebno je u popisu stajališta označiti sva tahimetrijska stajališta ( slovo T na kraju retka ) te pritisnuti osmu ikonu s lijeva čime se otvara formular za interaktivno računanje detaljnih točaka .

Ovaj formular je vrlo pregledan i već na prvi pogled se da zaključiti što je što. U našem slučaju, obratit ćemo pažnju na prvo stajalište. Otvaranjem formulara, peti stupac je za prvo stajalište označen crvenom bojom što znaći da je najveće odudaranje orijetiranih smjerova veće od vrijednosti definirane svojstvima predmeta. Odudaranje je veliko, oko 45 stupnjeva i tu će biti potrebno utjecati na orijentacije sa stajališta. U tu svrhu potrebno je pritisnuti na oznaku ">" uz oznaku stajališta što će otvoriti pregled orijentacija sa stajališta. Prisjetimo se, vlak je priklučen po koordinatama kako bismo izbjegli početnu orijentaciju. Sada je potrebno istu orijentaciju izbaciti iz računa orijentiranog smjera , koji se kasnije koristi za računanje detaljnih točaka. Ispravljeni podaci trebali bi izgledati ovako:

Pristiskom na OK GeoMIR5 će izračunati detaljne točke te pohraniti orijentirane smijerove i izbor orijentacija za svako stajalište. Ako bismo krenuli u računanje drugi puta, GeoMIR5 pamti da smo točku T35C sa prvog stajališta izbacili iz računanja te bi ostala neoznačena.


Ispis rezultata u izvještaje i datoteke

Dodaci ›› Dodatak B - radionica moj prvi predmet ››


Zaključak

Dodaci ›› Dodatak B - radionica moj prvi predmet ››

Za kraj je potrebno napomenuti da je ova radionica stvarno samo uvod u rad s programom GeoMIR5, no on će Vas ohrabriti u daljnjem upoznavanju programa.

Kao nadodgradnju ovog uputstva koristite naš forum na kojem je registracija besplatna i anonimna i uvijek odgovaramo na pitanja u najkraćem roku.


Dodatak C - radionica ActCAD - DTM i profili

Dodaci ››

GeoMIR5 i ActCAD radionica: digitalni model reljefa, profili, slojnice, kubature

Radionica obuhvaća izradu:

Uzdužnog profila preko mjerenih točaka

Poprečnih profila

Digitalnog modela reljefa i slojnica

Računanje kubature

Svi ovdje navedeni primjeri oslanjaju se na sadržaj datoteke radionica_g5_actcad_dtm_profili_kubature.zip, koja je dostupna na službenim GeoMIR stranicama.


Uvod

Dodaci ›› Dodatak C - radionica ActCAD - DTM i profili ››

Navedeni zadaci, o kojima je ova radionica, predstavljaju pojednostavljeni prikaz stvarnog stanja terena. Iako bi idealan slučaj bio rad u tri dimenzije, iz praktičnih razloga, kojih je mnogo, geodetski planovi se crtaju u ravnini, a treća dimenzija se koristi prema potrebi.

GeoMIR5 raspoznaje navedene CAD elemente za daljnje korištenje i izrade navedenih zadataka:

Referentne visinske točke terena:

  • 3D elementi: 3DPOINT i 3DBLOCK-INSERTION
  • 2D element: BLOCK-INSERTION koji nosi informaciju o trećoj dimenziji u atributu – TAG oznaka atributa se definira od strane korisnika, predložene vrijednosti su H i VISINA

Linije prijeloma terena:

  • 3D elementi: 3DPOLYLINE i 3DLINE
  • 2D elementi: LWPOLYLINE i LINE čije prijelomne točke leže na jednoj od gore navedenih referentnih visinskih točaka terena.

Svaki formular za navedene radnje omogućava, osim definicije TAG oznake atributa bloka koji sadrži treću dimenziju, definiranje iz kojih layera se preuzimaju elementi, posebno za referentne točke i za linije prijeloma terena.

Primjer korišten u ovoj radionici je snimak stvarnog stanja, prikazan u 2D u starom topografskom ključu. Naziv datoteke je g5_dmr_radionica.dwg. Mjerene točke koje nose treću dimenziju predstavljene su blokom B0_1 a nadmorska visina se nalazi u atributu TAG oznake H.


Izrada uzdužnog profila

Dodaci ›› Dodatak C - radionica ActCAD - DTM i profili ››

Pokrenuti izbornik DMR / Uzdužni profil te odabrati polyliniju ( radionica – polylinija označena sa (1) ) koja predstavlja uzdužni profil. Početna, završna te barem još jedna točka moraju imati treću dimenziju. Nakon odabira polylinije, pojavljuje se formular za iscrtavanje uzdužnog profila:

S lijeve strane se nalazi okvir nazvan 2D -> 3D za presijecanje linija terena , u kojem je moguće odrediti u uvodu navedene parametre za prostorni prikaz crteža. Ovakav okvir se nalazi na svim formularima vezanim uz izradu DMR-a i profila:

Izdvajanje referentnih točaka:

  • Layeri koji sadrže referentne točke – navesti u kojim layerima se nalaze elementi crteža ( 3DPOINT, 3DBLOCK-INSERTION, BLOCK-INSERTION ).
  • TAG atributa bloka koji sadrži nadm. visinu – pojašnjeno u uvodu
  • Najniža dozvoljena nadm. visina: ako točka ima treću dimenziju manju od ovdje navedene, neće biti preuzeta kao referentna visinska točka.
  • Izdvajanje linija prijeloma terena: (nema utjecaja pri izradi uzdužnog profila )
  • Layeri koji sadrže linije prijeloma terena - navesti u kojim layerima se nalaze elementi crteža ( LWPOLYLINE, LINE, 3DPOLYLINE, 3DLINE ).

S desne strane su parametri izrade uzdužnog profila: horizontalno te vertikalno mjerilo te korak za izradu linije ravnine usporedbe (RU). Nula profila nema utjecaja pri izradi uzdužnog profila

Nakon što su parametri određeni, biti će stvoren novi crtež s uzdužnim profilom.


Izrada poprečnih profila

Dodaci ›› Dodatak C - radionica ActCAD - DTM i profili ››

Poprečni profili se izrađuju u nekoliko koraka, ovisno o potrebi korisnika. Potrebno je definirati barem jednu os poprečnih profila, koja će biti nosilac svih potrebnih informacija. Izrada poprečnih profila bez definicije osi nije moguća.

Općenito, postoje dva načina izrade poprečnih profila: poprečni profili na kojima je svaka točka direktno mjerena te poprečni profili koji se dobivaju presjekom mjerenih linija loma terena. GeoMIR podržava oba načina te ih po potrebi objedinjuje u jednu cjelinu.

U ovoj radionici će biti izrađeni profili koji presijecaju linije loma terena progušćeni s dva direktno mjerena profila te jednim proizvoljno odabranim profilom izborom točke na osi.

Stacioniranje osi:

Pokrenuti DMR / Stacioniranje polylinije kao osi pop. profila, te odabrati polyliniju označenu za (1). Potrebno je unijeti korak među poprečnim profilima ( radionica – unijeti 15 ) te širinu pojedinog popr. profila ( radionica – unijeti 50 ). Ovime će svakih 15 metara biti stvoren jedan poprečni profil.

Progušćenje:

U praksi je ponekad potrebno progustiti profile na mjestima koja su posebno interesantna za prikaz. U tu svrhu potrebno je pokrenuti DMR / Ubacivanje pop. Profila na os te odabrati točku na osi gdje je potrebno progušćenje ( radionica – zgodno mjesto je između stacionaža 165 i 180 ).

Ako su na posebno markantnim mjestima profili direktno mjereni, moguće ih je ubaciti u prikaz. Pokrenuti DMR / Izbor polylinije kao mjereni pop. Profil te odabrati mjerene profile, koji mogu biti prikazani elementima LWPOLYLINE ili 3DPOLYLINE. Raspoznavanje treće dimenzije je prema objašnjenju iz uvoda ( radionica – polylinije označene sa (3) i (4) ).

Svi profili kao direktno mjereni:

Ako su svi profili direktno mjereni i nema potrebe za stacioniranjem osi, potrebno je nacrtati os LWPOLYLINE elementom te radnjom DMR / Definiranje polylinije kao osi pop. profila odabrati os. Mjereni poprečni profili moraju presijecati os.

Iscrtavanje poprečnih profila:

Svi poprečni profili vezani uz odabranu os biti će u jednom koraku iscrtani. Pokretanjem radnje DMR / Iscrtavanje poprečnih profila otvara se formular za iscrtavanje poprečnih profila:

Formular je jednak formularu za izradu uzdužnog profila, samo što sada svi podaci imaju utjecaja. Kao nulu poprečnih profila najbolje je odabrati os profila.

Nakon što su parametri određeni, biti će stvoren jedan novi crtež s svim poprečnim profilima. U polaznom crtežu će biti prikazane neke pogreške, zgodne za shvaćanje rada programa. Zatvoriti polazni crtež bez pohrane ili pohraniti pod nekim drugim nazivom.


Izrada digitalnog modela reljefa terena

Dodaci ›› Dodatak C - radionica ActCAD - DTM i profili ››

Izrada digitalnog modela reljefa terena

Digitalni reljef terena se uobičajeno prikazuje prostornim trokutima, takozvanom TIN mrežom. Jedini način izrade TIN mreže koji je u stanju vjerno prikazati teren je onaj koji izrađuje TIN iz referentnih točaka i linija prijeloma terena. GeoMIR5 koristi upravo taj matematički model. Naime, linije prijeloma terena sprječavaju izradu trokuta koji bi presijecali linije prijeloma terena čime bi došlo do deformacije modela u odnosu na stvarno stanje na terenu.

Prije same izrade modela, dobro bi bilo obrubiti crtež i stvoriti granicu kako bi bila spriječena izrada trokuta koji na terenu ne postoje.

Pokretanjem DMR / Granica te izborom polylinje definira se granica reljefa.

Pokretanjem DMR / Stvoriti novi otvara se formular za izradu reljefa:

Podaci za unos su objašnjeni u uvodu i u odjeljku o izradi uzdužnog profila. Nakon što su parametri određeni, digitalni model reljefa će biti stvoren i vizualiziran elementima 3DPOLYLINE u layeru g5_dmr.

Interpolacija slojnica

Pokretanjem DMR / Slojnice iz DMR-a otvara se formular za izradu slojnica u koji je potrebno unijeti vrijednost za ekvidistanciju ( radionica – unijeti 1 ). Interpolirane slojnice su prikazane elementima 3DPOLYLINE u layeru g5_slojnice, trenutno još bez zakrivljenja. Glavne slojnice su posebno označene.

Vidljivost digitalnog modela reljefa regulira se izbornikom DMR / Vidljivost ( radionica – slojnice postaviti na nevidljive, lakše je raspoznati slonice ).

Ubacivanje opisnog teksta za glavne slojnice se izvršava izbornikom DMR / Visina slojnice u Text ( radionica – ubaciti nekoliko tekstova po izboru ).

U ovom trenutku potrebno pregledati rezultat izrade slojnica i po potrebi promijeniti njihovo pružanje.

Za kraj je potrebno slojnice prebaciti u SPLINE elemente. PAŽNJA – ovaj korak može biti kritičan i potrajati duže vrijeme. Savjetuje se prethodno pohraniti crtež!


Izračunavanje kubatura iz DMR-a

Dodaci ›› Dodatak C - radionica ActCAD - DTM i profili ››

Izračunavanje kubatura iz DMR-a

GeoMIR5 računa kubature automatskom izradom velikog broja poprečnih profila koji presjecaju model reljefa. Za svaki od tih profila zamisli se linija koja spaja prvu i posljednju točku profila presjeka. Zbroj površina koje su ispod te linije predstavljaju iskop te zbroj površina iznad nje predstavljaju nasip. Aritmetička sredina tih površina pomnožena s razmakom između profila predstavljaju kubaturu. Postupak se provodi za sve profile a njihov razmak iznosi 1 cm. Primjerice, za model reljefa duljine 10 metara računa se 1000 profila. Moguće je neke od tako stvorenih profila, u svrhu dokumentiranja računanja, iscrtati kao profile izvještaja.

Pokretanjem DMR / Računanje kubatura uz jednog DMR-a otvara se formular za određivanje parametara računanja.

Računanje presjeka:

  • Automatski s juga prema sjeveru – zamišljeni profili presjeka se računaju automatski
  • Određivanje osi profila izvještaja – korisnik sam zadaje smjer osi za profile izvještaja

Izvještaji:

  • Bez izrade izvještaja – na kraju računanja se prikazuje samo rezultat
  • Izrada poprečnih profila – izrada poprečnih profila kao izvještaj

Parametri za profile izvještaja – osim mjerila i koraka razine usporedbe određuje se svakih koliko metara će biti stvoren poprečni profil izvještaja

Nakon što su parametri određeni, prelazi se na računanje.

Ako je za računanje presjeka izabrano određivanje osi profila izvještaja, korisnik mora odabrati dvije točke koje će predstavljati početnu i završnu točku zamišljene osi profila izvještaja.

Ako je odabrana izrada poprečnih profila kao izvještaja, u polaznom crtežu će biti označeni profili sa stacionažama te će biti stvoren jedan novi crtež sa svom poprečnim profilima – pri svakome će biti navedene njegove vrijednosti za iskop i nasip.

Za primjer:

pyramid_solid.dwg - datoteka sa 3D-Solid krnjom piramidom, korištena za kontrolu računanja kubature

pyramid_calc.dwg - datoteka s dva postojeća DMR-a, izvedenih iz 3D-Solid krnje piramide, idealno za isprobavanje računanja.

Računanje kubature bez granice područja računanja:

Otvoriti datoteku pyramid_calc.dwg te odmah pokrenuti računanje izbornikom DMR / Računanje kubatura .

Računanje kubature uz određenu granicu područja računanja:

Otvoriti datoteku pyramid_calc.dwg, izbornikom DMR / Granica odabrati crnu poliliniju. Nakon toga pokrenuti računanje izbornikom DMR / Računanje kubatura .

U oba slučaja odabrati Izrada poprečnih profila za izvještaje. Usporedbom dobivenih crteža s izvještajnim profilima, vidljiva je razlika pri računanju kubature sa i bez granice.


Dodatak D - prelazak GeoMIR4 -> GeoMIR5

Dodaci ››

Programi GeoMIR4 i GeoMIR5, iako slični, nisu kompatibilni jedan sa drugime te nije moguće direktno preuzimanje postojećih GeoMIR4 podataka u GeoMIR5.

Korisnicima GeoMIR4 programa preporučamo pri instalaciji programa GeoMIR5 ne instalirati datoeke za lakši početak, već izvršiti čistu instalaciju.

Prije pokretanja programa GeoMIR5, stvoriti mapu (direktorij) koja će biti određena kao mapa predmeta za GeoMIR5. Savjetuje se korištenje jednostavnih naziva i smještaja na disku, primjerice D:\g5_db ili slično. Nadalje, mapa mora imati privilegije za puni pristup (čitanje i pisanje).

Pokrenuti GeoMIR5 te iz izbornika Datoteka pokrenuti Određivanje mape predmeta i izabrati prethodno stvorenu mapu nakon čega će se pojaviti formular za stvaranje mape predmeta:

Odabrati Učitati postojeće podatke iz G4/G5 i pritisnuti tipku "..." što će omogučiti izbor mape (direktorija) GeoMIR4 predmeta.

Pritiskom na OK izvršit će se preuzimanje zajedničkih podataka poput tema kodiranja, korisničkih formata zapisa, zajedničkih koordinata točaka geodetske osnove te predložaka za teme kodiranja. Predmeti neće biti prebačeni! Nakon izvršenja prebacivanja, potrebno je zatvoriti te ponovno pokrenuti GeoMIR5.

Ako je potrebno prebaciti pojedini predmet u GeoMIR5, potrebno je isti unutar programa GeoMIR4 pohraniti (Formular predmeti, pohraniti predmet(e)), te tako dobivenu G4Z datoteku učitati u GeoMIR5 (Formular predmeti , Importirati predmet(e)).


Zaključak

Autor programa i nosilac autorskih prava:

Miroslav Mareković

Najnovije o GeoMIR programskim rješenjima na službenim internet stranicama .